#1 Edited by crusader8463 (14422 posts) -

Trying to get a feel for how many people this is happening to. The timer just rolled over saying I can install the game but as soon as I click download it just downloads the above mentioned then says it's fully installed. When I try to run it there's' no special launcher to update further. Nothing happens. Anyone else getting this? When I tried to download it the first time it errored out but every time since then this has been happening.

Steps so far with no fix:

  • Refreshed games library.
  • Verified the install.
  • Redownloaded the game.
  • Restarted PC and origin several times.
  • Switched from my E drive as the default install back to using my C drive instead.

Not sure if it's relevant or not, but I bought the game from Greenman Gaming and every time I try to log into origin it says I'm logged in elsewhere and that I need to force log in. Never had any problem with Steam keys from GMG, but this is my first Origin game. Nothing but a mess so far.

Update: So apparently this file is supposed to launch a little launcher window that updates the game further, but it will never launch. I tried going into the installation directory and launching it from in there but when I do it gives an error saying that Origin is not installed and to install it. Going to try removing all instances of Origin from my PC that I can and doing a fresh install.

#2 Edited by crusader8463 (14422 posts) -

Turned out I had to uninstall Origin and reinstall the whole thing plus the game before it worked. Joy oh joys.