#1 Posted by mrmovat (23 posts) -

Okay.  So. 
I am not the best with computers and I seem to have gotten myself into a pickle.  Steam for whatever reason was having problems connecting to the internet so I said fuck it I'll put it in offline mode.  Then I try to start Civilization 4 and it says it needs to update and it can't update in offline mode.  There is no visible menu that would allow me to get back online.  It seems like a problem with a very simple solution that I am just too dumb to find so if you wouldn't mind giantbomb community, do me a solid and help me out.  
Please.

#2 Posted by eroticfishcake (7783 posts) -

Have you tried restarting Steam at least?

#3 Posted by Rockdalf (1275 posts) -

Mine has done that before.  You should restart your computer completely.  Worked for me.

#4 Posted by CaptainMax (218 posts) -

Im having this exact same problem! I havent been able to use steam or play steam games for weeks. I don't know what to do :(.

#5 Posted by sagesebas (2003 posts) -
@mrmovat: geez just restart it
#6 Posted by CaptainMax (218 posts) -
@sagesebas:


What do you mean by restart? Do you mean reinstall or just close steam and open it again? Iv tried both and still no luck.

#7 Posted by sagesebas (2003 posts) -
@CaptainMax: I mean quit out of it, then open it, restarting means to shut something off, the start it back up
#8 Posted by Bobdaman18 (700 posts) -
@CaptainMax:
Try clicking on the steam tab of your steam client, selecting switch user (this logs you out), then restart your computer, then start steam, you should be asked to log in again and if you have internet it should put you online.
#9 Posted by CaptainMax (218 posts) -

Im also having another problem with steam. Everything is in russian. Can anyone help me with that? Its hard to find were the language options are.

#10 Posted by KaosAngel (13765 posts) -

Are you connected to the internet?

#11 Posted by Noodles (539 posts) -
@KaosAngel said:
" Are you connected to the internet? "
How would he be able to post if he wasn't?
#12 Posted by KaosAngel (13765 posts) -
@Noodles said:
" @KaosAngel said:
" Are you connected to the internet? "
How would he be able to post if he wasn't? "

Fuckin' Internet, How Does That Work? 
#13 Edited by 44gambit44 (1 posts) -

In Finder, go to Users -> Your Account -> Library -> Application Support -> and then locate Registry.vdf and open it with TextEdit.

In the Registry.vdf file, find the word "Offline" "1" and then replace 1 with 0 and save it. That's it, you should be able to open Steam now, that's how I fixed mine.

#14 Posted by SexyToad (2760 posts) -

In Finder, go to Users -> Your Account -> Library -> Application Support -> and then locate Registry.vdf and open it with TextEdit.

In the Registry.vdf file, find the word "Offline" "1" and then replace 1 with 0 and save it. That's it, you should be able to open Steam now, that's how I fixed mine.

This probably would have helped, if the OP posted this today. Check the date, this was 2 years ago.

#15 Posted by Zazu (1 posts) -
#16 Posted by SexyToad (2760 posts) -

@zazu: I guess I was wrong :P

Thanks for correcting me :P

#17 Posted by JoshuaNaismith (1 posts) -

It is so easy to fix,click steam in the top left corner of the application and click go online also if you would like to change the language back to english go to steam (top left corner) then click settings then interface or the third tab and change the language with the drop down menu there you go :D

#18 Posted by Dearblast (1 posts) -

wow, we are dumbasses, just mouse over steam and click go online XD

#19 Posted by fleabeard (175 posts) -

August 8th, 2013 - Steam Client Beta Update - August 8th We have just updated the beta, with the following changes:
- fixed cases where the client could become stuck in Offline Mode