#1 Edited by Rmack (1078 posts) -

I have a reasonable computer over here--just played through all of Crysis 3 on it with no issues--yet it seems to sound like a turbine whenever I play Trackmania. It runs and sounds fine, but I feel like it's breaking my computer. Has anyone else experienced this?

#2 Edited by Trace (3574 posts) -

I haven't experienced anything catastrophic with Trackmania 2, but I've had two older computers die on me due to hardware failure while playing previous Trackmania titles. It does spin the fans on my computer to a feverish pitch, though.

The causes might have been unrelated to the game itself, but I certainly don't think Trackmania is efficient with resources.

Moderator
#3 Posted by Rmack (1078 posts) -

Weird. I remember something similar happened with Legend of Grimrock. Forcing vsync stopped the issue, but I don't know how to do that here.

#4 Posted by Bollard (5663 posts) -

Hmm, I never seem to have a problem but I do remember my GPU fan sounding louder than usual recently, and I think that was during TM2: Stadium. You might be on to something.

Online
#5 Posted by Tylea002 (2295 posts) -

I bought the game, and I checked the fans immediately after playing, and everything seemed fine... but now I'm liable to never play it again for fear of overheating!

#6 Posted by Atwa (622 posts) -

There is a Vsync option, start settings when launching. Configure>Advanced> Comparability.

#7 Posted by Fattony12000 (7527 posts) -

143 frames per second over here, no vsync. I WANT ALL DAT FRAMES.

#8 Posted by Mister_V (1375 posts) -

Hmmm never thought of Trackmania as a resource hog.

Online
#9 Edited by Szlifier (496 posts) -

Vsync should be turned on, turn reflections to low. The game will run smoother and limit frames to 60, therefore it won't have to generate useless frames, no power wasted.

#10 Posted by Spam101 (143 posts) -

pretty sure it made my GPU overheat yesterday. I ended up with a lined screen, couldn't tab out, then the computer shut itself down.

#11 Edited by audioBusting (1623 posts) -

You can turn Vsync on through your graphics card control panel too (both Nvidia and ATI have their own). I keep it always turned on since Sims 3 ran at 800 FPS and crashed my laptop a couple of times. It fortunately works for Trackmania before I even realize that was a problem.