Reports from the Beta Front

  • 191 results
  • 1
  • 2
  • 3
  • 4
#1 Edited by Seppli (10251 posts) -

How you doing. Where you at. What's happening. Share your stories.

Just done creating a male Norn Warrior on Elona's Reach. Now stuck on a black screen after the introductory movie with an inactive 'Skip' button. Good times.

#2 Posted by TehJedicake (889 posts) -

"Unable to complete operation" when trying to pick a server.

I feel for them, they're probably getting hammered by hundreds of thousands of players.

#3 Posted by Xeirus (1305 posts) -

I almost bought it to get in, then I realized what was going to happen :P

I'll be patient, as hard as that is.

#4 Posted by Cake (211 posts) -

Picked a server, logged me out, been getting different errors for the last hour or so.

So... yeah.

#5 Posted by Rhaknar (5939 posts) -

played fior about 15minutes, got booted off, cant login. awesome

#6 Posted by Mustachio (242 posts) -

Got in early but the performance is terrible. Loads of people reporting 10-20 FPS and I'm one of them. Granted, my computer isn't amazing, but it's clear from what they've said and what others have commented that it should be getting improved before launch. If not then I'm screwed.

#7 Posted by Seppli (10251 posts) -

Official forums are down too. I guess we are in for a LOOONG night, before this thing gets of the ground in earnest.

#8 Posted by Liber (648 posts) -

The game tells me to check my internet connection ... what if I am really not connected ? :O

#9 Posted by Seppli (10251 posts) -

Their twitter says to keep trying. Keep trying I shall. Wish me luck.

#10 Posted by Kri0s (86 posts) -

Keep getting "Unable to complete operation. Try again in a few minutes" :(

#11 Posted by Gravier251 (217 posts) -

got on for about 10 minutes towards the start, since then just been getting errors though. Sometimes get as far as the character selection/creation screen, but that is it so can't really comment on it much.

#12 Posted by Cake (211 posts) -

Got a new one; "Transaction in progress. Please wait a few minutes and try again."

What transaction?

#13 Posted by Bollard (5555 posts) -

@Cake: Sounds scary.

#14 Posted by Hugh_Jazz (352 posts) -

@Cake: They're taking your money.

#15 Posted by Maystack (906 posts) -

Been playing for about an hour and half. Made a human ranger. Played some PvE and PvP. Game's fucking fun.

#16 Posted by Cake (211 posts) -

@Hugh_Jazz said:

@Cake: They're taking your money.

Joke's on them, I don't have any money.

Man, even the Diablo 3 open beta worked better than this.

#17 Posted by Hugh_Jazz (352 posts) -

@Maystack said:

Been playing for about an hour and half. Made a human ranger. Played some PvE and PvP. Game's fucking fun.

Fuck you. Sorry. I want to play too.

It's interesting how I'm getting different error codes when trying to log in. I think I've seen three different ones at this point.

#18 Edited by Seppli (10251 posts) -

@Cake said:

Got a new one; "Transaction in progress. Please wait a few minutes and try again."

What transaction?

Likely if you went on an American server with a European account (or vice versa). That's normal and should be done with in a couple of minutes.

#19 Posted by wemibelec90 (1672 posts) -

Played for about 30 min before all the people started to annoy me. Kinda crazy how populated my Low pop server is in the middle of the day...

#20 Posted by Seppli (10251 posts) -

btw. everybody else also getting the message, that loginservers don't respond? Seems to me their login servers crashed. Didn't I predict that would happen? It's always the login servers. Always.

#21 Posted by Cake (211 posts) -

@Seppli said:

@Cake said:

Got a new one; "Transaction in progress. Please wait a few minutes and try again."

What transaction?

Likely if you went on an American server with a European account. That's normal and should be done with in a couple of minutes.

Was an hour and a half ago when I chose a server. And when I bought the game through them, I made sure to ask (3 times) if I have the US version or the EU version, they said US even though I'm from Israel, so I picked a US "world".

#22 Posted by Rhaknar (5939 posts) -

i hate to be "that" guy (here come the entitlement posts) but unlike the diablo 3, or tera, or old republic weekend betas, which were free, in this case we actually had to PAY (the full game) to get in, lets be honest, most of the people that fully paid for it was for the beta, otherwise whats the point, so this kinda blows extra hard.just venting i guess (also this seems to be mostly a EU servers problem, so extra-hooray for the usual EU-screwjob)

#23 Posted by Beaudacious (930 posts) -

Works perfect, guilds in the game : D

#24 Posted by Cake (211 posts) -

@Rhaknar said:

i hate to be "that" guy (here come the entitlement posts) but unlike the diablo 3, or tera, or old republic weekend betas, which were free, in this case we actually had to PAY (the full game) to get in, lets be honest, most of the people that fully paid for it was for the beta, otherwise whats the point, so this kinda blows extra hard.just venting i guess (also this seems to be mostly a EU servers problem, so extra-hooray for the usual EU-screwjob)

What's weird about it, is that unlike the Diablo 3 beta which was open, this one is just for pre-purchasers which means they roughly have an idea of how many people are gonna be logged in, and it still crapped out.

#25 Posted by Tearhead (2168 posts) -

Does anyone else have a shitty framerate? 'Cus mine sucks, even at the lowest settings.

#26 Edited by AURON570 (1674 posts) -

Still can't log in ='(

Decided to play some tf2, but then after playing a single round I remembered that the more 'mature' players don't log on until night time. So I stopped playing that. Maybe going to pass some time with vanilla GW.

#27 Posted by JustKamToo (684 posts) -

Can get passed the login page so I've given up for today.

#28 Posted by Rhaknar (5939 posts) -

@Tearhead said:

Does anyone else have a shitty framerate? 'Cus mine sucks, even at the lowest settings.

game is unoptimized most say. seems it ues mostly the CPU not the GPU. I have (well, had in the 15mins I managed to play) the same framerate with the lowest settings that I had with high settings (in the 20s)

#29 Posted by Seppli (10251 posts) -

Anybody currently playing out of Europe? If yes, on a European or American homeworld?

#30 Posted by Gravier251 (217 posts) -

yeah, my frame rate was a bit off. Apparently they have said that they haven't particularly optimised it at all yet, relies mostly on the CPU for everything so even high end systems might have some issues with it until they work on it.

#31 Posted by CornishRocker (397 posts) -

Yep, Brit here, loads of friends/guildies and I are having touble logging in, too.

#32 Posted by Xyber (292 posts) -

@Tearhead said:

Does anyone else have a shitty framerate? 'Cus mine sucks, even at the lowest settings.

Yep, I'm on a i5 2500k overclocked to 4,6GHz and still only got 25-ish FPS in less crowded areas (down to 10 by the windmill outside the human city). This game can't be that CPU intensive.

@Seppli said:

Anybody currently playing out of Europe? If yes, on a European or American homeworld?

Yes, playing from sweden and are playing on the guilds US homeworld just fine.

#33 Posted by Sooty (8082 posts) -

I'm still downloading as I only decided to pre-purchase an hour or so ago, nearly done. Hope it's up soon!

#34 Posted by Rhaknar (5939 posts) -

finally got to the character select screen, only for it to crap out there... yay

Seems its pretty much official that its only for EU servers

#35 Edited by gike987 (1755 posts) -

@Xyber said:

@Tearhead said:

Does anyone else have a shitty framerate? 'Cus mine sucks, even at the lowest settings.

Yep, I'm on a i5 2500k overclocked to 4,6GHz and still only got 25-ish FPS in less crowded areas (down to 10 by the windmill outside the human city). This game can't be that CPU intensive.

@Seppli said:

Anybody currently playing out of Europe? If yes, on a European or American homeworld?

Yes, playing from sweden and are playing on the guilds US homeworld just fine.

The game is bottlenecked CPU bound right now.It's entierly CPU bound and doesn't take advantage of your CPU properly. I also remember them saying there could be perforamce problems if you overclocked. Did nobody read the Known issues post on their forums?

#36 Posted by WinterSnowblind (7617 posts) -

I'm in the UK, playing on US servers with a fairly average computer and it's running perfectly for me. 60fps (most of the time) and no lag.. Although I was quick logging in, seems those who got in later are having a lot of problems.

I've been playing the game for a few hours now, as a guardian and I can certainly say the game does not disappoint, I'm having an absolute blast with it. I do have one or two minor complaints, but I think that's mainly because of it's still in beta. The population is a bit crazy at the moment too, even the basic starting events are completely ridiculous with the amount of people taking part, but since everyone is working together, it promotes a really friendly atmosphere.. unlike say, Old Republic, where it took 5 minutes before I got frustrated by others killing targets I needed.

Oh, and the game is beautiful. I take back anything I may have said about the graphics not being on par with TERA. This easily looks better.

#37 Posted by gike987 (1755 posts) -

I got disconnected when the beta started and have been unable to login since.

#38 Posted by eldiax (632 posts) -

Still can't login.

#39 Posted by Hugh_Jazz (352 posts) -

I got through character creation and the story intro. No more than that, though. Maybe I should've checked if the choice of server made now is definitive also for the actual release. Anyone got info on that?

#40 Posted by Rhaknar (5939 posts) -

@Hugh_Jazz said:

I got through character creation and the story intro. No more than that, though. Maybe I should've checked if the choice of server made now is definitive also for the actual release. Anyone got info on that?

its not

#41 Posted by Seppli (10251 posts) -

Got to the char selection screen again. Crapped out on me again. Guess the luck of getting two consecutive mouseclicks through to their backend isn't likely gonna happen just now. Guess I'll watch a movie and revisit GW2 later.

#42 Posted by D_W (1163 posts) -

Other then the issues I had with pre-purchasing from gamestop I haven't encountered any major issues. I've been skipping the story bits and most just exploring. I'm playing an elementalist and mainly been using water. 
My major complaint is that you can't seem to bind something to "Shift+1" and I find having the stances (or whatever you call them) bound to the function keys is kind of a pain in the ass. 
 
Also Rabbits have the best death animation.

#43 Posted by Dark_Lord_Spam (3308 posts) -

I got in for about an hour and a half, was about two steps from taking an Asura Gate to LA, and then the server shunted me out. Worst timing ever.

My performance is fucking abysmal, but then I didn't expect any better given how terribad my PC is. Sounds like you folks with decent computers are way more disappointed. Silver linings, I guess?

#44 Posted by Adamsons (877 posts) -

Played thief til lvl 7, took about two hours. Most of the events ended in a massive zerg, with aoe being tunneled at piles of enemies. Also killed a dredge boss in a mine with about 30 people, which involved ranged auto attacking him. Negatives aside, the world seems pretty thick with content, the dye interface for armor is pretty sublime and the animations are better than expected.

Performance is terrible as is latency, but it is hardly worth mentioning really.

#45 Posted by Cake (211 posts) -

Ah fuck this, 3 hours of trying to log in is enough, I give up. Gonna try tomorrow.

#46 Posted by gike987 (1755 posts) -

I got in for awhile but now I'm unable to connect again.

#47 Posted by megaplushie (204 posts) -

I died. That's the latest from the Beta Front. Back to you at the login screen!

#48 Posted by Ragnarok512 (161 posts) -

Played for about 2 hours on my engineer. Having a great time so far.

#49 Posted by akzo (64 posts) -

I logged in at 2:45 est (I think that's 15 minutes before the beta was supposed to begin). It's very playable but my framerate was poor. Went into an instanced event and when I zoned back to the server (Yak's Bend) it said it was full and put me in an overflow server. I didn't know it was going to be used that way.

Not a lot of direction in the early going. Tutorial's are lacking and they just throw you in. The dynamic events are very much like the public quest in WAR (not a bad thing), the framerate and glut of people didn't help I'm sure. It's going to take a while to get used to the interface, but overall first impression was positive. I can see it becoming great as I progress and learn more about the game.

Good luck to everyone.

#50 Posted by MrMazz (981 posts) -

I've been playing since about 11:15 pst It finally crapped out on me I lost connection it said wait a bit so now I am here.

I'm only level 7 but I feel kinda bad ass already. I like the dynamic events that are going on but the end one by this lake has been a bit chaotic. I spent most of the time just reviving people as we took out this Shaman fellow who is really strong. I think we had about 20-30 people just in this area all trying to do the samething (take out the Shaman) but it was just CHAOS. I'm not sure if this is how things will be later on or if its just it being new.

The lack of regular quests makes me just wander around and do events which is fun but at the sametime I don't feel like I have a purpose.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.