anyone else have this drum problem??

#1 Posted by CreamyGoodness (1086 posts) -

so suddenly one day im playing and my yellow symbol doesn't register, i try everything, restart, unplug, change stuff, re sync. nothing. But i got it to register, the only problem is i have to whack the shit out of it for it to register. anyone else have this happen or any help on this situation.

#2 Edited by jakob187 (21735 posts) -

That's called poorly made hardware.  Just surf the Guitar Hero World Tour forums for about five minutes and you'll see what I mean.  =  /

My advice?  If you seriously want to have a good set of drums that will last for a while, invest in an Ion Drum Rocker set.  It's backward compatible with World Tour and the Rock Bands, but moreover, it's a very sturdy and pretty setup.  You've got four pads, three cymbals, all heavy duty that can take a beating, and each pad is velocity-sensitive to two different levels.

Only bitch is that the set costs, like, $300.
#3 Posted by Bonesofwar (262 posts) -

CYMBAL IS NOT SPELLED CYMBOL. kay?

#4 Posted by CreamyGoodness (1086 posts) -
Bonesofwar said:
"CYMBAL IS NOT SPELLED CYMBOL. kay?"
kay???
#5 Posted by Southgrove (323 posts) -

Get a USB to Midi interface for your drums and fix their sensitivity through a PC! =)
http://tinyurl.com/ckbgty << Red Octane will give you one for free.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.