I'm losing my patience very fast.

#1 Posted by kishinfoulux (2255 posts) -

Okay so here's the thing. Just go the game in the mail from Amazon. I immediately pop in disc 1 to install it to my 360. It gets to around 50% and then says "Error disc may be dirty or damaged. Please try to clean and attempt again" or something like that. I take out the disc and it's in PERFECT condition. I attempt to install again...gets to around 48% this time. Same message. I'm starting to get pretty aggravated, but just say "fuck it" I just won't bother installing it. I proceed to put in disc 2 so I can install the multiplayer portion at least. That worked fine. I switch back to disc 1 and just go right into the game. I go into Campaign and the intro movie plays out. Afterwards it seemingly begins to load what comes next, except I just get taken back to the main menu. I immediately think "hmmm...that's kind of weird". I go back to Campaign and do it again. I have to SIT THROUGH THE WHOLE MOVIE AGAIN!!! Why oh why can't I skip this shit? (but that's a separate issue altogether).

So I patiently wait...and nothing. I get sent back to the main menu. My anger is rising. So I try to go into the chapter select and manually select what comes next. I pick it and try to load it up. The game then says "one of the players doesn't have the DLC needed" or some dumb shit. I'm playing solo. There was a patch that was installed when I first put in the disc so I should be up to date. I have no idea what's going on and I'm seriously about to throw the disc out the window. I know it's a long shot, but does anyone here have any idea what's going on? Also I am connected to Xbox Live, if that matters.

#2 Posted by Barrock (3525 posts) -

I'd say clear you're cache and give it another shot. If that doesn't work you might have a bad disc.

#3 Posted by Vinny_Says (5686 posts) -

I feel like you could have just summed all that up with tweet

#4 Posted by kishinfoulux (2255 posts) -

@Barrock said:

I'd say clear you're cache and give it another shot. If that doesn't work you might have a bad disc.

I just tried cleaning it, but it's seriously in fine condition. The exact message it says is "Players failed to load content. A player may be missing downloadable content". I'm the only player.

Gonna try what you said. Doubt it will work, but I have no other options at this point.

#5 Posted by Barrock (3525 posts) -

@kishinfoulux said:

@Barrock said:

I'd say clear you're cache and give it another shot. If that doesn't work you might have a bad disc.

I just tried cleaning it, but it's seriously in fine condition. The exact message it says is "Players failed to load content. A player may be missing downloadable content". I'm the only player.

Gonna try what you said. Doubt it will work, but I have no other options at this point.

The disc is probably in perfect condition. It's just a problem with the data on the disc.

But yeah, I'd clear your cache and delete any Halo 4 data from your 360 and then go back in fresh.

The good thing is Amazon is usually pretty good about replacing games.

#6 Posted by kishinfoulux (2255 posts) -

@Barrock said:

@kishinfoulux said:

@Barrock said:

I'd say clear you're cache and give it another shot. If that doesn't work you might have a bad disc.

I just tried cleaning it, but it's seriously in fine condition. The exact message it says is "Players failed to load content. A player may be missing downloadable content". I'm the only player.

Gonna try what you said. Doubt it will work, but I have no other options at this point.

The disc is probably in perfect condition. It's just a problem with the data on the disc.

But yeah, I'd clear your cache and delete any Halo 4 data from your 360 and then go back in fresh.

The good thing is Amazon is usually pretty good about replacing games.

Well I just cleared it and it's actually loading up the mission right now surprisingly...oh wait nevermind. It got to like 89% and just gives the same message again.

So I should try and delete the mutliplayer stuff too you're saying?

#7 Posted by Barrock (3525 posts) -

@kishinfoulux said:

@Barrock said:

@kishinfoulux said:

@Barrock said:

I'd say clear you're cache and give it another shot. If that doesn't work you might have a bad disc.

I just tried cleaning it, but it's seriously in fine condition. The exact message it says is "Players failed to load content. A player may be missing downloadable content". I'm the only player.

Gonna try what you said. Doubt it will work, but I have no other options at this point.

The disc is probably in perfect condition. It's just a problem with the data on the disc.

But yeah, I'd clear your cache and delete any Halo 4 data from your 360 and then go back in fresh.

The good thing is Amazon is usually pretty good about replacing games.

Well I just cleared it and it's actually loading up the mission right now surprisingly...oh wait nevermind. It got to like 89% and just gives the same message again.

So I should try and delete the mutliplayer stuff too you're saying?

I mean it's worth a shot. I really don't know why the multiplayer stuff would effect the first disc. Man... 89% that blows.

#8 Posted by kishinfoulux (2255 posts) -

@Barrock said:

@kishinfoulux said:

@Barrock said:

@kishinfoulux said:

@Barrock said:

I'd say clear you're cache and give it another shot. If that doesn't work you might have a bad disc.

I just tried cleaning it, but it's seriously in fine condition. The exact message it says is "Players failed to load content. A player may be missing downloadable content". I'm the only player.

Gonna try what you said. Doubt it will work, but I have no other options at this point.

The disc is probably in perfect condition. It's just a problem with the data on the disc.

But yeah, I'd clear your cache and delete any Halo 4 data from your 360 and then go back in fresh.

The good thing is Amazon is usually pretty good about replacing games.

Well I just cleared it and it's actually loading up the mission right now surprisingly...oh wait nevermind. It got to like 89% and just gives the same message again.

So I should try and delete the mutliplayer stuff too you're saying?

I mean it's worth a shot. I really don't know why the multiplayer stuff would effect the first disc. Man... 89% that blows.

I keep thinking if there is anything online related that's affecting me. I know my Gold was just renewed a month ago or so...that can't be it. I'm definitely online. The one odd thing I notice though is when I go to check out my Network Status it says "NAT Rating: STRICT" and the text says "You might not be able to join games or hear other players. Matchmaking times may be affected". No clue what that is, but doesn't seem good.

#9 Edited by MideonNViscera (2257 posts) -

@kishinfoulux said:

@Barrock said:

@kishinfoulux said:

@Barrock said:

@kishinfoulux said:

@Barrock said:

I'd say clear you're cache and give it another shot. If that doesn't work you might have a bad disc.

I just tried cleaning it, but it's seriously in fine condition. The exact message it says is "Players failed to load content. A player may be missing downloadable content". I'm the only player.

Gonna try what you said. Doubt it will work, but I have no other options at this point.

The disc is probably in perfect condition. It's just a problem with the data on the disc.

But yeah, I'd clear your cache and delete any Halo 4 data from your 360 and then go back in fresh.

The good thing is Amazon is usually pretty good about replacing games.

Well I just cleared it and it's actually loading up the mission right now surprisingly...oh wait nevermind. It got to like 89% and just gives the same message again.

So I should try and delete the mutliplayer stuff too you're saying?

I mean it's worth a shot. I really don't know why the multiplayer stuff would effect the first disc. Man... 89% that blows.

I keep thinking if there is anything online related that's affecting me. I know my Gold was just renewed a month ago or so...that can't be it. I'm definitely online. The one odd thing I notice though is when I go to check out my Network Status it says "NAT Rating: STRICT" and the text says "You might not be able to join games or hear other players. Matchmaking times may be affected". No clue what that is, but doesn't seem good.

That just means you should set your router to open NAT. Shouldn't have anything to do with your problem though. Here's a NAT opening link anyway for future reference.http://news.softpedia.com/news/Guide-to-Opening-NAT-Xbox-360-71775.shtml

#10 Edited by Barrock (3525 posts) -

@kishinfoulux said:

@Barrock said:

@kishinfoulux said:

@Barrock said:

@kishinfoulux said:

@Barrock said:

I'd say clear you're cache and give it another shot. If that doesn't work you might have a bad disc.

I just tried cleaning it, but it's seriously in fine condition. The exact message it says is "Players failed to load content. A player may be missing downloadable content". I'm the only player.

Gonna try what you said. Doubt it will work, but I have no other options at this point.

The disc is probably in perfect condition. It's just a problem with the data on the disc.

But yeah, I'd clear your cache and delete any Halo 4 data from your 360 and then go back in fresh.

The good thing is Amazon is usually pretty good about replacing games.

Well I just cleared it and it's actually loading up the mission right now surprisingly...oh wait nevermind. It got to like 89% and just gives the same message again.

So I should try and delete the mutliplayer stuff too you're saying?

I mean it's worth a shot. I really don't know why the multiplayer stuff would effect the first disc. Man... 89% that blows.

I keep thinking if there is anything online related that's affecting me. I know my Gold was just renewed a month ago or so...that can't be it. I'm definitely online. The one odd thing I notice though is when I go to check out my Network Status it says "NAT Rating: STRICT" and the text says "You might not be able to join games or hear other players. Matchmaking times may be affected". No clue what that is, but doesn't seem good.

The Nat rating will just effect the online games you join. It's based on a router setting.

Give this a read,

http://forums.xbox.com/xbox_forums/xbox_support/f/3145/t/377372.aspx

#11 Posted by mtcantor (947 posts) -

Could be worse. Could be actually playing Halo 4. Count your blessings.

#12 Posted by Baillie (4039 posts) -

Uh, it's pretty obvious you have a defective disc. Get a replacement.

#13 Posted by kishinfoulux (2255 posts) -

Just tried out multi for the hell of it to see if that even functions. Seems fine. Found players, got into a match, played for a few minutes just to test it out. Seems perfectly okay. So the problem is just the campaign then it seems. Guess I'll have to return this to Amazon or whatever. I'm pissed because I've used Amazon for so damn long and never had this issue. Never had to return anything to them, but I guess there's a first time for everything. I'm wondering if it would be possible to try and trade it in at a Gamestop for a new copy and say I bought it there, but I'm guessing that won't work.

#14 Posted by Barrock (3525 posts) -

@kishinfoulux said:

Just tried out multi for the hell of it to see if that even functions. Seems fine. Found players, got into a match, played for a few minutes just to test it out. Seems perfectly okay. So the problem is just the campaign then it seems. Guess I'll have to return this to Amazon or whatever. I'm pissed because I've used Amazon for so damn long and never had this issue. Never had to return anything to them, but I guess there's a first time for everything. I'm wondering if it would be possible to try and trade it in at a Gamestop for a new copy and say I bought it there, but I'm guessing that won't work.

Make sure you try clearing your cache before you return it. That thread I linked you to had a guy complaining of your exact issue where it would mess up at 89%.

#15 Posted by kishinfoulux (2255 posts) -

@Barrock said:

@kishinfoulux said:

Just tried out multi for the hell of it to see if that even functions. Seems fine. Found players, got into a match, played for a few minutes just to test it out. Seems perfectly okay. So the problem is just the campaign then it seems. Guess I'll have to return this to Amazon or whatever. I'm pissed because I've used Amazon for so damn long and never had this issue. Never had to return anything to them, but I guess there's a first time for everything. I'm wondering if it would be possible to try and trade it in at a Gamestop for a new copy and say I bought it there, but I'm guessing that won't work.

Make sure you try clearing your cache before you return it. That thread I linked you to had a guy complaining of your exact issue where it would mess up at 89%.

Reading through that I wonder if this is a major issue or not. The cache clearing didn't seem to work. I'm tempted to try and ignore the update, but then I feel like that would only be a short term solution and could rear it's head again.

#16 Posted by Chontamenti (153 posts) -

@mtcantor said:

Could be worse. Could be actually playing Halo 4. Count your blessings.

..yeah I thought the same...

#17 Posted by Aleryn (703 posts) -

Sounds a lot like two 360s that died on me years back. The internals were fine but the DVD Drive stopped reading discs gradually, and the first signs of them going bad was the dirty disc errors.

#18 Posted by believer258 (11634 posts) -
@kishinfoulux

Just tried out multi for the hell of it to see if that even functions. Seems fine. Found players, got into a match, played for a few minutes just to test it out. Seems perfectly okay. So the problem is just the campaign then it seems. Guess I'll have to return this to Amazon or whatever. I'm pissed because I've used Amazon for so damn long and never had this issue. Never had to return anything to them, but I guess there's a first time for everything. I'm wondering if it would be possible to try and trade it in at a Gamestop for a new copy and say I bought it there, but I'm guessing that won't work.

Sometimes things go wrong, duder. It might not even be Amazin's fault, if the game is messed up then it might have happened at the facory or during shipping.
Just to make sure - has your disc drive been acting up at all lately? Maybe it's your XBox?
Online
#19 Posted by kishinfoulux (2255 posts) -

@Aleryn said:

Sounds a lot like two 360s that died on me years back. The internals were fine but the DVD Drive stopped reading discs gradually, and the first signs of them going bad was the dirty disc errors.

I hardly use my 360 anymore, but I hope that's not the case. :-/

#20 Posted by mshaw006 (539 posts) -

I had the exact same problem as you when I first put in the game. The game would randomly send me back to the main menu, and it wouldn't be able to load maps in multiplayer.

I cleared the cache, deleted all Halo 4 data from the HD, unplugged and plugged back in by HD, and started all over.

After that, it worked perfectly until yesterday (I got it at launch) when I beat level 6 on Heroic and was sent immediately back to the main menu with level 7 unlocked, but level 6 showing as unplayed. Pretty frustrating.

I'd clear the cache, delete all Halo 4 data, take out and put back the HD, and start over. That mostly did it for me. But, since the same thing happened to me, I think it might be a common issue with the game.

#21 Posted by kishinfoulux (2255 posts) -

Okay so this is odd...checked out those forums a bit and it definitely seems to be fairly widespread. Something perhaps a patch could fix. I popped in Dragon's Dogma just to test it and it worked fine. So I put Halo back in and...it actually loaded up to 100% and I got into the Campaign. I have no idea what to make of this. The game is trolling me at this point. I'm no expert, but definitely seems like maybe a patch could fix this. And others seem to think it's just random. Sometimes the game will load up and sometimes it won't. Problem is always with Disc 1, no matter how many times they've tried different 360's or trading the game back for a new one.

#22 Posted by TheHBK (5463 posts) -

Have you tried this on an Xbox that is not modded?

#23 Edited by CrazyBagMan (836 posts) -

Had some issues like this when i first got the game. Clearing my cache fixed it all entirely.

EDIT: Correction, clearing cache and deleting any data on my HDD that sowed as corrupted.

#24 Posted by big_jon (5709 posts) -

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.