The Legends of Aethereus wiki last edited by peterpasinili007 on 09/30/13 12:45AM View full history

System Requirements

PC

Minimum

  • OS: Windows XP, Windows Vista and Windows 7
  • Processor: Intel Core®2 Duo E6700 @ 2.6GHz or AMD Athlon64 X2 6000+ @ 3.0Ghz or better
  • Memory: 4 GB RAM
  • Graphics: 512MB Video RAM(1GB Video RAM), DirectX9c Shader Model 3.0
  • DirectX: Version 9.0c
  • Hard Drive: 3 GB available space
  • Sound Card: DirectX Compatible(Recommended Surround Sound 5.1 capable)
  • Additional Notes: Supported Video Cards: AMD Radeon™ HD 2900/3000/4000/5000/6000/7000 series, NVIDIA® GeForce® 8800GTX/9/200/400/500/600 series, INTEL HD 3000/4000. Laptop versions of these cards may work, but are not supported. These chipsets are the only ones that will run this game.

Recommended

  • OS: Windows 7 (64 bits)
  • Processor: Intel I5 or better
  • Memory: 4 GB RAM
  • Graphics: DirectX 9 compatible with 768MB video RAM or better(NVIDIA GeForce GTX 460 / ATIRadeon HD 5850)
  • DirectX: Version 9.0c
  • Hard Drive: 8 GB available space
  • Sound Card: DirectX Compatible (Recommended Surround Sound 5.1 capable)
  • Additional Notes: *Supported Video Cards at Time: AMD Radeon™ HD 2900/3000/4000/5000/6000/7000 series, NVIDIA® GeForce® 8800 GTX/9/200/400/500/600 series, INTEL HD 3000/4000. Laptop versions of these cards may work, but are not supported. These chipsets are the only ones that will run this game.

Mac

  • OS: Snow Leopard (10.6.X)
  • Processor: 2.3Ghz Intel
  • Memory: 4 GB RAM
  • Graphics: 512MB NVidia or ATI graphics card
  • Hard Drive: 3 GB available space
  • Additional Notes: Not recommended for Intel integrated graphics or Mac Minis or early-generation Mac Books (Intel HD 4000 will work)

Linux

Minimum

  • OS: Ubuntu 12.04
  • Processor: Intel Core®2 Duo E6700 @ 2.6GHz or AMD Athlon64 X2 6000+ @ 3.0Ghz or better
  • Memory: 4 GB RAM
  • Graphics: 512MB Video RAM(1GB Video RAM)
  • Hard Drive: 3 GB available space
  • Additional Notes: Supported Video Cards: AMD Radeon™ HD 2900/3000/4000/5000/6000/7000 series, NVIDIA® GeForce® 8800GTX/9/200/400/500/600 series, INTEL HD 3000/4000. Laptop versions of these cards may work, but are not supported. These chipsets are the only ones that will run this game.

Recommended

  • OS: Ubuntu 12.04
  • Processor: Intel I5 or better
  • Memory: 8 GB RAM
  • Graphics: Graphicscard with 768MB video RAM or better(NVIDIA GeForce GTX 460 / ATIRadeon HD 5850)
  • Hard Drive: 3 GB available space
  • Additional Notes: *Supported Video Cards at Time: AMD Radeon™ HD 2900/3000/4000/5000/6000/7000 series, NVIDIA® GeForce® 8800 GTX/9/200/400/500/600 series, INTEL HD 3000/4000. Laptop versions of these cards may work, but are not supported. These chipsets are the only ones that will run this game.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.