Anyone who bought the latest humble bundle...

#1 Edited by Jeust (11596 posts) -

is getting a black screen and the error that the program has stop working when launching Limbo?

I'm using Windows 7.

Do you know any fixes?

Update: apparently you have to install dx9 in Windows 7.

#2 Posted by Roland_D11 (196 posts) -

I remember having a similar problem when I bought it a few months back, but I can't recall the solution. Did you check the Steam forums? Usually you can find the solution there (even if you are not using the Steam version of Limbo).

#3 Posted by Jeust (11596 posts) -

Yeah, I've looked into it. Although nothing too consistent appeared as a solution.

#4 Posted by Talis12 (522 posts) -

update your directx.. seems to be the issue most users encountering the black screen

#5 Posted by Jeust (11596 posts) -
@sideshow said:

update your directx.. seems to be the issue most users encountering the black screen

yeah, I tried but there was an error at the end of the instalation of directx. ahah I'm going to try it again later on.
#6 Edited by effofexx (2 posts) -

I had the same problem as you Jeust and found a solution.

Go to the limbo.exe file in the game directory, right click and go to properties. Then go to the Compatibility tab and check the box that says "Run this program in compatibility mode for:", and select Windows 7 from the drop down box.

Click OK and try to run the game.

I know it seems strange that there is a Compatibility mode for Windows 7 in Windows 7; I was surprised to see it as an option. But I'm not complaining, whatever gets this game working. I hope that helps.

EDIT: Also, if you're using a shortcut to launch the game you'll have to make a new shortcut after the change or make the same change to your existing shortcut icon.

#7 Posted by peebeeb (3 posts) -

I had the same issue which drove me ape and broke my heart because i'd bought the bundle primarily for Limbo and Bastion (lappy can't power Amnesia or Psychonauts and i've played S&S). Anyway I can only tell you what worked for me in the hopes that it might help someone else.

I'd tried every single suggestion; upgrading direct x (was already current), changing the monitor to single screen (already was), launching in compatibility mode for windows 7 (I have windows 7 so no compatibility for windows 7 was available). After all that I updated my driver and still had no luck so in a final desperate attempt I uninstalled the game and re-installed it... and it worked. Simple as that.

So try uninstalling the game (if you haven't already), I performed an extensive removal with revo uninstaller. When you re-install launch the game right away when it prompts you too, this is what I did and I can't say whether it made a difference or not - but like I said it's working for me now.

Good luck

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.