Mass Effect 2 (PC) fix for long load times.

#1 Edited by crusader8463 (14428 posts) -

I just though I would share this with the community for those of you that are in the same boat I was in. On the PC version of Mass Effect 2 I was having problems with it taking anywhere from 60-120 seconds to load whenever I would transfer from deck to deck of the Normandy. Now I thought this was just how the game worked, but after searching around I found this fix, and my loads went form taking two minutes to less then 3 seconds. To say the least my mind was blown. I wish I knew about this before I spent about 30 hours putting up with these nightmarishly long load times.

Anyway, the reason you're here. The problem is with a bug in the unreal engine for those of you using dual core processors. The bug essentially multiples the load times by upwards of 10 times what it's supposed to be. To fix this simply do the following:

  1. Once you start the game alt tab back to the desktop.
  2. Go to your task manager ( ctrl +alt+ delete)
  3. Find "masseffect2.exe" in the processes list, then right click it and go to "Set Affinity...".
  4. Change it to one core, then click ok.
  5. Re-open it again and set it back to two.
  6. Congratulations, you just cut your load times to nothing! Sadly you will need to do this every time you start the game.

Hope this helps someone. I know my enjoyment of the game went through the roof after doing this fix.

#2 Posted by eroticfishcake (7790 posts) -

I remember KaosAngel mentioning this a while ago actually. What about quad cores?

Online
#3 Posted by crusader8463 (14428 posts) -
@eroticfishcake: Sorry I'm not sure. From what i have found it should only affect dual, but if you have a quad you can try it and see. I have an intel core 2 duo extreme so i cant test for compatibility with quads.
#4 Posted by eroticfishcake (7790 posts) -
@crusader8463: Hmm. Well I've only got a dual core myself and I was just curious about quad cores. It's going to be a while before I pick up this game and it might already be patched by the time I get it by cheers all the same. I'll keep this in mind if I run into any problems.
Online
#5 Posted by crusader8463 (14428 posts) -
@eroticfishcake: I'm not sure if they will patch it as i believe it to be a problem with the choice of engine itself, and not so much the game. Ether way it is honestly like night and day playing it now. I was honestly about to give up on playing it before i found this, as it was just dragging the game down because you tend to do a lot of changing levels on the Normandy. Anyway as i said in the OP hope others find this before they have a great game ruined by these technical problems. Perhaps a mod can sticky it?
#6 Posted by Korwin (3026 posts) -

Quads are fine, my i7 920 has been loading normally.  Shame that the fix for dual cores is the set the affinity to a single thread, that pretty much eliminates the multicore performance advantage (and unreal engine 3 laps up multi core systems).

#7 Posted by crusader8463 (14428 posts) -
@Korwin said:
" Quads are fine, my i7 920 has been loading normally.  Shame that the fix for dual cores is the set the affinity to a single thread, that pretty much eliminates the multicore performance advantage (and unreal engine 3 laps up multi core systems). "
It doesn't disable it, you just have to turn it off then back on.
#8 Posted by tasketaske (1 posts) -
@crusader8463: 
Man, I signed up to this site just to say thanks, I owe you a couple of hours of my life!
#9 Posted by FalconCritical (224 posts) -

Weird bug, my loading times have always been superfast, going up to the capn's cabin barely has time to show the loading screen before I'm there.

#10 Posted by Metal_Mills (3046 posts) -

My load times take 1-10 seconds. 15 for major areas.

#11 Posted by Darkstar614 (1098 posts) -

Seems to only affect certain people, regardless of dual core or not. Hopefully they patch whatever it is. I played half of my first playthrough with terrible load times until I found this fix via google.
 
And before everyone complains about disabling a core, you don't actually disable it permanently. You just flip it off, then back on for the process.

#12 Posted by King9999 (615 posts) -

Maybe someone here can answer this... 
 
I noticed that when you boot up the game in WIn XP, it loads up much faster than it does in Windows 7.  Does anyone know why that is?  It's not a major problem or anything, but it's something I noticed between the two OS's.

#13 Posted by FalconCritical (224 posts) -

I run it through Steam on Vista, so I can't really comment.  It's not super-fast to boot but not slow either.

#14 Posted by Dekan69 (1 posts) -

I like   tasketaske signed up for this website just to say thank you crusader8463.  I love you man.  I can't believe I played through the game once already without knowing how to reduce the load times.  I wish I had read this so much ealier.  My game literally loads 1000% faster.  Thank you.

#15 Edited by MrWizard6600 (18 posts) -

Its so easy to get multithreading right, or rather, its so easy to not get it wrong. How does a game released in 2010 (the fucking future) have problems with NT thread handling?
 
For anyone else out there, anything running WOW (thats windows-on-windows, a 16bit/pre NT (dos) emulator, not World of warcraft) like for example old pre win2000 games, if your having difficulty running the game, setting the affinity to core 0 alone will often help resolve problems. This is true for dues Ex and System Shock 2.

#16 Posted by clichekiller (1 posts) -

Chalk another person who signed up simply to thank you.  I was about ready to chuck the game out the window, my mouse and keyboard with it, the load times were so frustrating.  Thanks!!!

#17 Posted by tmarc (1 posts) -
@crusader8463: hey bro, do you know what to do if it restricts you to set  Mass Effect's affinity? because when i try to change mine, it denies me of access. My OS is windows vista ultimate. Can you help me on this one? thanks!
#18 Posted by Leptok (942 posts) -
@tmarc: 
Don't hate if this is stupid, but are you admin?
#19 Posted by crusader8463 (14428 posts) -
@tmarc: Sadly i cant say, I'm not a wiz on this kind of stuff. I just thought i would share the solution to a problem i had with the game here. I happened across the solution by mistake while i was googling to see if others had the same problem a day after the game came out; i found it buried deep within some techy site.
 
I would suggest trying to run the game as an admin ( right click the shortcut then select run as administrator) or running it in compatibility mode( right click the short cut and go into properties. Go to the compatibility tab and select XP.) Try the admin thing first, that usually solves most problems like this.
 
@tasketaske: @Dekan69: @clichekiller: Your Welcome. I played the game for about eight to ten hours before i too was about to break my mouse in half and throw it out an airlock. I'm just glad i found this solution as i would have hated to had missed the rest of such a great game.
#20 Posted by eksenee (1 posts) -

omg omg omg dude thank you for making this post. it worked and now i wont have to break my computer

#21 Edited by marcelo_20xx (7 posts) -

Well I had this problem also when my proccesor was a core2 duo, then I switched to a quad and the loading times were faster, never though the bad handling of affinity was the problem, but if you want to make the process automated there is a nice utility called MassAffinity or something, It set the affinity for you and then launch Mass Effect 2 replacing the necessity to alt tab and change the things for yourself. And I highly doubt this will be patched, It was reported on the official Mass Effect 2 Bioware forum before even the patch 1.02 came and it wasnt fixed.

#22 Posted by Boboblaw (329 posts) -

My load times for ME2 were always super quick, like 5-10 seconds max.
 
I  noticed it most in the normandy going floor to floor was insanely quick.

#23 Edited by marcelo_20xx (7 posts) -

As everyone said this bug only affected people who had dual core processors, quad owners never had this issue, and even if you had a very fast processor you are still restricted in load times cause the way the engine handles biks for loading. Lets say your processor is faster enough to stream the data like in 2 secs BUT the cinematic cant be skipped until they finish, this mean you had to wait like 10 secs more for the bik to end or 20 secs if you are unlucky if your processor stream the data in more than the default lenght of the movie, I think you get the idea. The workaround to this problem was to replace all the loading biks in the movie folders to a very short or custom bik with at least 3 secs of duration BOOM your load times are cut to the minimum if you have a very fast processor. You only need to keep the default load_f13m.bik or else your game will hang up when Joker takes control of the Normandy.

#24 Posted by charizardex2004 (1 posts) -

Hi. I came across this solution of yours and tried to implement it myself. The only problem is that when I right-click on the process, unlike everybody else I do not see the "Set Affinity" option. I use Windows XP and have Intel Core 2 Duo E7500.

Your help would be REALLY appreciated! Thanks!

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.