A required Windows component is disabled...GFWL error.

#1 Posted by Funzzo (835 posts) -

GFWL just stopped working today. I get an error when ever I try to run a game or use the marketplace."A required windows component is disabled in your system" it has a link to a pointless and unusable xbox help page. I cant play any of my GFWL games including dirt 3 that I just bought off steam. I have tried running services.msc and msconfig to make sure that the live ID thing is on and set to automatic also the BITS must be on and set to automatic. I have tried everything out there that I can think off I even tried calling support at microsoft which was pointless. Please help.

#2 Posted by myketuna (1710 posts) -
#3 Posted by Ravenlight (8040 posts) -

Have you tried restarting your computer yet to make sure there aren't any pending Windows updates mucking up the works?

It seems like every time I get a Windows-related error recently this has been the cause.

#4 Posted by Hunkulese (2745 posts) -

Re-install GFWL.

#5 Posted by ShadowSkill11 (1783 posts) -

Gfwl and it has an error? Shocking. The damn thing never did work right on my laptop. Arkham city, bio shock 2, bio shock 1 never update and have text issues.

#6 Posted by Demoskinos (14878 posts) -

Yuck. Best of luck dude. I read that thread that was posted and this seems like a nasty problem.

#7 Posted by Funzzo (835 posts) -

Ok so I found a way to fix the problem. I had to create a second admin user account in windows. When I use the second account GFWL works fine. Why it works I have no idea but o well. It sucks that Dark Souls will use this shitty "service" but I will still buy it. Thanks for the help everyone and if you have this problem try the second admin user account thing first it might work for you.

#8 Posted by turble (1 posts) -

Took Funzzo's advice and instead... Windows 7 users, right click the GFWL file from the start menu (or desktop, etc.) 'Run as Administrator'. Should work fine. I should have known that GFWL and Win 7 wouldn't be compatible without going through extra steps.

#9 Posted by booman0028 (2 posts) -

ok ive spent a long time on trying to figure it out and im almost positive ive found it. what you need to do is go to your user account settings and remove your password. i know it sounds stupid but it works, for some reason having a password messes it up

#10 Posted by Rawaan (1 posts) -

@booman0028 You are my hero. This was all i needed to do.

#11 Posted by coaxmetal (1623 posts) -

you would think they could have figured out gfwl by now. Its been a long time. But it's still broken as hell, it didn't work on windows 8 if it was installed with a game, I had to uninstall that version and re-install it from the standalone installer, but then it couldn't handle my network, and I got mysterios unclear errors withe error codes, and exposing the raw underlying exception for some reason. Turns out that was because it sucks at upnp and couldn't open the like 17 ports it needs. -

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.