ATX 24 pin power plug is loose in the motherboard

#1 Posted by Eric_Buck (1289 posts) -

My PSU and motherboard are brand new, but the 24 pin plug from the PSU is really loose in the motherboard. Like if I nudge it it falls off.

There is a pin missing on the plug from the PSU that is not missing on the motherboard so could that be a problem? This is frustrating.

#2 Edited by EXTomar (4687 posts) -

The power supply connector is supposed to have a hook which latches onto the connector on the motherboard connection. Or are you saying the PSU is modular and the connection from it loose?

#3 Posted by Kidavenger (3534 posts) -

There shouldn't be any missing pins on the plug, but even a missing pin wouldn't make it loose, everyone one I've ever put in has been extremely tight, especially when new.

#4 Posted by Ravenlight (8040 posts) -

There shouldn't be any missing pins on the plug, but even a missing pin wouldn't make it loose, everyone one I've ever put in has been extremely tight, especially when new.

[Insert reference to boning here]

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.