GAMES STUTTERING

#1 Posted by pcmasterace (18 posts) -

most of the games im playing are having stuttering issues

i replaced the 660ti with the 770, still stuttering, i used every driver between 314.22 to 326.41

i defragmented the hard drive, that seemed to help, but now i just reformatted everything and reinstalled my OS (win7 64-bit), still stuttering in games, stuttering when a game is running on either my original hard drive, or this extra one i just installed

i tested both hard drives with HD-Tune and both came out just fine, including the error checking

i replaced the 8gb ddr3-1600 ram with 8gb ddr3-2400 and am still stuttering, and the ram has no errors

i tried all 3 ram slots that arent blocked by the "hyper212+ cpu cooler"

intel's official cpu tester didnt find any errors, ive been using prime95 and i dont see any issues

my internet isnt an issue at all, my ping isnt jumping around or anything, 30mb download 10mb upload

my power supply is 700w, all i have connected to my computer is a mouse, keyboard, and headset

my video card is at like 40 or 50 degrees and the hard drive is like 30-something degrees and the cpu is 30degrees idle, 40degrees in-game, 55degrees full load, and 65degrees max on prime95, the motherboard is like 30 or 40degrees

everything is plugged in nice and secure, i checked on that

everything is dust-free, i cleaned it all up deep

the air in the case isnt stuffy or anything, i got lots of positive air pressure in there

asrock z77 extreme4

660ti

700w 80+ bronze

1tb 7200rpm 110mb/s hdd

400gb 7200rpm 70mb/s hdd

2x4gb ddr3 1600

i5 3570k

#2 Posted by zenmastah (879 posts) -

Did you turn power profile to maximum performance on the Nvidia control panel?

#3 Posted by pcmasterace (18 posts) -

yes, that didnt help

#4 Posted by CannonGoose (372 posts) -

Are you running games with or without vsync?

#5 Posted by Forcen (1806 posts) -

Is your CPU fan loose? That happened to me once.

#6 Posted by ll_Exile_ll (1479 posts) -

I have on occasion had this issue, and have resolved in different ways. I was having extreme stuttering issues in Metro 2033 and Shootmania, and it turned out that the driver settings for my graphics card (under Nvidia Control Panel in windows control panel) were forcing v-sync off, regardless of what setting it was on in game. Fixing that fixed the issue.

I also ran into the issue in Skyrim, and was able to take care of it by running a windowed borderless mod (basically a mod that runs the game windowed but it looks like full screen because the window border is removed and the resolution is the native resolution of the monitor). I don't know why that fixed the issue but it did.

Hope that helps.

#7 Edited by pcmasterace (18 posts) -

running a game in windowed mode doesnt help, the stuttering is the same

#8 Edited by CannonGoose (372 posts) -

Stuttering is a strange beast with many, many possible fixes. I've solved it in the past by running games in a window, turning vsync off or on, using triple buffering in conjunction with vsync, capping the frame rate to 60, 58 or 30, changing the maximum pre-rendered frames in Nvidia Inspector to 1 or higher... or just waiting for a patch to come out like the one for Far Cry 3.

There are also some games that just hitch up every few moments, like the STALKER series for instance. Sleeping Dogs also stuttered a lot (though a few of the above fixes helped) and so did Far Cry 3 at launch.

#9 Posted by pcmasterace (18 posts) -

those arent affecting the results really except for blops2

but even with the v-sync dropping it to 30% gpu usage, i can still get rare stutters

#10 Edited by JJWeatherman (14557 posts) -

Use a frame rate limiter to lock your framerate at 60.

#11 Edited by pcmasterace (18 posts) -

i tried that and it didnt work

the problem wasnt solved

#12 Posted by VACkillers (1059 posts) -

What games you referring to that are stuttering? and is this every single game you have thats doing it? or just a select few? have you made sure the graphics card is firmly connect to the motherboard? did you try a proper uninstall of the nvidia drivers? (going into safe mode, properly removing everything) and then reinstalling them? are you using windows 8? did you check on the Nvidia forums see if this is a common issue with the GTX 770? I have several friends that bought the 760 and have had zero issues after several weeks of use! which could suggest a driver issue

#13 Posted by Shingatsu (44 posts) -

@forcen said:

Is your CPU fan loose? That happened to me once.

#14 Posted by pcmasterace (18 posts) -

the cpu fan is not loose, if it was, im sure my cpu would overheat

-call of duty black ops 2

-call of duty modern warfare 3

-call of duty modern warfare 2

-call of duty world at war

-borderlands 2

-payday 2

-the sims 3

the games i did not have ANY stuttering at all ever were

-bioshock infinite

-counter strike global offensive

#15 Posted by Devildoll (877 posts) -

@pcmasterace:

  • could you check what framerate you actually have?
  • have you tampered with the nvidia control panel? ( activating some insanely demanding AA setting for example )
  • what speed does your ram currently run at?
  • could you post the hd tune results?
  • what is your cpu and gpu usage like ingame?
#16 Edited by pcmasterace (18 posts) -

one of the ram sets was 2x4gb 1600mhz

the other was 2x4gb 2400mhz

#17 Posted by Devildoll (877 posts) -

gpu usage looks pretty good, ideally you'd want it to be a bit more locked att 100% unless you hit the framerate you desire.
what kind of monitor do you have? alot of those frames goes to waste, if lets say you have a 120 Hz monitor, you could lock the framerate at that through msi afterburner.

cpu seems to be pretty busy though, could be responsible for the slight dips in gpu usage.

The hard-drive curve is steady and decent, no dips down to 0, indicating that the harddrive is in okay health and not being choked by other applications.

controlpannel stuff seems to be in order, should probably leave ambient occlusion on auto though, and power management mode on the most aggressive setting.

one of the ram sets was 2x4gb 1600mhz

the other was 2x4gb 2400mhz

yeah, but did you actually run em at 2400 MHz, or did you just dump em in your computer, probably wasn't the cause for the stuttering, but its not so fun to buy something and have it running at half speed.

#18 Posted by pcmasterace (18 posts) -

every gpu usage drop was when the stutter occured, you can see how the frametime directly correlates with the gpu usage

i still have the usage drops in games that use much less cpu usage like 30% or something, blops2 is just the worst cpu optimized game in PC-gaming history

when i got "maximum performance" in nvidia control panel and restart my computer to confirm its in effect, i still have those stutters

i go into the bios and set the correct RAM speed, and the motherboard's "auto" voltage setting always matches whats on the sticker on the RAM sticks

#19 Posted by pcmasterace (18 posts) -

just to show you what happens with "maximum performance" in nvidia control panel, i still get the exact same results

i did restart the computer so the effect is confirmed to be in place

#20 Posted by VACkillers (1059 posts) -

It still could just simply be a driver problem. The driver I'm currently using at the moment is 306.97 but I am using an older GPU though. (GTX 560 ti)

The reason I'm using such an old driver at the moment is because of minecraft (yes minecraft) there is a shader mod called "SEUS UNBELIEVABLE SHADERS" which basically turns MC into a much more visual modern day game along with texture packs. Now, SEUS is using some advanced shading, and also recently added volumetric Clouds to the shader, and according to him, the newer "drivers" have some really bugged features which makes the shader only work on older drivers. Now he is a very good programmer and writes all his own code for the custom shader, now if the newer drivers are really that bugged with some of the more advanced feature sets and all these games are using them, this could be part of the reason why your performance is dipping all over the place, even with the 314.22 driver. The problem is that your GPU isn't officially supported until much much later, like the last 2 drivers that have been released, but you could give it a go anyway. Have you tried switching back to your 660ti recently? to see if its still a much smoother experience for you? Otherwise I only really see 2 last options for you, 1) wait for a new driver release from Nvidia see if that fixes anything or 2) RMA the Graphics Card back, there could be something actually wrong with it, and see if you hit the same shit with a replacement, you should still be in the warrenty and you have your other graphics card to use in the mean time. IT could something as simple as a dodgy memory buffer in the card thats causing your slow downs, who knows?

#21 Edited by OurSin_360 (838 posts) -

Did you fix the problem? If not, it could be your PSU not giving enough voltage. Bronze is good, but gold is better @ 700w and more i believe.

Did you run memtest on the ram for errors? I doubt both sets are bad though, but it could happen.

I have similar problems and i think it's either my ram or my psu, i just don't have any money to test the theory out lol.

#22 Posted by pcmasterace (18 posts) -

i still have the same issue in two different graphics card, so i dont think i need to RMA the 660ti

i didnt try memtest, but windows error checking didnt see a problem on the 2400mhz ram i just replaced the 1600 with

#23 Edited by VACkillers (1059 posts) -

@pcmasterace: no i mean RMA the new card you have, the 770, not the 660 you were using before, but if it happens with both cards, then most likely a driver issue, but do a memtest anyway... make sure you verify the integrity of your games, just noticed all your games are on steam? your steam might have got fucked up somehow

#24 Posted by pcmasterace (18 posts) -

idk i uninstalled and re-installed steam several times to test hard drives, and did complete formats on the hard drives and reformatted the operating system by re-installing it

im already using two different sets of ram, it cant be ram thats the issue

#25 Edited by Arabes (338 posts) -

@pcmasterace: Hey dude, I looked through the previous posts but didn't see it mentioned, are you using dual displays? I've had this issue when I had my displays duped on my TV and monitor. Even with the TV turned off, some games would stutter on the monitor while i had it set to duplicate screens. Might be worth checking if that is your set up.

#26 Edited by VACkillers (1059 posts) -

On a related note, it could also be the refresh rate of your monitor setup as well, make sure its all at its native refresh rate.

#27 Edited by pcmasterace (18 posts) -

its all at native refresh rate AND it doesnt do any weird 59.9hz or 60.01hz......... its a complete 60hz at default

its a single monitor

black ops 2 with v-sync doesnt show stuttering, but modernwarfare2 does

#28 Posted by VACkillers (1059 posts) -

that is definitely a driver issue then by the sounds of it.. its V-sync is affecting it any then you know its something to do with the graphics card/drivers for it pretty much. Disable adaptive V-sync.

#29 Posted by pcmasterace (18 posts) -

i hate using adaptive v-sync, thats been off

turning down all the settings in the games didnt help

i just found out that im getting crazy amount of microstutters in counterstrike:go where my game just seems to jump back to a previous frame

v-sync is on, the game microstutters every second with a frametime going from 17ms to 21ms like every second or two

the new new nvidia driver, 326.80 did not solve the issue

i notice that i get a massive stutter in counter strike : go

when i press the ESC [escape button] and that little menu comes up, but im still able to walk around while that options window comes up

a massive stutter, like the frametime graph reaches the top of the graph for like a full second seemingly while the gpu usage drops

#30 Edited by Rowr (5487 posts) -

Just to confirm, same problem running things stored on both hard drives?

I've had microstutter drama's in the past and traced it to the hard drive. Despite formatting, defragging and error checking etc (can't remember quite how thorough i was), I couldn't really find the exact problem, though it was definitely the HDD

If it's both though that seems extremely unlikely.

Dodgy power supply? That seems like the only thing you haven't switched out. Try a different power plug? I have no idea how power works.

Otherwise I guess the motherboard could have an issue.

#31 Posted by pcmasterace (18 posts) -

yes, same problem running things stored on both hard drives

ill replace the power supply in the afternoon, i never got to it because i did CRAZY wiring to make everything fit perfectly around the back on my pc case in that tiny 1.5cm of space

#32 Posted by pcmasterace (18 posts) -

okay, i just noticed that i stutter in counter strike global offensive when i do " vsync + laptop power saving"

which tremendously removed the input lag

this used to never make me stutter, it is just now, it makes me stutter every second

but when i play with ONLY Vsync and disable the other setting, i dont get any stuttering at all

#33 Edited by VACkillers (1059 posts) -

ok your confusing me a little, is this stuttering on a laptop? or a desktop machine? at the beginning I thought this was coming from a desktop machine but now your talking about a laptop? which you will nearly always get shoddy performance when running on any sort of power saving/battery saving options or on alienware (stealth mode). This is because it reduces things like the GPU/CPU to save battery life. Make sure you dont have any virus's or spyware, and disable any antivirus programs you might have installed also, the ususal stuff, just in case things like AVAST's sandbox is blocking the games from functioning properly, i've had a shit ton of issues with the new avast crap.

Did you try using a different monitor? did you try using a different connector to see if the same problem exists? example DVI / HDMI connections.

If on a desktop, go into control pannel and go into power options. From here click high-performance and and click on change plan settings and click "change advanced power settings" so a new window pops up. Go through all the settings and make sure all power saving options on things like CPU/Harddisk/PCI Express is not on some dodgy sleep mode or power saving mode. Maximize performance on everything. Its definitely something to do with vsync from the sounds of it though, whether changing it makes it worse or better, or that with other things enabled, its always something to do with that which affects it some how, you could always try reinstalling DirectX, reinstall PhysX, but think you'll be better off going to a much more technical website other then this. At the end of the day it could be so many things, something small or something large, could be just a windows update thats messed stuff up, hence why it still did it after a format? could be a motherboard issue where the north or southbridge is overheating? If you're doing any overclocking, even with just the default turbo on, there might not be enough voltage going through to the CPU/MEM under high load.... so i suggest perhaps going to places likes tomshardware to ask a bit more with the screenies you've posted here to show whats going on in graphs (thx for those btw) but im pretty much at a loss apart from what i just mentioned.....

Edit: 1 last thing, i know you said you didn't try memtest, because you put in other RAM and it did the same thing anyway, but did you try both sets of RAM in different slots? you might have a bad memory slot on your mobo.

#34 Edited by pcmasterace (18 posts) -

"laptop power saving" is just a setting in-game in cs:go that locks the framerate or something idk....... im using a desktop

i re-checked the power settings and everything is at performance settings

i tried a single stick of ram in each of the 3 ram slots that arent being blocked by the cpu cooler, and i still had the stuttering

#35 Edited by Lind_L_Taylor (3962 posts) -

Damn! I've never heard of anyone doing this much work & not seeing results before. Maybe you should try switching to Radeon & not use nVidia. Did you try lowering your resolution? I didn't see anyone mentioning that.

I've got a 5+ year old PC using Radeon & 8G RAM that runs low resolution most of the time, but it never stutters.

Perhaps the nVidia card you have & the mobo don't get along? smh.

#36 Edited by pcmasterace (18 posts) -

i swapped my video card with an even better one that works on another computer and i still have the issue

and the cards are vigorously inspected and are in the motherboard correctly, locked in and not bending

and i put the video card in a different pci slot

i think i still had that issue when i lowered my resolution, ill check again

#37 Posted by pcmasterace (18 posts) -

i just swapped my power supply and i still have the issue

i took out the 700w psu

and put in a 750w psu

and its still stuttering

#38 Posted by Devildoll (877 posts) -

@pcmasterace: looks like you have a solid 165 fps there with two dips down to slightly under, with a 60 hz screen, that shouldnt be noticable.

since it only shows 60 frames, and judging by that you have 60+ all the time.

if it is notecable enough for you to see it with the naked eye, do you think you could film it with a camera, or perhaps fraps?

#39 Posted by cloudnineboya (774 posts) -

This could be turning into a epic trollalalalalala

#40 Posted by Devildoll (877 posts) -
#41 Posted by Lind_L_Taylor (3962 posts) -

You must be cursed. If you've changed out every part & you still have the issue then it must be the mobo, CPU, or RAM. I don't see how the RAM could be a factor, so I'd start by replacing mobo/CPU. Be sure to read some reviews on the mono/CPU that you use with the video card that you want to use & see if anyone ran into any problems with it prior to purchasing. That's what I do. I read reviews, buy the stuff that people use that report successful results & have less to worry about. Although I've cobbled together gaming machines for the past 18 years with whatever hardware I could get & never saw the crap that you've seen.

#42 Edited by VACkillers (1059 posts) -

I dont see any issues with the last graph you posted as someone mentioned above, acording to that, you are running at just about perfect no major dips that are out of the ordinary what so ever. All graph lines are pretty steady through-out, no offense but maybe its just you? your seeing something that actually isn't there? If you've swapped out pretty much every single part of your machine, except your Mobo, well, there's your answer :D

#44 Posted by Ravenlight (8040 posts) -

Sounds like...

...ghost problems!

#46 Edited by kn00tcn (158 posts) -

what does wintimertester show?

what's your DPC look like when idling & in game during the stutters?

try this maybe EDIT: whoops you did

windows isnt a realtime OS, drivers arent perfect, many games are a mess

motherboard bios updated? cpu power options disabled in bios?

#47 Posted by Nictel (2386 posts) -

Are the games that have and the games that do not have the stuttering on the same hard drive?

#48 Posted by TheHBK (5466 posts) -

I assume you have it checked to high performace for the power profile in the control panel, not the nVidia control center? It happens to me. What frequency are your running your CPU at? What is reported to you?

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.