LAN never works...

#1 Edited by SexyToad (2760 posts) -

So I feel there might be something wrong with my router. I have many LAN pc games that do not work. Take Minecraft for an example. Wifi works fine, I've done homesharing in the past, but if I try to play a game over LAN it doesn't work. We have my PC hooked up to my brother's laptop. We're just trying to play some games together. I tried following tutorials online but it just doesn't work. I did read something about port forwarding though. I'm new to PC gaming so I wouldn't know how to do all this. Any help duders?

Edit: We have them both connected to the same router.

#2 Posted by MB (11903 posts) -

How are you connecting the two machines? With a direct cable or to a switch or a router?

Moderator
#3 Posted by SexyToad (2760 posts) -

@MB: We have them both connected to the router.

#4 Posted by EXTomar (4453 posts) -

There could be anything wrong with the setup of "We have my PC hooked up to my brother's laptop." Most modern NIC transceivers can do auto-sensing so you don't need "crossover cables" but one of the machines might be too old to handle that. Even given that, two machines don't start automatically communicating with each other just because there is a hard wired link. Do either NIC have the correct firewall configuration? Do either need additional configuration?

#5 Posted by SexyToad (2760 posts) -

@EXTomar: By connected, I mean both to the same router. They are both fairly new. He bought his around a month ago and I got mine, I would say a year ago. I have tried adding the game to list of things allowed through the firewall but it doesn't work.

#6 Posted by Jams (2959 posts) -

what kind of router are you using?

#7 Edited by SexyToad (2760 posts) -

@Jams: It's a Cisco Linksys model WRT160N V3.

Edit: Here's a picture.

Looks like that except the positions of Linksys and Cisco are swap. I went cheap...

#8 Posted by Devildoll (876 posts) -

well, you could try turning off the windows firewall on both computers and see if it works then
 
if it does, then all you need to do is authorise the program in question correctly.
 
controllpanel>windowsfirewall> advanced settings > here you should find someting like "properties for windows firewall" klick that
 
and here you should have like 4 tabs, domain, private and public profile are the 3 first, go ahead and turn the firewall off for all 3 on both computers, reboot em, and see if minecraft/whatever game works.

#9 Posted by SexyToad (2760 posts) -

@Devildoll: Thanks, I'll try that.

#10 Posted by VACkillers (1059 posts) -

In case you run into any more issues.... here is a guide to "Port Forwarding" for your router..... This is standard procedure for fixing issues for playing games on a network through a router...

Link For Port Forwarding

#11 Posted by SexyToad (2760 posts) -

@Devildoll said:

well, you could try turning off the windows firewall on both computers and see if it works then if it does, then all you need to do is authorise the program in question correctly. controllpanel>windowsfirewall> advanced settings > here you should find someting like "properties for windows firewall" klick that and here you should have like 4 tabs, domain, private and public profile are the 3 first, go ahead and turn the firewall off for all 3 on both computers, reboot em, and see if minecraft/whatever game works.

This worked for me! How can I configure firewall correctly?

#12 Posted by Devildoll (876 posts) -

 @SexyToad
  tired to find a good way to explain it, this will probably do

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.