PC Games Only Running Under the Surface?

#1 Posted by A_Cute_Squirtle (679 posts) -

So I'm still relatively new to PC gaming, and the PC I built this summer has been giving me some issues regarding some of the games I'm running. Dragon Age: Origins, Need For Speed Hot Pursuit, and Far Cry 2 have all given me this same issue:

I launch the game, either by its exe, or through Origin/Steam.

Visually, nothing occurs, but I can tell through Task Manager that the program is in the "processes."

Can anyone think of a fix? Here are my specs:

XFX Core Edition FX-787A-CNFC Radeon HD 7870 GHz Edition

Intel Core i5-3550 Ivy Bridge 3.3GHz (3.7GHz Turbo)

G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3

ASRock Z75 Pro3 LGA 1155 Intel Z75 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard

And I'm on Windows 7, if that makes a difference.

#2 Posted by DystopiaX (5295 posts) -

Happened to me while playing ME. What worked for me was quitting, running Steam as an administrator, then playing the game. It works, and after the first time you can run steam normally.

Not sure if it'll solve your problems but I guess it's worth a shot.

#3 Posted by A_Cute_Squirtle (679 posts) -

@DystopiaX said:

Happened to me while playing ME. What worked for me was quitting, running Steam as an administrator, then playing the game. It works, and after the first time you can run steam normally.

Not sure if it'll solve your problems but I guess it's worth a shot.

I've tried that as a fix for a few games, but those three instances seem to be impervious to that method.

#4 Posted by Colourful_Hippie (4330 posts) -

Weird, the only similar issue I can think of was when The Walking Dead was doing that but that issue was because of Windows 8 and having a controller connected.

#5 Posted by Theory (85 posts) -

Try turning off UAC temporarily and see if anything takes. Maybe windows is messing stuff up.

Go to control panel, search for UAC, it's under Action Center's "Change User Account Control settings"

#6 Posted by emem (1961 posts) -
@A_Cute_Squirtle: Standard question: Are all your drivers up to date (graphics card and chipset)?
#7 Posted by yoshisaur (2665 posts) -

I can tell you that it generally has nothing to do with your internal hardware, but most likely something Windows itself is hindering, or possibly the most recent: you have a controller plugged in. I know that when I tried to start up Jurassic Park the Game, it would just hand as if it started. This was resolved by un-plugging the controller. This has been happening for some odd reason for a number of games lately. The only other common solution I can think of is finding the executable that Steam launches in it's library and setting it's compatibility to "run in administrative mode."

If that doesn't help, sorry duder, but good luck!

#8 Posted by A_Cute_Squirtle (679 posts) -

@emem said:

@A_Cute_Squirtle: Standard question: Are all your drivers up to date (graphics card and chipset)?

I updated my "Intel(R) HD Graphics" (I assume this is just the chipset included with my CPU?) but that does not seem ot have solved the problem.

@Colourful_Hippie said:

Weird, the only similar issue I can think of was when The Walking Dead was doing that but that issue was because of Windows 8 and having a controller connected.

@ck1nd said:

I can tell you that it generally has nothing to do with your internal hardware, but most likely something Windows itself is hindering, or possibly the most recent: you have a controller plugged in. I know that when I tried to start up Jurassic Park the Game, it would just hand as if it started. This was resolved by un-plugging the controller. This has been happening for some odd reason for a number of games lately. The only other common solution I can think of is finding the executable that Steam launches in it's library and setting it's compatibility to "run in administrative mode."

If that doesn't help, sorry duder, but good luck!

I don't have a controller connected, but I appreciate the help duders.

@Theory said:

Try turning off UAC temporarily and see if anything takes. Maybe windows is messing stuff up.

Go to control panel, search for UAC, it's under Action Center's "Change User Account Control settings"

This didn't work, but thanks for the help sir.

#9 Edited by Snail (8584 posts) -

@A_Cute_Squirtle said:

@emem said:

@A_Cute_Squirtle: Standard question: Are all your drivers up to date (graphics card and chipset)?

I updated my "Intel(R) HD Graphics" (I assume this is just the chipset included with my CPU?) but that does not seem ot have solved the problem.

That's not your graphics card driver. That Intel HD Graphics thing is indeed referring to a graphics chip built into your CPU, and, if everything is working correctly, shouldn't be what you're using to play games. Download the first two packages in this page (if you have a 32-bit version of Windows, which I seriously don't expect you to have, go here), restart your computer, and try again. Let us know how it went.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.