PC problem

#1 Edited by icepick19 (5 posts) -

At first PC wouldn't turn on and after disconnecting everything from the motherboard and putting it back together it turned on and now it won't get past first BIOS screen. Keyboard and mouse which are USB also aren't working and I can't get into BIOS. Please, help!

#2 Edited by andmm (213 posts) -

Any error messages on the boot screen?

#3 Posted by Dagbiker (6978 posts) -

do you know enoough about computers to check to see if your hard drive is not being detected?

If not here is a Google Search for you ( and not one of those meme ones )

#4 Edited by icepick19 (5 posts) -

Nothing, just the BIOS screen saying press Del to enter Setup or F12 to enter Boot menu but I can't press anything because the keyboard doesn't work and I'm not able to get a PS/2 keyboard at the moment.

#5 Posted by icepick19 (5 posts) -

@Dagbiker Well, I haven't tried it but I can google it and then try.

#6 Posted by psylah (2185 posts) -

Are you hooking the mouse and keyboard to the back USB ports? If you're plugging them into the front, you may have unplugged those jumpers from the mobo too.

#7 Posted by andmm (213 posts) -

Could be a number of things.

Do you have the mobo speaker installed? If it's installed and it's not making any noise then ok.

Your cmos battery might be dead and that could've disabled the usb legacy support in system boot.


#8 Posted by icepick19 (5 posts) -

-The mouse and keyboard are hooked in at the back because I don't have any front ports and that probably isn't the problem.

-The PC isn't making any beeps but I think the HDD has suddenly gone bad. I unhooked the IDE cable and the power cable and hooked them back in and started the PC and it got past the first BIOS screen but then it said: Verifying DMI Pool Data... Can't find system drive. Insert System drive and press Enter. I tried to press Enter but I did nothing and then I shut down the PC and pressed the cables more firmly into the HDD and then it was back to the problem described in the first post.

#9 Posted by icepick19 (5 posts) -

Found the problem. One of my memory modules failed and I took it out by accident and now it is working perfectly.

Thanks for the support!

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.