Second monitor causing performance issues?

#1 Posted by Gruebacca (510 posts) -

I recently hooked up a second monitor, and it's been invaluable for productivity tasks like doing homework and looking up stuff about a game while playing it. The problem with games is that ever since I put the second monitor on, the games have been running significantly worse.

I have a GTX680 2GB. Both monitors are connected to the gpu via DVI cables. All games are being run from the primary monitor.

Sometimes games will run at half speed and then back up with no noticeable dip in gpu usage. Oddly enough, games will perform MUCH worse in fullscreen mode, but will run almost fine in windowed. Even if I stretch the game across both monitors, it runs better than being fullscreened to one. For example, Need for Speed: Rivals never dipped below 30 in all the time that I played it when it came out, but with two monitors it dips below all the time, sometimes dipping below the 20s while using less than half of the gpu. When I alt+tab out of the game, it runs perfectly fine in the background.

And then to top it all off, when games (or videos) are being run on the primary, the secondary monitor suffers from extreme lag and framerate issues. I can't play a game and watch Brad die in Demon's Souls without extreme stuttering on the latter.

I'm not sure at all on what to do about this. Some people on the Internet say that there shouldn't be any problems with a second monitor while others say there are. Is there a solution to this, or have I joined some horrible club that I have to get used to?

#2 Edited by Slaegar (697 posts) -

While I can't offer too much help, I can tell you that I have a second monitor running XBMC at all times and notice no performance problems. I also have a weaker video card (AMD HD 7850 2GB).

What is your CPU and RAM? This seems more like an odd refresh rate issue rather than a straight up performance problem, but more info doesn't hurt.

I do a similar thing where I play giant bomb videos on one monitor and play games on the main monitor and I have no issues unless the game is pushing my system very hard.

#3 Posted by Gruebacca (510 posts) -

@slaegar: CPU is a Core i5 2500, and with 8GB RAM. Should be plenty for most games. Both monitors have a maximum 60 Hz refresh rate and are set at that.

The video stuttering seems to happen whenever the gpu memory eclipses 50%. Which is dumb. Why not start stuttering when it's full?!

#4 Posted by ChaosDent (234 posts) -

I don't know what to say, that seems very strange. I watched a lot of Netflix on a side monitor while playing Civ V on my primary a couple of years ago. This was with an AMD Phenom II and an ATI Radeon 5770, not at all high end even for their day.

#5 Edited by Slaegar (697 posts) -

@slaegar: CPU is a Core i5 2500, and with 8GB RAM. Should be plenty for most games. Both monitors have a maximum 60 Hz refresh rate and are set at that.

The video stuttering seems to happen whenever the gpu memory eclipses 50%. Which is dumb. Why not start stuttering when it's full?!

So your CPU, GPU, and RAM are all up to snuff.

Could you try disabling Aero and seeing if that helps at all?

#6 Edited by Gruebacca (510 posts) -

@slaegar: What the fuck? Why does disabling Aero solve everything? That is unbelievably lame.

Thanks, though. This will work for now. If anyone else has a better idea, throw it at me, cause having to disable Aero every time I want to play a game is dumb.

#7 Edited by OurSin_360 (842 posts) -

What's your power supply ? Are all your drivers up to date?

#8 Posted by Gruebacca (510 posts) -

@oursin_360: Power supply is 550 watts. probably should be a little higher, but I haven't had issues with it. The 680 doesn't use much power.

Using the latest drivers. It doesn't seem to matter what version it is. All of them do this.

#9 Posted by Dagbiker (6956 posts) -

Arro uses the gpu so it's basically like running two games at once. Try running in full screen window or even just as a window.

#10 Posted by Ben_H (3335 posts) -

@slaegar: What the fuck? Why does disabling Aero solve everything? That is unbelievably lame.

Thanks, though. This will work for now. If anyone else has a better idea, throw it at me, cause having to disable Aero every time I want to play a game is dumb.

Use Classic theme. No switching to worry about. Aero used to sometime switch for me but not always and it would sometimes screw up and force me to do all kinds of stuff to make it work right. So I just gave up and used Classic. Now I never have to think about it because it is a non-issue for me. I do so with 3 monitors too.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.