Terrible frame rate in UE3 games

#1 Posted by howardee (19 posts) -

First of all, I realise I'd probably be better off posting this in the tested forums but I wanted to ask any fellow duders if they had run into this same problem and if they did, how they fixed it.

I recently built my first gaming rig and everything seemed peachy and awesome. I've been playing some SLEEPY DAAAAWGZ and Assassin's Creed 3 with pretty much all the video settings on high or very high and both have been running at 60fps with no problems at all. I can run Metro 2033 with everything set as high as it goes and the frame rate never drops below 30fps. My problems began when I picked up XCOM, Borderlands 2 and Antichamber, all Unreal Engine games. My PC should have no problems running these games (see the specs below) but for some reason, they all run like hot fucking garbage. Antichamber doesn't launch at all (it displays the Unreal splash screen then freezes and has to be force-closed) and XCOM and Borderlands seem to be running fine until I hit the main menu, then the frame rate drops to less than 5fps and remains that low during any gameplay, which is pretty much unplayable. This problem persists regardless of the video settings or screen resolution selected and it's driving me insane! I've tried literally everything I can think of, short of reformatting my PC, to no avail; making sure my video and hardware drivers are up-to-date, rolling back to the drivers included on disc, installing beta drivers, uninstalling and reinstalling the games, verifying the integrity of the game caches through steam, reinstalling DirectX, installing UDK, running the game from an SSD and a hard drive, reading through page after page of troubleshooting threads on Steam and the Gearbox and Firaxis sites, praying to Jesus, Allah, Buddha and any other gods I could think of and finally, opening up my case and screaming "WHYYYY?!" at my graphics card. No luck :(.

Have any duders here run into the same or similar problems? If so, did you ever figure out what the hell was going on? I've been bashing my head against this for a few days now and I don't feel any closer to a solution. My PC specs are as follows:

CPU: Intel i7 - 3770k @ 3.5 GHz

GPU: nVidia GeForce GTX 660 Ti (MSI Power Edition)

Mobo: MSI Z77 MPower

RAM: 8 Gb

OS: Windows 7 64-bit

#2 Posted by mosdl (3242 posts) -

Belongs in the PC forum, but the big question is what resolution.

#3 Posted by Colourful_Hippie (4467 posts) -

I'm on close specs (have an evga 660 ti) and I always get a high framerate.

#4 Posted by howardee (19 posts) -

@mosdl said:

Belongs in the PC forum, but the big question is what resolution.

My bad, first time post. It doesn't matter what resolution I try running the games at, the frame rate doesn't change. I've been running everything non-Unreal at 1920x1080 with no problems but even when running in windowed mode at 1024x768, XCOM refuses to put out more than 4fps. I'm going to try a reformat and see if that makes a difference.

#5 Posted by buft (3321 posts) -

UT3 games have issues with some sound cards and some mobos with virtuMVP which your card has, i dont have a solution for you but thats a place to start

#6 Posted by AlexW00d (6382 posts) -

UE3 is like the worst engine in the world, so that's probably why... (I don't have an actual response sorry)

#7 Posted by believer258 (12081 posts) -

Have you tried turning it off and back on again?

Uh... un- and re-install drivers? I have no clue where to start here.

Here's an idear - plug your computer into the integrated graphics - don't worry, it will work, just not well - and try Borderlands. See if you get better framerates at low settings. This way, we can determine if it's your card or something else entirely.

#8 Posted by howardee (19 posts) -

@buft said:

UT3 games have issues with some sound cards and some mobos with virtuMVP which your card has, i dont have a solution for you but thats a place to start

I've got Virtu MVP disabled. I tried enabling it but it didn't make a difference. Also tried disabling my sound card in Device Manager but that didn't make a difference either. Worth a shot though!

@believer258 said:

Have you tried turning it off and back on again?

Uh... un- and re-install drivers? I have no clue where to start here.

Here's an idear - plug your computer into the integrated graphics - don't worry, it will work, just not well - and try Borderlands. See if you get better framerates at low settings. This way, we can determine if it's your card or something else entirely.

I just tried running Borderlands and XCOM using the integrated graphics, then the dedicated card. I got 4fps from Borderlands and 2fps from XCOM, regardless of which was being used. Weird stuff.

I've just finished backing up all my files so I'm going to try reformatting my PC now. I'm following that age old advice, "If in doubt, nuke everything and start again from scratch."

#9 Posted by believer258 (12081 posts) -

@howardee: In that case, it probably was not your graphics card that was the issue.

#10 Posted by howardee (19 posts) -

@believer258: Yeah, I just assumed the graphics card was at fault because I read a ton of posts from AMD users complaining about their cards not working properly with Unreal. If it's not the card, it could be pretty much anything so a reformat's probably my best option anyways.

#11 Posted by howardee (19 posts) -

If anyone cares, I figured it out. Well, I didn't figure it out but reformatting my PC fixed whatever was broken. It could've been a lot of things but when I was reinstalling drivers, I did each one manually instead of using MSI's Live Update software. And I didn't install the driver for my integrated graphics cause I figured maybe any Unreal games were trying to run using that instead of the dedicated card. Whatever the issue was, it's gone now so I can get back to my back catalogue of games I bought during the Steam Sale that I haven't gotten round to playing yet. Thanks for the help, duders!

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.