Very Poor Performance

#1 Posted by kadash299 (279 posts) -

For whatever reason, I run Planetside 2 very, very poorly..

As in.. about 15-20fps in very low settings poorly.

This does not make sense for my rig, as I can run Skyrim(Modded) At 60+ Fps, Medal of Honor (2012) At High settings at 35-45fps, Xcom Ultra @ 60+ Fps, and Far Cry 3 at 60+ FPS on Mixed High/Med settings.

Can anyone explain the performance issue to me.. because I saw Jeff in the quicklook, and i really, REALLY want to play this game looking like that, and since it really doesn't look that great, (or atleast, not as good as Far Cry and Medal Of Honor) I can't for the life of me understand my performance issue...

#2 Posted by kadash299 (279 posts) -

Bump because I really wanna play it now =/

#3 Posted by Dagbiker (6976 posts) -

I have this problem off and on. Restarting my computer fixes the problem.

#4 Posted by Morbid_Coffee (955 posts) -

Two reasons I can think of:

1) The game is a massive memory hog. Like a lot. My CPU and GPU shoot up to 50% usage on both and I just built my new gaming PC three months ago.

2) The game has memory leaks. Like every hour of play makes it permanently drop 5 FPS. A reboot of the game fixes this.

#5 Posted by kadash299 (279 posts) -

well I have a quad core and 8GB of DDR 3 Mem, I'm not using 50% of either of those

#6 Posted by ajamafalous (11994 posts) -
@kadash299 said:

well I have a quad core and 8GB of DDR 3 Mem, I'm not using 50% of either of those

What are your processor and GPU? The game's pretty resource-intensive with as much shit happening at all times as it has.
 
Also, I can confirm that there must be a memory leak or something, because as a few other people said above, the game's performance definitely gets worse the longer you play. Both of my roommates have to restart the game every hour/hour and a half to get the game's framerate to become playable again.
#7 Posted by Raven10 (1790 posts) -

I have no major issues with it and I have only a mid-range system. I don't have it maxed out, but on medium settings it looks great and runs over 30 fps unless there is a ton of stuff happening on screen.

#8 Posted by Shookems (474 posts) -

I haven't tried it since the beta but I remember it running extremely poorly even though I have a pretty decent system. Are your drivers up to date? What video card are you running?

#9 Posted by Slaegar (710 posts) -

The dev's have said they are working on optimization on the forums
 
http://forums.station.sony.com/ps2/index.php?threads/quick-note-on-optimization.49152/
 
Also specs may help to see more into the problem.

#10 Posted by kadash299 (279 posts) -

I have a 3.2 Ghz Intel Quad Core, with 8gb of 1666 (or whatever) DDR 3 Ram, with a 1GB Nvidia GeForce GT 430(I have a slimline, its as good as i can get) -- But as i said, I get a lot of power out of that card, and can play many of the AAA titles with a solid framerate, yet for some reasons Plantside runs like shit. Ive even played Crysis 2 All the way through on the 2nd graphics setting (I forget what its called.. Advanced maybe?) At above 30 FPS.. Thats why I'm so confused!

#11 Posted by kadash299 (279 posts) -

Bump for discussion :'(

#12 Posted by Slaegar (710 posts) -
@kadash299 said:

GeForce GT 430

Well that would do it. My 7850 is always running at 100% and I often dip into the 30s during a larger battle. Also Crysis 2 is a console port and as such is very forgiving.
#13 Posted by envane (1163 posts) -

that card sounds liek absolute shit , i dunno how you get those fps out of farcry , unless you forgot ot mention you run everything at 800x600 ..

but anyway planetside is just a processor/gpu/memory whore , and will use it all and demand more even tho its not really using everything you have anyways .. but yeah .. that gpu would help a bit

you will still lose alot of fps when alot of people are in the same area , which is a shame because thats where it shines.

#14 Posted by Funkydupe (3319 posts) -
#15 Posted by Subjugation (4720 posts) -

That card definitely isn't helping your situation. However, PS2 also needs a TON of optimizing. It should run way better than it does.

Online
#16 Posted by kadash299 (279 posts) -

@envane said:

that card sounds liek absolute shit , i dunno how you get those fps out of farcry , unless you forgot ot mention you run everything at 800x600 ..

but anyway planetside is just a processor/gpu/memory whore , and will use it all and demand more even tho its not really using everything you have anyways .. but yeah .. that gpu would help a bit

you will still lose alot of fps when alot of people are in the same area , which is a shame because thats where it shines.

Actually I run it at native Resolution for my monitor (1600x900), With absolutely 0 Issues. Thanks for your useless Input though.

@Subjugation said:

That card definitely isn't helping your situation. However, PS2 also needs a TON of optimizing. It should run way better than it does.

I figured It was optimization, But I wanted to make sure that it wasn't on my end.

#17 Posted by superst3ve (15 posts) -

@ kadash299 if you press alt-f in game a frame counter will appear at the bottom left. Beside it, it will tell you specifically what is the bottleneck. That will directly tell you what you should troubleshoot.

I'm pretty sure you're going to see it's your GPU unless your quad core is an older model e or q. The 430 is a fantastic GPU for an HTPC (in fact the current de facto) and dx9 games but it does not have the memory nor cores to run PS2 efficiently. Due to how poorly optimized PS2 is, a 460 is about the baseline you'll need for solid fps at med settings.

#18 Edited by DeathTrap (249 posts) -

I found a work around that gave me a nice performance boost:

  1. Set the options to how you would like them in game (I used Medium, but my computer's a couple years old now)
  2. Go to the install directory for Planetside 2 and find UserOptions.ini
  3. Under [Rendering] Change ShadowQuality to: ShadowQuality=0
  4. If you don't have ShadowQuality for some reason, add that line.
  5. Save the file
  6. Change UserOptions.ini to Read-Only

Keep in mind, if you do this, you will be unable to change your options in game - you'll have to go back to the file, allow edits, and then make your changes either in game or in the ini file itself. If you do it in game, then you'll likely have to redo the steps above.

#19 Posted by Ubersmake (754 posts) -

Don't know if it's still an issue (I haven't played for a few days), but take a look at UserOptions.ini and look for RenderDistance.

When I opened that file, that value is set to -1, which means that the game will render infinitely. Everything. All the things. So set it to something like 2000 or 3000. Or set it to 60, and see what the game might look like if you were playing it on an N64.

#20 Posted by RIDEBIRD (1232 posts) -

That's quite a bad card, and I can't either understand how you can run FC3 with it so well. Anyway, the game is also really badly optimized currently.

#21 Posted by CreepingDeath0 (176 posts) -

@RIDEBIRD: I maxed Far Cry 3 at 1600x1024 on an old Geforce 8800GTS. It's just an amazingly well optimized game xD

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.