Clicking doesnt do anything

#1 Posted by StalkingTurnip (150 posts) -

I bought Civ 5 when it came out and have run it up until now no problems. After buying gods and kings and trying to play it, it lets me start up a match but then nothing happens. I cant select any units at all. I cant even change the upper left corner thing. I can only bring up the menu or the victory conditions on a scenario. If i try to retire, it will bring up an advisor but if i hit one more turn it still wont respond and from that point onward the retire option will be perpetually selected and i cant retire again. If i try quiting to main menu the game crashes. If i quit the windows it works though. I have tried going back to previous saves and deleting it and redownloading it. Does anyone else have a similar issue or can help me?

#2 Posted by Sackmanjones (4762 posts) -

Did you download any mods that might have screwed it up?

#3 Posted by StalkingTurnip (150 posts) -

N@Sackmanjones said:

Did you download any mods that might have screwed it up?

No, I havent downloaded any mods since before i bought it and it worked than. Plus i thought that might have been the case so i deleted all of them and it still didnt work.

#4 Edited by Ravenlight (8011 posts) -

@StalkingTurnip: Maybe something got fucked up with the game files. Try this:

  1. Right-click Civ V in Steam and go to Properties
  2. Click on the Local Files tab
  3. Finally, click Verify Integrity of Game Cache

This could take awhile as Civ V is a big game. Probably less than 10 minutes, though.

After it finishes, see if it worked.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.