If the DirectX 10/11 option is disabled for you

#1 Posted by mosdl (3229 posts) -

 
Go to C:\Program Files (x86)\Steam, right click on steam.exe, go to properties, got compatability, click on change settings for all users. I had Windows Vista set for steam.exe for some reason, unselect "run this program in compatability mode"

#2 Posted by sins_of_mosin (1556 posts) -

Yeah, a lot of people are reporting this and have no idea how long that has been set.  I just installed steam last night so I'm going to check mine once I get home.
#3 Posted by Brenderous (1105 posts) -

I have Vista, and I wasn't running on compatibility mode, and I still can't select Direct X 10 or 11.

#4 Posted by Tovan (633 posts) -
@Brenderous said:
" I have Vista, and I wasn't running on compatibility mode, and I still can't select Direct X 10 or 11. "
This is my exact problem as well.
#5 Posted by Gul_Pirak (29 posts) -

@mosdl said:

Go to C:\Program Files (x86)\Steam, right click on steam.exe, go to properties, got compatability, click on change settings for all users. I had Windows Vista set for steam.exe for some reason, unselect "run this program in compatability mode"

That fixed it for me. Thanks a bunch!

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.