System Requirements

#1 Posted by The_Drizzle (624 posts) -

I recently went to "can you run it" and everything is fine except my CPU speed, but i checked the reqs on steam for the CPU speed and it says 
Intel Core 2 Duo 1.8 GHz and i have a Intel Core 2 Duo P8600 @ 2.40 hgz, so what gives? Why does it show that i don't meet the minimum requirements?

#2 Edited by Diamond (8634 posts) -
@The_Drizzle:  The P8600 is a mobile version.  I don't know off the top of my head and I don't know how Civ 5 performs, but it might not be enough.
 
Looking up benchmarks for it, it seems the P8600 should be enough.  Odds are the site doesn't calculate mobile processors correctly.
#3 Posted by The_Drizzle (624 posts) -

Ah that would make sense i guess my best bet will be to DL the demo and see how it runs

#4 Posted by Animasta (14648 posts) -

can you run it? is messing up everyone's civ 5 specs for some reason, so you'll probably be able to run it.

#5 Posted by AndrewB (7482 posts) -

I think those "can I run it" type sites are an inexact science. I'd just go by the listed minimum requirements and maybe wait for the demo like you said if you're worried.

#6 Posted by Anty1 (22 posts) -

That site is so inaccurate, Like you said best bet is to try demo first.

#7 Posted by RVonE (4603 posts) -

That site messes up a lot of the diagnostics. Like Anty1 said, just try out the demo that's out on tuesday.
#8 Posted by Grilledcheez (3943 posts) -

Those sites don't take integrated graphics into account properly either

#9 Posted by Paulus (174 posts) -

Just tested my own system to check for myself...This was the result: 
 

CPU
Minimum:  Intel Core 2 Duo 1.8 GHz or AMD Athlon X2 64 2.0 GHz
You Have:  Intel(R) Core(TM)2 Duo CPU E6850 @ 3.00GHz
PASS
CPU Speed
Minimum:  Intel Core 2 Duo 1.8 GHz or AMD Athlon X2 64 2.0 GHz
You Have:  3.00 GHz
Upgrade Suggested: Unfortunately, your CPU Speed does not meet this requirement. Click here to see some recommendations.
    
...I don't really get it. :p
#10 Posted by Rhombus_Of_Terror (2088 posts) -
@Paulus said:
" Just tested my own system to check for myself...This was the result: 
 
CPU
Minimum:  Intel Core 2 Duo 1.8 GHz or AMD Athlon X2 64 2.0 GHz
You Have:  Intel(R) Core(TM)2 Duo CPU E6850 @ 3.00GHz
PASS
CPU Speed
Minimum:  Intel Core 2 Duo 1.8 GHz or AMD Athlon X2 64 2.0 GHz
You Have:  3.00 GHz
Upgrade Suggested: Unfortunately, your CPU Speed does not meet this requirement. Click here to see some recommendations.
    ...I don't really get it. :p "
Does your processor have dual cores or a single core?
#11 Posted by Meteora (5787 posts) -
@RhombusOfTerror: Doesn't it already say "duo" cores, meaning dual, or am I missing something here? 
 
Also traditionally speaking, Civilization games tend to be more CPU focused than GPU.
#12 Posted by sins_of_mosin (1556 posts) -

My PC barely makes it over the min requirements.  My woman's laptop is better then my desktop but once she sees that I won't give it back for 10hrs a day, she'll probably stop letting me play on it.  :D 
 
Gonna have to try the demo out to make sure I can run it good enough to warrant the money.  Otherwise, it'll have to wait for my new desktop this winter.
#13 Posted by haggis (1677 posts) -
@The_Drizzle:  I had the same problem, with the "can I run it" program telling me that my 2.0 ghz Core Duo wasn't higher than the 1.8 ghz minimum spec. Don't worry, you can probably run it.
#14 Posted by Rhombus_Of_Terror (2088 posts) -
@Meteora: my bad it does say dual.  
 
Steam
lists 1.8ghz QUAD core:
 
STEAM RECOMMENDED STATS 

    Recommended:

    • OS: Windows® Vista SP2/ Windows® 7
    • Processor: 1.8 GHz Quad Core CPU
    • Memory: 4 GB RAM
    • Graphics: 512 MB ATI 4800 series or better, 512 MB nVidia 9800 series or better
    • DirectX®: DirectX® version 11
    • Hard Drive: 8 GB Free
    • Sound: DirectX 9.0c-compatible sound card  

    • So OP probably got mixed up with the fact that he has a 1.8ghz dual core where infact it lists a 1.8ghz quad.
#15 Edited by JoeyRavn (4948 posts) -

Woah. I was tempted to buy this game, since I heard it's a much more streamlined experience than previous Civs (wich I liked, but never been able to get into). But with those recommended requirements, I think I'll wait. 
 
PS: BTW, why do they recommend DirectX 11 if neither 9800GTs nor ATi 4800s support it?

#16 Posted by JoshLarson (68 posts) -

There is a big difference between "Recommended" system requirements and "Minimum" system requirements. Quad core CPU is for the former, dual core is the latter.
#17 Posted by Meteora (5787 posts) -

Hopefully when they mean recommended Quad core; they actually mean that they've optimized the game for quad core. Too many games actually perform better in dual than quad.

#18 Posted by sins_of_mosin (1556 posts) -

Civ games have always been a more CPU intensive game so I'm happy that my CPU is a bit better then the min even if my GPU is just above the min. 
 
I don't need to see waves or grass blowing in the wind, I just need it to work.  :D
#19 Posted by Sanity (1891 posts) -

Im curious how my E8500 will work on this, im running a gtx280 and 4 gigs of ram with it but as you said its more cpu intensive.

#20 Posted by Theavy (78 posts) -

i have a core i7 processor and it tells me i cant run it, i am on a laptop but im sure any core i7 will be quick enough to run it

#21 Posted by Driadon (2995 posts) -
@Turkish_Heavy: It's likely reading the base speed (which knowing most mobile i7's, is likely between 1.6 and 1.8 GHz). An i7 should breeze through this fine.
#22 Posted by Hunkulese (2640 posts) -

System Requirements Lab is always wonky and very unreliable.  
 
Check out yougamers for a much more reliable analysis

#23 Posted by mrfizzy (1517 posts) -
@Laketown said:
" can you run it? is messing up everyone's civ 5 specs for some reason, so you'll probably be able to run it. "
oh thank god. i was planning to get civ 5 when its released tomorrow and just checked "can you run it?" and it said my CPU wasnt good enough, even tho my CPU is higher than the recommended. so glad this forum is here!  
thanks guys! 
#24 Posted by smudo (150 posts) -

...and yet Civ V CRAWLS everytime I play it.
At least it works better in the Direct X 9 mode, so my $50 isn't totally wasted.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.