Big issue when using an xbox controller on pc

#1 Posted by SilenceUK (330 posts) -

Very weird one here.

When trying to play the game with a 360 pad the game will recognize the pad in the all the menus and allow me to hit start to bring up the menu in game but will 100% not recognize anything else, no movement no action no nothing.

Can select all options in the menu using the A button etc as well just nothing at all in game other than the start button.

Any ideas?

#2 Posted by l4wd0g (2017 posts) -

I have serious latency issues with it, but I can still use the controller. That is a strange issue.

#3 Posted by Roland_D11 (195 posts) -

I've read that the latest patch brings up that problem for some people. It works fine for me, though. I think your best bet are the Steam forums of the game, usually somebody comes up with a solution :-) .

#4 Posted by AlisterCat (5711 posts) -

Weird. You could try reinstalling the drivers for the controller.

Online
#5 Posted by Mnemoidian (960 posts) -

That's odd.

None such issues for me, though I was using a PS3 gamepad with drivers disguising it as an Xbox gamepad.

But yeah, try the Steam forums or the "official" forums for the game.

#6 Posted by SilenceUK (330 posts) -

I've done an hour or 2 of googling and forum hunting and there seems to be no exact fix that works for all.

My fix is to turn my mouse off just after launching the game as any mouse movement seems to disable the 360 pad for in game use while still allowing it for menus.......yeah go figure lol ah well at least its a way to make it work so i can play in bed on the tv rather than at my desk lol

#7 Posted by Humanity (10035 posts) -

@Roland_D11 said:

I've read that the latest patch brings up that problem for some people. It works fine for me, though. I think your best bet are the Steam forums of the game, usually somebody comes up with a solution :-) .

That should be the catchphrase of PC Gaming.

PC Gaming: Look around, usually somebody comes up with a solution..

Online
#8 Posted by Mnemoidian (960 posts) -

@SilenceUK: There's a setting in the options for primary control method, have you tried setting that to gamepad? ... I'm guessing you have, and I don't know what it actually does (probably just changes the icons?) - but worth testing if you haven't :)

#9 Posted by impartialgecko (1708 posts) -

Tried turning off V-sync?

#10 Posted by ProfessorEss (7505 posts) -
@SilenceUK:  Hmm, strange. I plugged it in and away I went.  @Mnemoidian said:

@SilenceUK: There's a setting in the options for primary control method, have you tried setting that to gamepad? ... I'm guessing you have, and I don't know what it actually does (probably just changes the icons?) - but worth testing if you haven't :)

That's the only thing I could think to suggest as well.
#11 Posted by AhmadMetallic (18954 posts) -

Are you sure that in the options you don't have "Keyboard and Mouse only" picked but rather "Swap between the two" or whatever the option is called?

#12 Edited by Canteu (2821 posts) -

@SilenceUK: There is an option in the menus to select only controller, only M+KB or automatic (or something).

Selecting one completely disables the other, except the third option.

Perhaps look into that?

#13 Posted by Tag (65 posts) -

Ive been using a x360 controller on the pc and have had no issues

#14 Posted by Karnov (10 posts) -

Try unplugging any other "Game Controllers" you have plugged in, your racing wheel, hotas, what have you.

That solved it for me.

#15 Posted by SilenceUK (330 posts) -

Yup have that set to controller only and still has the issue if there is any mouse movement after pressing play on steam it locks the controller out

#16 Posted by JoeyRavn (4983 posts) -

It has happened to me from time to time. Really annoying. And, yeah, if you move the cursor with the mouse while the game is loading, it breaks gamepad movement, even if one is selected exclusively.

#17 Posted by Ravenlight (8011 posts) -

@SilenceUK said:

Yup have that set to controller only and still has the issue if there is any mouse movement after pressing play on steam it locks the controller out

Plug your controller/wireless receiver into a different USB port. If you're using a USB hub, plug it directly into your computer. Somebody on the Square-Enix forums reported this fixed the semi-responsive controller issue. I can't find a link to the forum in question, though :/

#18 Posted by cannonballBAM (612 posts) -

@SilenceUK: I use a PS3 controller mapped as a 360 remote using DS3 tool. Sleeping Dogs seems to work perfectly fine using it, I would check your drivers and see if you need to re-install.

#19 Posted by mtcantor (951 posts) -

No idea. Works great for me. Using a wired controller though... are you using the wireless version?

#20 Posted by SilenceUK (330 posts) -

Have really tried all the obvious ideas guys lol Current fix is to go into manage computer disable the last game controller device in the devices menu then turn the mouse off as i hit play on steam. People have moaned on their forums about it so expect there will be some kinda fix soon but hey at least i can play it now in bed on my big tele lol

#21 Posted by Devil240Z (3429 posts) -

I'm using a 3rd party 360 pad and it works fine.

#22 Posted by MB (13073 posts) -

I had to start using a controller in order to even continue playing the game. For some reason my escape key wasn't functioning in some menus, notably the clothing change ones, so I was getting stuck and the only solution was to plug in a controller and hit the B button.

I'm glad that happened though, controller seems like the preferable choice for this game now that I've tried it.

Moderator
#23 Posted by Givan (1 posts) -

im using PlayStation 2 Stick n im OK with all the menus and in game control, but the problem is, i can't change the controller bottons option, because on the controller option menu there are only keyboard options....how can i if i wanna change the controller configurations?

#24 Posted by gulinotm (125 posts) -

a year later and this is still a problem...

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.