Frequent crashes?

#1 Posted by AndrewB (7691 posts) -

I feel like posting about what is surely a temporary bug is kind of pointless, but I just want to know if I'm the only one who's experienced a crash in every single campaign mission so far? It hasn't been game-breaking because it's always happened early in the mission, but is annoying nonetheless and considering the stability I've had for months now with every other game, it's hard to imagine it being a hardware issue (and yes, I have the latest drivers for all of my hardware short of the beta drivers for Nvidia graphics cards which mention no improvements for Starcraft II outside of SLI).

Again, surely something that will be patched on either Nvidia's part or through a general release, but still has ground my attempts to play the campaign to a halt for the time being.

#2 Edited by Zirilius (732 posts) -

Played through 1/3 of the campaign and haven't had a single crash. Running on a Geforce GTX 460 on ultra graphics though I have heard of other users experiencing your issues.

#3 Posted by Bocam (3833 posts) -

I haven't had any crashes but there have been times when the game freezes but the actions queued still go

#4 Edited by haffy (674 posts) -

Had one crash in about 15 hours of play.

#5 Posted by AndrewB (7691 posts) -

Err, I guess I should mention my hardware is fairly standard for this era of gaming. Core i5 3570, Geforce GTX 670, ASROCK Z77 Extreme4 being the most relevant items.

@zirilius said:

... though I have heard of other users experiencing your issues.

I mean, as long as it isn't me, then I'll be happy knowing there's a quick fix in the works.

#6 Posted by Zirilius (732 posts) -

@andrewb said:

Err, I guess I should mention my hardware is fairly standard for this era of gaming. Core i5 3570, Geforce GTX 670, ASROCK Z77 Extreme4 being the most relevant items.

@zirilius said:

... though I have heard of other users experiencing your issues.

I mean, as long as it isn't me, then I'll be happy knowing there's a quick fix in the works.

Blizz forums show some people complaining about crashes, freezes, and stalls but nothing official other than update your drivers from what I saw. Seems pretty sporadic in terms of hardware that its affecting.

#7 Posted by doe3879 (820 posts) -

I have the exact PC set up.

Gtx 670. I5 3750k. 8gb ram

On mission 20 and had roughly 4 crashes.

And the game isn't running that smoothly some compare to my older 3 year old PC.

It's running at 33fps with everything max when I'm in the home base.

#8 Posted by kovike (1 posts) -

It's a common issue with current drivers of GeForce 6. Either downgrade to version 310.90, or wait for new ones. Nvidia is working on it.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.