A StarCraft II Bug Or Two You Might Want To Know About

  • 94 results
  • 1
  • 2
Posted by BradNicholson (812 posts) -

The StarCraft II: Wings of Liberty downloader and I don't get along. Because I can't connect to the direct download server, I'm stuck in a peer-to-peer logjam. In an estimated 13 hours or so, I'll be able to experience Blizzard's RTS, which from all the accounts I've read thus far, is a stellar offering. Yet, it's one that isn't without its small share issues. This downloader springs to my mind, but Blizzard has identified more pressing faults on the game's official website.

Perhaps the most important one you should know about at this point is a dandy that can send your computer into a nuclear meltdown. "Certain screens make your hardware work pretty hard," the known issues portion of the site reads, "screens that are light on detail [like a menu screen] may make your system overheat if cooling is overall insufficient." It's a result of the game "drawing the screen quickly." The workaround is to cap the game's frame rate by digging and adjusting file values. 
 

I don't know who this guy is, but I like his beard. I bet we're going to be the bestest of best friends whenever I start playing. 

Windows owners of the game are also reporting crashes when running the game in compatibility mode. But Mac owners are feeling the pain, too. In a message board thread, it's pointed out that there are crashes associated with NVIDIA drivers for owners with OSX 10.6 and that plugging in a USB headset makes the frame rate take a dive--another handy fix, I'd say, for anyone with menu screen meltdown issues.

Have you spotted any issues? I would chime in, but I've got a few more hours of downloading before I get a chance to whiff Jim Raynor's space cigarette smoke or put the hurt on some Zerg.
#1 Posted by BradNicholson (812 posts) -

The StarCraft II: Wings of Liberty downloader and I don't get along. Because I can't connect to the direct download server, I'm stuck in a peer-to-peer logjam. In an estimated 13 hours or so, I'll be able to experience Blizzard's RTS, which from all the accounts I've read thus far, is a stellar offering. Yet, it's one that isn't without its small share issues. This downloader springs to my mind, but Blizzard has identified more pressing faults on the game's official website.

Perhaps the most important one you should know about at this point is a dandy that can send your computer into a nuclear meltdown. "Certain screens make your hardware work pretty hard," the known issues portion of the site reads, "screens that are light on detail [like a menu screen] may make your system overheat if cooling is overall insufficient." It's a result of the game "drawing the screen quickly." The workaround is to cap the game's frame rate by digging and adjusting file values. 
 

I don't know who this guy is, but I like his beard. I bet we're going to be the bestest of best friends whenever I start playing. 

Windows owners of the game are also reporting crashes when running the game in compatibility mode. But Mac owners are feeling the pain, too. In a message board thread, it's pointed out that there are crashes associated with NVIDIA drivers for owners with OSX 10.6 and that plugging in a USB headset makes the frame rate take a dive--another handy fix, I'd say, for anyone with menu screen meltdown issues.

Have you spotted any issues? I would chime in, but I've got a few more hours of downloading before I get a chance to whiff Jim Raynor's space cigarette smoke or put the hurt on some Zerg.
#2 Posted by msavo (7522 posts) -

Good to know. I'm a mac owner and I was going to plug in a headset. Thanks Brad. 

#3 Posted by KarlHungus (125 posts) -

I have experienced some inconsistent frame rates at times, but other than that I have had no other issues.

#4 Edited by Falx (335 posts) -

I've had a really annoying problem that when i save my campaign and quit out and go back to it later the saves havent worked and ive had to repeat 1 or 2 missions again, it only happens when i quit the campaign mode and it goes to the main screen but says it has lost connection to battlenet.

#5 Posted by Rockdalf (1274 posts) -

I've just gotten a brand new rig, so I should be cool, but I'll monitor my temps while I game the next few times just to be sure it's not going to blow up on me mid game.  Hope it downloads soon.

#6 Posted by EightBitShik (1333 posts) -

Brad, my roommate had the same problem and it turned out he was uploading way more then it was downloading he was able to do something to make it so that he was downloading more of the information. As far as other problems it seems quite a few people can't get the in game voice chat to work but it works with things like wow and vent just fine.

#7 Edited by Crono (2620 posts) -

The game's client has been out for over a week before the game's launch, Brad.  It was even posted as news here.  You should have downloaded it before the rush :p
 
Unless you mean for the update?

#8 Posted by GBLatros (1 posts) -

Good to know, thanks!

#9 Posted by Falx (335 posts) -

Erm, ive just got another problem while trying to post a message in the bug forum "You need a StarCraft II character (created in-game) to post on the forums." and i do have a starcraft 2 character, ive been playing it for almost 2 days.

#10 Posted by MordeaniisChaos (5730 posts) -

You need to set some stuff up to allow Blizzards downloader to work properly. This isn't to do with SC2 in general, the Blizz Downloader is notoriously finicky. But generally, once you get it going, you should be fine.

#11 Posted by Franstone (1057 posts) -

My only issue has been the latest mission I've tried to complete has taken me 3 or 4 attempts and I can't seem to beat it yet...
#12 Posted by V_Ben (108 posts) -

Yeah, I'm a Mac guy with an Nvidia card, and the game is bricking it for me. Lovely :/

#13 Posted by pap (23 posts) -

No problems for me so far.  Actually, I'm just amazed that my little lappy can handle it.  No concerns about frame rate at all - although I've not faced a super-rush yet :)

#14 Posted by Jayzilla (2539 posts) -

not a blizz gamer but glad to hear everyone is having fun sans the issues i am reading about here.

#15 Posted by Jacob816 (136 posts) -

I've had some graphical hitches on my 2.5 year old MBP, running OX 10.6. I was able to play the beta at 1440 x 900, with most options set to medium, and things ran pretty smooth. Now the same settings are causing noticeable framerate and slowdown issues, to the point where I had to scale down the resolution and drop a lot of the settings to low. Isn't a finished product supposed to run better then the beta, not worse. Le sigh...

#16 Posted by GreatDane (40 posts) -

Im on a Macbok pro unibody: c2d 2,4 ghz, 2gb ram, 9600gt 256 mb.  osx 10.6.
 
And the game runs like shit, cant run medium!  
 
Gotta put all things to minium, and it looks like crap.

#17 Posted by Driadon (2990 posts) -

No issues here. My big ass laptop eats this game for lunch, which is a relief seeing as when I played the beta on my desktop I got some very inconsistent frame rates

#18 Posted by Myomoto (310 posts) -

How the hell does a game that has been in development for so long ship with issues such as "might melt your computer, sorry!". What the eff'?

#19 Posted by 234r2we232 (3181 posts) -

Does this affect the N64 version?

#20 Posted by MSUSteve (71 posts) -

I did have SC2 freeze on me last night when examining menu options.  Perhaps it was due to this overheating issue.  I updated my video card drivers and didn't have a problem after that.

#21 Posted by StupidGamer (155 posts) -

My first night was full of issues. I have the CE, and I had a failed install on the first attempt, several crashes after finally getting installed on the second attempt, and a corrupted install that forced me to use the Blizzard repair tool. After the 3rd game crash I was only through the second mission in single player and I gave up for the night. 
 
I'm running Windows XP, all settings at Ultra (by recommedation).

#22 Posted by NoXious (1335 posts) -

I goddamn hate the Haven mission. Had to stop trying after 5 attempts because I just cba with it at the moment. God that mission gets on my nerves. I want those achievements! Finished the mission without getting two of the three achievements :-(
I'll just swap to another mission that I probably can manage till I have the resources to ace that mission.

#23 Posted by letsgohome (19 posts) -
@sofacitysweetheart: HAHAHAHHAHAHAAH!
#24 Posted by DjRich (122 posts) -

A headset dropping the framerate. What?

#25 Edited by Darko (114 posts) -

Protip: if you're trying to use the blizzard downloader and it won't work, download the pirated version from your filesharing service of choice. Don't install any cracks for it, just install it and register as you would your version from Blizzard. Should work.
 
Having said that... I've had no issues.

#26 Posted by Rhombus_Of_Terror (2055 posts) -

Running the game on an eighteen month old PC build. I can run it at ultra apart from having the texture set to high. The game is beautiful to watch. I just wish the Battlenet loading on start-up could be a little smoother, though that could be down to the router I'm using.

#27 Posted by SSully (4060 posts) -

 
I run everything with a mix of ultra/high and i turned off reflections but i do get some janky frame rates every now and again. Its only during the cut scenes though, which is a bit odd. Its fine during game play, smooth as butter. I just think its funny that its for the cut scenes because i can get crysis to run at 60 FPS but i get the jitter with star craft cut scenes. 

#28 Posted by Teirdome (262 posts) -

There's a part of me that's chuckling after hearing all of the mac issues.  The only friend who had problems last night was the one super proud of his apple logo.

#29 Posted by DoctorWelch (2774 posts) -

I'v had a few weird connection issues with battle.net where it just logs me out randomly for no reason. It happened once in the middle of a match. It never happens with any other online game I am playing, and I play WoW, so idk what it is.

#30 Posted by HydraHam (1338 posts) -

Don't you have the disc? why on earth would you use the installer if you have the disc? i bought the CE yesturday, popped in the disc, did the small patch that took maybe 30-40 seconds and was ready to go
 
the only problem i came across was audio problems, huge stuttering problems which got fixed by turning off the echo effect.

#31 Posted by FuzzYLemoN (1600 posts) -

Guess I got lucky. Mine installed and patched like butter. I was playing with 30 minutes of getting home. Haven't had any issues since then either.

#32 Posted by Gav47 (1542 posts) -

Can anyone tell me is there a V-Sync option?

#33 Posted by Kumo (124 posts) -

Brad, the issue is that your upload is choking the download, a common problem with Blizzard's downloader. There's an option in the downloader to disable peer-to-peer downloading, so do that and it will download directly from HTTP servers.

#34 Posted by MachoFantastico (4307 posts) -

Haven't had any serious issues performance wise, the only issue I've noticed is balancing which still seems a little off. 

#35 Posted by Darko (114 posts) -
@Gav47:  Yes. It's in the graphic options
#36 Posted by VisariLoyalist (2991 posts) -

well, the only reason why people scrutinize blizzard games so much is because people love them so much. I don't think these issues are any worse than issues that most games have at launch especially games which involve such complicated programming with tons of piles of patches to balance the game.

#37 Posted by Boyling (185 posts) -

For some reason, the mission archives screen looks super wonky for me, and I do have some framerate issues right at the beginning of most missions. That's about it.

#38 Posted by Deathpooky (1343 posts) -

When I made my digital purchase the website threw a ton of errors at me, failed, and then charged my credit card 12 times.  I'm guessing billing will solve that, but until then it's a little uncomfortable having $600 in holds on my account.

#39 Posted by TwoLines (2762 posts) -

It's a PC game, it has bugs.
It's Blizzard, the game'll be patched.

#40 Posted by kratier (223 posts) -

i really wish there was someone legitimately discussing the issues about various units not being in multiplayer,
 
and people keep talking about MELEE multiplayer? what is that exactly?
 
And why hasn't blizzard talked about pricing of the next 2 games.

#41 Posted by hsj (2 posts) -

I was playing multi and notice my SCVs started idling after they had mined a bit... just sat there, had 4-5 of them doing nothing.  Clearly showed in the economy graph after the game.

#42 Posted by Ben_H (3206 posts) -

The little bit I've played it on my new 2.4 Ghz C2D MacBook with the 320M has been a great experience thus far.  It runs quite smooth on a mixture of medium and high. 
 
It's much better on my Desktop though but playing on my MBP will be good for at the lake where there's no internet.

#43 Posted by hsj (2 posts) -

Also, my Windows 7 mouse cursors are messed up at the moment, I believe that happened when was switching video modes from fullscreen windowed to just fullscreened.

#44 Posted by Gav47 (1542 posts) -
@Darko said:
" @Gav47:  Yes. It's in the graphic options "
So shouldn't that fix the overheating problem?
#45 Posted by plasmafrag (26 posts) -

I've been having some loading time issues and choppy framerate when a mission starts on a rig that should be able to handle it.

#46 Edited by Brackynews (3966 posts) -

How come people didn't just try the demo first to see how it runs on their machine?
 
Oh. Right.

#47 Posted by blacklab (1476 posts) -

I don't understand why this game would be so technically greedy.  It looks like a bunch of tonka toys fighting.

#48 Posted by Uberjannie (282 posts) -
@Ben_H:  The game requires internet just to start, does it not? I even thought you had to stay connected at all times even to play single player.
#49 Posted by Lydian_Sel (2452 posts) -

That's a real disappointment to hear considering the way most Blizzard games handle on your standard system. Kinda makes me glad I didn't rush out & grab a copy.

#50 Posted by Meowshi (2911 posts) -
@TomA said:
"

Mr Nicholson your a dumbass, that's Mengsk. And the rest of the people upset or shocked by the download servers sucking ass are dumbasses too. If you knew anything about Blizzard games, you should know that they are terrible for download and patch problems, like this one.

"
I hope you're banned.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.