Anyone else having trouble with Xbox Live matches?

#1 Edited by skrutop (3615 posts) -

Yesterday, I noticed that signal strength wasn't coming up for most of the listed matches in all modes.  After refreshing a few times, I realized that I was seeing the same names over and over again.  Whenever I made a match, nobody would connect after quite a long time.  It's still doing it today, and showing the same names as yesterday.  Has anyone else seen this?

#2 Posted by TheLastNeo (443 posts) -

I had this same thing happen to me last night... I was wondering what the hell was going on...     
 
Maybe its all the crazy MW2 Madness...   (highly unlikely..  but... thats the one thing that would be noticeably different)

#3 Posted by Jimi (1126 posts) -

Yeah I got it too :(.

#4 Posted by JJOR64 (19017 posts) -

LIVE was fucked up all day yesterday because of the stupid MW2 map pack.  It should be OK now.

#5 Posted by Jeffsekai (7042 posts) -
@JJOR64 said:
" LIVE was fucked up all day yesterday because of the stupid MW2 map pack.  It should be OK now. "
Yo fuck MW2
#6 Posted by JJOR64 (19017 posts) -
@Jeffsekai said:
" @JJOR64 said:
" LIVE was fucked up all day yesterday because of the stupid MW2 map pack.  It should be OK now. "
Yo fuck MW2 "
Agreed.  That shit fucked up my SF4 yo.
#7 Posted by skrutop (3615 posts) -

Yeah, it's fine now.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.