A Fix For Steam Workshop Mods Appearing To Not Install

#1 Edited by crusader8463 (14426 posts) -

Just thought I would share some advice for an annoying bug with Skyrim and the Steam Workshop not working as intended, as I think it's a common problem but I can not for the life of me find people talking about it. I had subscribed to a good 40+ mods in the workshop but whenever I would start the game the mods would never install. I went online and everything I could find said that when you started the launcher you would see it telling you in the bottom right corner that it was installing and that you would get a message saying when it was done. Well that never happened. Turns out that even though I never got the message of it telling me that it was installing the mods it was still downloading them, I just had no way of knowing.

So if your mods are not installing, just launch the game and let it sit at the launcher for a few minutes; even if it looks like it's not doing anything. To make sure things are being installed, just click on the "Data Files" button and you should see them starting to propagate as they download. Until they fix it the only way to make sure they are all installed is to go to your subscription list and make sure the number of subs you have match up with the number of installed mods listed in "Data Files".

I'm sure not everyone has this problem, but I'm even more sure I can't be the only one who has had this annoying "glitch". Thought I would try to save a few people some time hunting around for answers. Everything I found just said that it should work a certain way, but never gave suggestions on how to resolve it should it not. Hope this saves some folks some time.

#2 Posted by jd18b (43 posts) -

Thank God I found this thred.... I've had this problem since they first launch the workshop. Ill have to give it a try and let you know how it works.

#3 Posted by SSully (4272 posts) -

Yeah I have this issue as well, thanks for posting!

#4 Posted by Vampire_Chibi (169 posts) -

Thanks i just found this and i had never had a message appear, EVER!

so i really had no idea why nothing happened..

but i'm glad that i found this on giantbomb, whilst looking on skyrim forums >_>

anyways thanks \^u^

#5 Posted by ArcadiaExeter (86 posts) -

same here. thank you so much for this thread.

#6 Edited by Corax8421 (1 posts) -

So, uh. I guess I shouldn't have subscribed to 40+ mods before launching the game... but, it was like going through a candy store, picking out everything that looked remotely cool, because it was all free...!

Great tip. The Data Files list is being populated as I speak. I searched the entire Internet for a simple answer like this!

#7 Posted by crusader8463 (14426 posts) -

@jd18b: @SSully: @Vampire_Chibi: @ArcadiaExeter: @Corax8421: No problem. I was paranoid to think I might have been the only one to have this problem after not getting any replies for this when I made it a few months back. Glad to have helped.

#8 Posted by progamer76002 (1 posts) -

For everyone experiencing the lack of text indication on Data Files progress, I found a fix that worked for me. Changing a setting in windows fixed the visual area/verbose text informing me of what data files were being downloaded/updated/double-checked and what-not each time i launched Skyrim via steam.

For Windows 7 - 64bit OS... go to Control Panel -> Appearance and Personalization -> Display --> then set to "Smaller - 100%" text size, and click apply. You will have to log out of windows and log back in for it to take effect, but Skyrim launcher should now show the text indicating that it is working on your steam subscribed mods.

I figured this out after realizing i had recently toyed with that setting playing with my desktop and then spending hours trying to figure out what mod i might have installed toying with Skyrim, only to find someone mention on another forum the idea that Skyrim and windows 7 64 had some issue with text size. I put 2 and 2 together and figured it was me and not some mod.

I really hope this helps a lot of people who might have been experiencing the same thing.

#9 Posted by celien (1 posts) -

I just had to register to this site to THANK YOU i been googling like an idiot to find out wahts wrong and this is it i never seen any message either. Thanks alot

I can also confirm that the text size was the problem as said by progamer76002

#10 Posted by mjcobb22 (1 posts) -

i dont know who you are, or where you live, but one day i will give you a hug.

#11 Posted by JackStalker1998 (1 posts) -
#12 Posted by TessaWracked (52 posts) -

Wow, I've been pulling my hair out about this and now feel so much better. Also thanks for the tip progamer, I totally forgot I screwed around with text size when I moved my PC into the living room.

#13 Posted by terminadair (1 posts) -

my data files won't let me click on it

#14 Posted by BritishDragonborn (1 posts) -

@terminadair: you cant click on your data files becuse you havent enabled them

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.