Black screen immediately after launch.

#1 Posted by guusjo11 (8 posts) -

Hello,

So I've recently got Skyrim including DawnGuard and update 1.7, but I've got a problem, whenever I click play in the launcher or try running it via TESV.exe, it gets me to a blackscreen, which I can only get rid of by restarting my pc or open Task manager with CTRL+ALT+DEL and close it. Note that I have got a no-steam version (though I did try launching it via steam once, same results) and I have Windows 7 Ultimate, before re-installing windows 7 Ultimate, I never had this problem. My graphics card drivers are all up to date and yes, Skyrim detects my Nvidia 310M. Any help would be greatly appreciated!

Guus

#2 Posted by mosdl (3229 posts) -

Assuming you have a legal version of the game, I would try running the game as administrator and see if that helps.

Online
#3 Posted by Benny (1953 posts) -

@guusjo11: Start disabling things in the launcher and trying things there, then try making sure your graphics card isn't handling video quality settings on its own. I'd also try windowed mode, running as administrator. The usual stuff.

Perhaps check the official forum or steam forum for people with similar issues too.

#4 Posted by guusjo11 (8 posts) -

None of this has seemed to help.. I am running Skyrim as an administrator and with Windows XP SP 3 compatibility mode (standard). I've already checked similiar forums but none of the solutions has seemed to help.

What I've tried:

-Uninstalling and reinstalling Skyrim, including all of the updates, no luck.

-Disabling Dawnguard and run the game without it, no luck.

-Reinstalling Skyrim and try running without the updates, no luck.

-Changing things in Skyrimprefs.ini, no luck. (changed back though)

-Windowed mode, no luck.

So it goes exactly like this, I click "play" in the Skyrimlauncher, and all I get is a black screen, right from the start, when I hover my mouse over it, it shows a loading/not responding symbol and when I open task manager it says Skyrim is not responding, and closing it is only possible with task manager, which takes it's time closing it. I'm running Skyrim with my NVidia 310M graphics card on Medium settings (Launcher detected). How can I make sure the graphics card isn't handling things on it's own? Any way to check this with NVidia control panel?

#5 Posted by CL60 (16906 posts) -
@mosdl

Assuming you have a legal version of the game, I would try running the game as administrator and see if that helps.

He doesn't. There is no such thing as a non-steam version. The game is steam works.
#6 Posted by Zella (773 posts) -

Yeah it is most likely an issue with the crack or whatever you are using for the game, cause all legit versions use steam. If not I would try disabling any mods if you have them installed.

#7 Posted by Enigma777 (6078 posts) -

It's a quest. You gotta use magelight and kill the giant ass spider

#8 Posted by Capum15 (4929 posts) -
@Enigma777: I thought it was a giant crab. Then again, it has been a while since I've played Skyrim.
#9 Posted by Grimhild (723 posts) -
#10 Posted by guusjo11 (8 posts) -

@Grimhild: There is in Holland.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.