Is there a way to use the weapon rack in Breezehome?

#1 Posted by nemt (863 posts) -

I'd like to hang up some quest related weapons I never use, instead of just throwing them around.

#2 Posted by Rave (370 posts) -

There are wall mounts you equip the weapon you want to hang the press a and you will hang it. I hung the axe of winterrun above my front door and a lunar blade in my living area.

#3 Posted by Obsidian (346 posts) -

You cannot remove quest items from your inventory.

#4 Posted by nemt (863 posts) -

@Rave said:

There are wall mounts you equip the weapon you want to hang the press a and you will hang it. I hung the axe of winterrun above my front door and a lunar blade in my living area.

I'm holding the axe of whiterun and looking right at the mount but pressing A does nothing.

#5 Posted by Rave (370 posts) -

@nemt:

weird is there already a weapon on the mount? By holding you mean you can actually see it in your hand like you would to attack someone? Are you sure what you are looking at is a mount they are red I believe. Im pretty sure it was A I pressed maybe X? It worked for me first try, when I looked at the mount the first time a little tutorial message poped up explaining how.

#6 Posted by nemt (863 posts) -

Yeah, i have it drawn ready to attack and there's no weapon there already. Weird. I also never got a tutorial or anything - maybe because I didn't even notice the mounts the first time I went into the house?

This is Xbox, right?

#7 Posted by Shnowmon (12 posts) -

I am having the same issue, I have tried everything, but it still just behaves like a dead slab of furniture. I own the Breezehome in Whiterun, fully furnished on the Xbox 360. I have tried this with the weapon rack on the floor as well as the red ones on the walls. Nothing happens, no tutorial, nothing. >( I have also noticed that if I drop something from my inventory, arrange it within the room, then leave the house, the items will be back on the floor where I dropped them from my inventory. The only way around this is to drop the item, leave the house, enter the house again, then arrange them. That is the only way they will stay put. I have not tried any other houses yet to see if it is an isolated problem with that specific house. I hope Bethesda is aware of these problems as it is EXTREMELY annoying not being able to use my weapon racks and having to jump through two loading screens every time I want my decorations to save correctly.

P.S. Bookshelves work flawlessly, just as I always wanted them to. I am also running the game off the disk, I do not have it installed.

#8 Posted by Hemmelight (159 posts) -

Weird. I'm on PS3, and the bookshelves work perfectly fine, but the weapon rack and mounts do nothing. Not even a prompt to interact with it, no nothing. :/

#9 Posted by SirPsychoSexy (1328 posts) -

Working fine for me, maybe it only does 1h weapons?

#10 Posted by rjayb89 (7717 posts) -

I've put two-handed weapons near the bookshelf, so that's covered. Two, in fact.

#11 Posted by Napalm (9020 posts) -

I just wanted to bump this to let everybody know, (or whoever is having similar issues), that it seems the weapon racks de-activate if you only buy one or two items in your home and then enter your home. The only workaround that people are reporting is that you have to purchase all upgrades at once before you enter your home. Hopefully Bethesda fixes this, because this is a pretty shitty issue to have, especially if you want to display your armored earnings.

Until then, I hope everybody has a save from before you purchased your homes. I know I don't.

Source!

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.