PC Performance Issues.

  • 64 results
  • 1
  • 2
#1 Posted by Wampa1 (688 posts) -

Picked up Skyrim in the sale this week on steam and seem to be having issues maintaining a solid framerate, I meet the "Ultra" requirements and can run other games like Space Marine without any issue. But when in the first person view on Skyrim it gets incredibly choppy even on Low setting, Any ideas what I can do to fix this?

#2 Posted by MasturbatingestBear (1190 posts) -

Do you have any mods installed?

#3 Posted by Wampa1 (688 posts) -

@MasturbatingestBear: Nope just the current up to date version of the game, I disabled the high res textures in case that was the issue but it hasn't made any difference.

#4 Posted by wewantsthering (1570 posts) -

Did you update your video card drivers?

#5 Posted by MrKlorox (11209 posts) -

How choppy, and where at? The game can hover around 18fps for me in some places, looking in certain directions (at the top of the steps in Markarth for example). Does this happen in third person? 
 
What video card do you have? If Nvidia, Ambient Occlusion might be turned on, which can eat frames.

#6 Posted by Wampa1 (688 posts) -

@wewantsthering: To the best of my knowledge yes, to be frank this is my first gaming PC so i'm a bit of an idiot when it comes to these things. I just went to AMD's site and downloaded the Control center it said i needed. Like i said stuff like Space Marine runs like a dream at the highest settings though.

#7 Posted by wewantsthering (1570 posts) -

@Wampa1: Specs?

#8 Posted by SlasherMan (1725 posts) -

Post your specs, maybe?

#9 Posted by Wampa1 (688 posts) -

@MrKlorox: I have an AMD, It's choppy no matter where i am just when ever i look around, which totally dissapears in 3rd person, which is the part thats confusing me.

#10 Posted by wewantsthering (1570 posts) -

You need to be more specific than AMD...what processor speed, memory, video card, etc.

#11 Posted by Vitor (2822 posts) -

@Wampa1 said:

@MrKlorox: I have an AMD, It's choppy no matter where i am just when ever i look around, which totally dissapears in 3rd person, which is the part thats confusing me.

You need to be more specific. The brand doesn't help.

Go to the start button, and in the empty search box, type 'dxdiag' (minus the quotation marks). Copy the main body of info on the first page, and then click the next panel to find you graphics card info and post it all here.

#12 Edited by Wampa1 (688 posts) -

Time of this report: 2/9/2012, 23:25:56

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110622-1506)

Language: English (Regional Setting: English)

System Manufacturer: Advent

System Model: DT1410

BIOS: BIOS Date: 09/22/11 14:34:16 Ver: 04.06.04

Processor: Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz (4 CPUs), ~3.0GHz

Memory: 6144MB RAM

Available OS Memory: 6126MB RAM

Page File: 2675MB used, 9574MB available

Windows Dir: C:\Windows

DirectX Version: DirectX 11

DX Setup Parameters: Not found

User DPI Setting: Using System DPI

System DPI Setting: 96 DPI (100 percent)

DWM DPI Scaling: Disabled

DxDiag Version: 6.01.7601.17514 64bit Unicode

Card Info.

Card name: AMD Radeon HD 6700 Series

Manufacturer: Advanced Micro Devices, Inc.

Chip type: ATI display adapter (0x68BA)

DAC type: Internal DAC(400MHz)

Device Key: Enum\PCI\VEN_1002&DEV_68BA&SUBSYS_03FE1043&REV_00

Display Memory: 3819 MB

Dedicated Memory: 1012 MB

Shared Memory: 2806 MB

Current Mode: 1920 x 1080 (32 bit) (60Hz)

Monitor Name: Generic PnP Monitor

Monitor Model: LG TV

Monitor Id: GSM0001

Native Mode: 1920 x 1080(p) (60.000Hz)

Output Type: HDMI

Driver Name: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll

Driver File Version: 8.17.0010.1114 (English)

Driver Version: 8.930.0.0

DDI Version: 11

Driver Model: WDDM 1.1

Driver Attributes: Final Retail

Driver Date/Size: 12/6/2011 03:16:00, 933888 bytes

WHQL Logo'd: Yes

#13 Posted by SeriouslyNow (8534 posts) -

That system shouldn't be having performance issues in this game.  What resolution do you run this game in?

#14 Posted by Zelyre (1207 posts) -

@SeriouslyNow: Looks to be 1920x1080 by his monitor's native resolution.

This machine should have no issues running Skyrim on High at 1080p.

@Wampa1: Don't run your shadows on ultra. Try dropping them to high or medium. They're not rendered by the GPU for some stupid reason, so the performance hit is crazy. There are newer drivers for your card, but I'm running older ones than you are with no issues. Since you're using an AMD card Steam can update them for you. Go to Steam, then chose Update AMD Video Drivers. But, I'd try this first:

Right click on your desktop, open the catalyst control center. Go to gaming. then 3d application settings. Put everything on Use Application Settings. Set your anti-aliasing mode to multi-sample AA, or performance.

My only other thought is that since Skyrim relies heavily on CPU over GPU, you're having some sort of thermal issue and the CPU is clocking itself down. So, a slow CPU will hurt your frame rate, no matter what your graphic settings are at. If the step above doesn't fix your performance issues, you'll need to get your hands a lil dirty. PC Gaming, it'll accidentally learn ya somethin!

http://www.cpuid.com/softwares/cpu-z.html

CPU-Z. Very useful if you're overclocking, but just very useful in general. This will show you what your processor speed is currently running at. Your Core i5 will throttle itself depending on how much processing its doing. If the processor gets hot, it'll lower its clock speed drastically. Fire up CPU-Z and after a few seconds, it'll start reading off your CPU voltage and speed.

http://www.mersenne.org/freesoft/

Prime 95. You can use this as a stress test. It'll work every one of your CPU cores to 100% causing them to throttle to their max speed and generate a lot of heat.

http://www.almico.com/sfdownload.php

Speedfan. Also useful if you're overclocking, but it has many other uses as well. It takes readings from various sensors on your computer, including your hard drive's SMART and thermal temperatures. I'm not sure where the i5 starts to throttle itself down to protect itself from heat, but if your CPU core's are above 75 degrees celsius, I'd consider that a cause for concern.

Fire up SpeedFan, then fire up CPU-Z, then fire up Prime 95 and do a torture test. If that processor temperature jumps up incredibly fast past 75 degrees C, I'd say you're having thermal issues. Also, if it hits that temperature, check CPU-Z and see if the CPU's speed has dropped. If so, this is why Skyrim runs dog slow.

If Advent used the stock Intel heatsink, the little pins that hold the heat sink may have come loose in shipping. I found the intel heatsink retention mechanism to be the worst thing I've had the joy of trying to use since the original Athlon days with the clips that required -so- much force that people's arms would shake from the strain, heh.

#15 Posted by SeriouslyNow (8534 posts) -
@Zelyre: That's his display res, who knows what he's running the game at.  The shadows are rendered by the gpu, the framerate hit comes from the fact that at ultra they are done in 3 passes instead of two in high and 1 on medium and low.  The rest is pretty good if generic advice.
#16 Edited by Wampa1 (688 posts) -

@Zelyre: Wow that's a few ideas to get me started at least, like I said totally new to this but i'll give everything a try just forgive me if i'm back asking "durr what dah GPU do?" in a few hours! I tried dropping the shadows and using catalyst but it didnt seem to have any effect.

@SeriouslyNow: Running at 1920x1080, tried dropping it low but it didn't make a difference.

Should also note it's constantly hitching when running, talking or fighting at this point.

#17 Edited by newhaap (421 posts) -

@Wampa1: My frame rate usually gets noticeably choppy in Whiterun. Try reducing the distant object detail and the fade distances in the View Distance settings, after some tweaking I managed to remove the choppiness in Whiterun by very slightly giving up the level of detail for distant objects, which I rarely pay attention to anyway.

#18 Posted by evilrazer (489 posts) -

I believe steam has downloaded HD Textures for you and turned them on. I had the same issues you have until I turned them off in the launcher.

Start your game > Data Files > Check HighResTexturePack01 and HighResTexturePack02 off the list.

#19 Posted by Wampa1 (688 posts) -

@evilrazer: Turned them off already, as i suspected that was the issue but no luck :(

@newhaap: Distant object detail was all the way down and didn't make a difference either, totally baffled.

#20 Posted by SeriouslyNow (8534 posts) -
@Wampa1 said:

@Zelyre: Wow that's a few ideas to get me started at least, like I said totally new to this but i'll give everything a try just forgive me if i'm back asking "durr what dah GPU do?" in a few hours! I tried dropping the shadows and using catalyst but it didnt seem to have any effect.

@SeriouslyNow: Running at 1920x1080, tried dropping it low but it didn't make a difference.

Should also note it's constantly hitching when running, talking or fighting at this point.

That sounds like something else is heavily taxing your CPU.
#21 Posted by Wampa1 (688 posts) -

@SeriouslyNow: Any idea what it could be? I'm not running anything but Steam and the game when I'm playing.

#22 Posted by SeriouslyNow (8534 posts) -
@Wampa1 said:

@SeriouslyNow: Any idea what it could be? I'm not running anything but Steam and the game when I'm playing.

What about Antivirus software?  Windows Updates?  Running any network shares?
#23 Posted by Tru3_Blu3 (3210 posts) -

Is the game constantly lagging and twitching for you? If so, I have the same exact problem, and my rig is pretty good with running Skyrim smoothly before the 1.4 patch.

#24 Posted by Wampa1 (688 posts) -

@Tru3_Blu3: Yeah, I've considered reinstalling it, is there anyway to remove the patches on steam?

@SeriouslyNow: Nope just Steam, made sure to turn everything else off just incase.

#25 Posted by SeriouslyNow (8534 posts) -
@Wampa1 said:

@Tru3_Blu3: Yeah, I've considered reinstalling it, is there anyway to remove the patches on steam?

@SeriouslyNow: Nope just Steam, made sure to turn everything else off just incase.

How do you mean 'turn everything off'?  I want you to tell me what Antivirus software you have etc. 
#26 Edited by Wampa1 (688 posts) -

@SeriouslyNow: Sorry like i said new to it, running Avast free. Ment that i'd closed stuff like browsers, itunes and such.

#27 Posted by SeriouslyNow (8534 posts) -
@Wampa1 said:

@SeriouslyNow: Sorry like i said new to it, running Avast free.

Avast has been known to slow down computers when it does background 'idle' scans.  Believe it or but Skyrim (without the HD texture pack) doesn't actually tax your machine that hard (it uses two cores of a quad core CPU for example) and that might make make Avast think there's idle time to scan.  The issue comes from the fact that HDD access is often a lot more system intensive than rendering a scene in Skyrim and it can cause the computer to halt as Skyrim is left waiting for Avast to finish accessing the disc as Skyrim wants to stream level data (map information, quest information objects, characters, textures and sounds) from the disc at the same time.  Is HDD light constantly flashing?
#28 Posted by CannonGoose (373 posts) -

The 1.4 beta update gave me a much more solid framerate but also introduced what I think you are experiencing: Micro stuttering.

I can stop the micro stutters by turning off vsync and triple buffering, but then I get crazy amounts of screen tearing :(

#29 Posted by Wampa1 (688 posts) -

@CannonGoose: Looked up some videos of micro stuttering and that looks like my issue. It's like a small but constant jerk to everything. Would removing the patches help?

@SeriouslyNow: The HDD isn't constantly flashing, but should I try turning Avast off and running the game incase it isn't the micro stuttering issue? Again thanks for the help and patience.

#30 Posted by mustachioeugene (510 posts) -

@Wampa1: If I recall correctly, Avast has a silent/game mode setting.

#31 Posted by Wampa1 (688 posts) -

@mustachioeugene: Got it running on that mode already, just seems to turn off notifications during gameplay.

#32 Posted by SeriouslyNow (8534 posts) -
@Wampa1 said:

@mustachioeugene: Got it running on that mode already, just seems to turn off notifications during gameplay.

I'd recommend uninstalling it completely and using MS Security Essentials instead.  It's a lot more efficient and won't intrude on your gaming.
#33 Posted by Talis12 (488 posts) -

while running the game hit ctrl+alt+del and start taskmanager.. go to the processes tab and see if anything is taking up a lot of memory during play.. might find your issue that way

#34 Posted by Wampa1 (688 posts) -

Tried everything suggested but still no luck incredibly hitchy at any setting even reinstalled.

#35 Posted by Demoskinos (14874 posts) -

I would try setting shadows to low and enabling FXAA as FXAA is much less a strain on the system and the results are pretty are pretty similar and unless your a huge videophile you won't notice the difference. Beyond that you might want to try Skyboost if they did indeed update it to go with the 1.4 patch.

You could also just simply toy with it and start on absolute mininum settings gradually turning things up until you deduct where your PC is struggling with it.

#36 Posted by Wampa1 (688 posts) -

Just tried running it in windowed mode and it ran without issue..

#37 Posted by SeriouslyNow (8534 posts) -
@Wampa1 said:

Just tried running it in windowed mode and it ran without issue..

Then it's your GPU.  Look up bordless windowed mode mod for Skyrim.  Get it.  Enjoy :)
#38 Posted by Wampa1 (688 posts) -

@SeriouslyNow: Well it ran smooth windowed at 800 X 450. I'll try it with the mod though!

Thanks to everyone who replied really appreciate people giving advice!

#39 Posted by SeriouslyNow (8534 posts) -
@Wampa1 said:

@SeriouslyNow: Well it ran smooth windowed at 800 X 450. I'll try it with the mod though!

Thanks to everyone who replied really appreciate people giving advice!

At that res ANY game should run smooth on your machine.  Try it Windowed at full res.
#40 Edited by BaneFireLord (2941 posts) -

This might sound stupid, but I read that apparently having the "360 Controller" box checked in the options menu eats frames somehow if you're using mouse and keyboard.

#41 Posted by Wampa1 (688 posts) -
#42 Posted by WilltheMagicAsian (1546 posts) -

@Wampa1: Are you running two GPUs in crossfire? That may be the cause of your microstutter. Try disabling one.

#43 Posted by Wampa1 (688 posts) -

@WilltheMagicAsian: Total layman with this stuff, i posted my Specs a page or so back if you look at them it should say, if you see that is the case how would i disable one?

#44 Edited by WilltheMagicAsian (1546 posts) -

@Wampa1: Somewhere in your GPUs control panel probably under "Crossfire" it should let you disable it, that is, if you're running multiple GPUs (at least it should, I haven't used an ATi card since the AGP days.) If you're really not sure you're running multiple GPUs (I'm assuming you bought a pre-built?) then you can manually open up your case and check or just check the back of the computer case, your card should only take up two slots (minus any expansion cards like sound, eSata, USB, what have you,) so if you have four taken up that should mean you're using two cards. I don't remember if DxDiag lists if you have two cards or not.

You can also try the latest beta drivers.

http://downloads.guru3d.com/download.php?det=2848

#45 Posted by Wampa1 (688 posts) -

@WilltheMagicAsian: Gave the Drivers a try but no luck.

#46 Posted by buft (3318 posts) -

I have a similar PC but with an AMD 6100 processor and 8gb of Ram, my card is the XFX radeon HD 6770, i wonder if i will have similar issues as you. I am considering buying Skyrim

#47 Posted by Wampa1 (688 posts) -

@buft: I don't want to advise you against it since by all accounts it should work, If i get mine running i'll let you know.

#48 Posted by Wampa1 (688 posts) -

Also noticed textures now pop in and out while i'm playing, sorry if i keep bringing back a dead topic just driving me crazy.

#49 Posted by FritzDude (2263 posts) -

My apologies if this has already been discussed and answered, but have you tried to downgrade the resolution to 1280x720p? Or verified integrity of Steam game cache?

#50 Posted by SlasherMan (1725 posts) -

@Wampa1 said:

Also noticed textures now pop in and out while i'm playing, sorry if i keep bringing back a dead topic just driving me crazy.

I would wipe the drivers and reinstall the latest ones. If you install new drivers when old ones haven't been removed correctly, it can result in several issues. This could be one of them.

Follow these steps:

  1. Download Driver Sweeperand install.
  2. From the Windows control Panel, uninstall the Catalyst Control Center and all related AMD video drivers.
  3. Once it is done, you'll be asked to restart the computer. Do so, but instead of going into Windows normally, log on to Safe Mode (F8 before the Windows logo appears).
  4. While in Safe Mode, start Driver Sweeper. Check "ATI - Display" and then click the Analyze button. You'll see a long list of files and registry entries. You should then click Clean.
  5. Once it's done, restart and boot back normally into Windows.
  6. Install new drivers (Do not allow Windows to install its own, download the latest driver here).

It might seem like a lot to do, but it barely takes 5 minutes and if you get used to doing this every time you want to install a new set of drivers, you'll save yourself quite a few headaches in the future. I don't guarantee that this will actually solve your problems, but it's certainly worth a shot considering nothing else seems to have solved it so far. At the very least, you'd be able to rule out driver conflicts.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.