Why wont this run well on my rig?

#1 Posted by loserkid962 (96 posts) -

Hi all, I just bought The Witcher 2: Assassins Of Kings, and i've noticed that it runs worse on my computer than my buddies alienware laptop, and my computer's fairly new.  
I have an i7 860 @ 3.33GHz 
4 GB DDR3 1600 RAM 
Dual ATI 5770's in Xfire 
i exceed all the standards for the system requirements, but still this game runs really shitty on high spec, even with SSAO and AA turned off.. anyone got any ideas?

#2 Posted by loserkid962 (96 posts) -

I'm running it in 1080p, also.

#3 Edited by AlexW00d (6275 posts) -

Turn uber sampling off.

Also try disabling one 5770 and see if it is better, if it is then dual gpu drivers are still shit.

#4 Posted by loserkid962 (96 posts) -

I done did that. Still doesn't run smoothly.

#5 Posted by lockwoodx (2479 posts) -

Alienware tunes and overclocks their systems for the customer. Do you just call your PC a "rig" to be cool or do you actually know how to use it?

#6 Posted by project343 (2825 posts) -

My "rig" is roughly the same, and I certainly have issues running the game. Need to play it on medium to high.

#7 Posted by buft (3317 posts) -
@Buzzkill said:

Alienware tunes and overclocks their systems for the customer. Do you just call your PC a "rig" to be cool or do you actually know how to use it?

im sure he does, theres a button on it to turn it on and several other buttons you can use to type. 
#8 Posted by Ghost_Cat (1439 posts) -

Doesn't the game still have some issues with ATI cards?

#9 Posted by lockwoodx (2479 posts) -

Every game has issues with ATI drivers. The cards run great ;)

#10 Posted by Heltom92 (710 posts) -

Make sure you have the newest drivers, they released an update recently to fix problems that people were having with TW2.

#11 Posted by JoeyRavn (4974 posts) -

You could try lowering individual settings to see which one is breaking your performance. Games sometimes do that. Borderlands with real-time shadows = crap, without them = smooth as silk.

#12 Posted by AlexW00d (6275 posts) -

@Ghost_Cat: I'm running it 50fps with everything but ubersampling on a hd6870 so I doubt it.

#13 Posted by TorMasturba (1094 posts) -

@Ghost_Cat said:

Doesn't the game still have some issues with ATI cards?

I have the ATI saphire radeon 6870 1GB and I had this game set to high in all fields so... No?

#14 Edited by TorMasturba (1094 posts) -

@JoeyRavn said:

You could try lowering individual settings to see which one is breaking your performance. Games sometimes do that. Borderlands with real-time shadows = crap, without them = smooth as silk.

Yeah, I remember it was called something like shadow tesselation, and older cards didn't have the right hardware to process tesselation, or somesort like that.

Regardless, this's some sound advice here though.

#15 Posted by ninjakiller (3405 posts) -

@Buzzkill said:

Alienware tunes and overclocks their systems for the customer. Do you just call your PC a "rig" to be cool or do you actually know how to use it?

Yeah and overcharges on average 500-1000 bucks. Alienware is for noobs.

#16 Posted by Rolyatkcinmai (2687 posts) -

@loserkid962 said:

Hi all, I just bought The Witcher 2: Assassins Of Kings, and i've noticed that it runs worse on my computer than my buddies alienware laptop, and my computer's fairly new. I have an i7 860 @ 3.33GHz 4 GB DDR3 1600 RAM Dual ATI 5770's in Xfire

Well there's your problem. You want to run your graphics cards in CrossFire. Xfire is just for chatting with friends who are playing other games, and has largely been replaced with Steam Community.

#17 Posted by SlasherMan (1725 posts) -
@Heltom92 said:
Make sure you have the newest drivers, they released an update recently to fix problems that people were having with TW2. 
@JoeyRavn said:

You could try lowering individual settings to see which one is breaking your performance. Games sometimes do that. Borderlands with real-time shadows = crap, without them = smooth as silk.

Solid advice here indeed.
 
Also, consider trying the application profiles on Rage3D. Should prove to be helpful.
#18 Posted by McGhee (6094 posts) -

I named ma rig "The Porkchop Express". It really hauls.

#19 Posted by Leekspin (34 posts) -
#20 Posted by AlexW00d (6275 posts) -

@leekspin: I fully imagine he is running 64-bit windows. I don't know why he wouldn't.

#21 Posted by FritzDude (2263 posts) -

Wow... reading all of this is really weird for me. I've seen several posts and threads now here and on different forums about the game running slow on pretty high PC's, yet my shitty old PC with 2,4ghz processors, 4gb RAM and a recently bought Nvidia GTX 560 can run the game in 1080p on auto-high settings with 40-60 Fps.  
 
PC makes no sense. 
 
The only thing i can come up with is that you 100% update your PC, DirectX and graphics drivers. Also you can try gameBooster, it's a pretty neat application for gaming.

#22 Posted by CashBailey (805 posts) -

@McGhee_the_Insomniac said:

I named ma rig "The Porkchop Express". It really hauls.

Win.

#23 Posted by Binman88 (3687 posts) -

I run it one two gtx280s, an i7 920 and 6gb ram, and can't run it smoothly with everything at its highest at 1920x1200. A 5770 is less powerful than a 280, so it makes sense that you'd need to lower some stuff. Asides from ubsersampling and aa; shadows, shadowed lights and lod distance are the real killers.

#24 Posted by Raineko (433 posts) -

I'm running this game with my Phenom II X4 955 3,2 GHz and the good old 4870 X2 (god bless the good old 4870 X2) on high settings without a problem.
Download GPUz and check if Crossfire mode is enabled, because if not your power supply is too weak.

#25 Edited by ShadowSkill11 (1783 posts) -

@buft said:

@Buzzkill said:

Alienware tunes and overclocks their systems for the customer. Do you just call your PC a "rig" to be cool or do you actually know how to use it?

im sure he does, theres a button on it to turn it on and several other buttons you can use to type.

So... that would be a no or you have no idea then.

The game runs great on my home computer with SLI Nvidia 470's and my Alienware M18x laptop with SLI Nvidia 460's. Just turn of the Ubersampling and the game runs like a dream.

#26 Posted by sutro (2 posts) -

there,s np at all with ati cards on this game,it runs on ultra with ubersampling on , getting 40-50 fps on my alienware aurora r3 with a radeon hd 6990

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.