Failed to Initialize Direct3D

#1 Edited by Colourful_Hippie (4328 posts) -

So Tomb Raider unlocked on Steam but I can't play because when I press play in the launcer a dialogue box appears that says "Failed to Initialize Direct3D". Doing some searching on the matter it looks like the problem is unique to nvidia users. I guess that's what I get for preordering.

It's eventually going to get fixed but I'm just giving a heads up. At least I didn't pay full price for this so I'm not too bummed about waiting to play something that I've been curious about.

EDIT: Someone in the Steam forums helped me out with this fix. For those of you having similar issues try downloading this registry file. Unzip, right click, then merge, and you should be set. It worked for me and it turns off exclusive fullscreen which seemed to be the problem for people.

#2 Edited by Ares42 (2559 posts) -

Turn off exclusive fullscreen.

#3 Posted by Colourful_Hippie (4328 posts) -
#4 Posted by Ares42 (2559 posts) -

options in the launcher, top right corner.

#5 Edited by Colourful_Hippie (4328 posts) -

@ares42: Pressing options just causes it to crash.

#6 Posted by Ares42 (2559 posts) -

Sounds bad, but ye fixed the "Failed to Initialize Direct3D" for me, and several other people according to steam forums. Try validating or something I guess ?

#7 Posted by InformationHigh (21 posts) -

@ares42: Pressing options just causes it to crash.

Try this, it at least let me get into the options:

http://steamcommunity.com/app/203160/discussions/0/846946775331888860/#c846946775332549723

#8 Posted by Colourful_Hippie (4328 posts) -

@informationhigh: I'm way too lazy to do any of that right now. I'll just wait for the eventual fix, thanks though.

#9 Posted by InformationHigh (21 posts) -

@informationhigh: I'm way too lazy to do any of that right now. I'll just wait for the eventual fix, thanks though.

Yeah it sucks, I had to re-verify my files and now it's downloading 1.1 GB of something. Apparently people with nvidia cards are getting tons of crashes also. PC master race.

#10 Edited by Jams (2959 posts) -

@informationhigh said:

@colourful_hippie said:

@informationhigh: I'm way too lazy to do any of that right now. I'll just wait for the eventual fix, thanks though.

Yeah it sucks, I had to re-verify my files and now it's downloading 1.1 GB of something. Apparently people with nvidia cards are getting tons of crashes also. PC master race.

I'm getting a weird graphical glitch right now myself. Uploading a video on youtube incase.

My game just crashed while I had it paused to pour another cup of coffee. frak

crashed again while I was playing. well I'm done for the morning.

#11 Edited by Tearhead (2147 posts) -

@jams: Yeah, I'm getting that same graphical glitch too. Rolling back to NVIDIA driver 310.90 allows me to play with tessellation on without crashing. Also had to turn off stupid hair thing (TressFX) 'cus that eats up too many of my frames. Which sucks, 'cus I kinda like the stupid hair thing, even though it's kind of distracting in a real uncanny valley sort of way.

#12 Posted by Ethereal (102 posts) -

I am on newly purchased/installed Sapphire HD7850 and got the same error. If you turn off exclusive full screen you can get it to launch. Then it seems when you are messing with the settings, switch the basic settings level to custom and leave "exclusive full screen" unchecked. Also maybe try to do all of your settings tinkering in the launcher and not the game. This is obviously not ideal. Looking for more info on a fix if anyone has one.

#13 Posted by psylah (2161 posts) -

@ares42 said:

Turn off exclusive fullscreen.

This tip helped me fix my problem A++++++++++++++++++++++++ would read again

#14 Posted by Colourful_Hippie (4328 posts) -

@psylah said:

@ares42 said:

Turn off exclusive fullscreen.

This tip helped me fix my problem A++++++++++++++++++++++++ would read again

It would have fixed mine but pressing options causes the launcher to crash, had to use another fix.

#15 Edited by cloudnineboya (762 posts) -

Colourful_Hippie go into steam folder look for steamapps/common. then click on DXSETUP and that should update for you it might work helped me before with a problem i had once .

#16 Edited by mavismoog (1 posts) -

I have tried un-checking exclusive fullscreen.

I have tried "regedit" and altering the value to 9 on the "RenderAPI"

I have tried contacting Steam Support (what an appalling service!)

Nothing has worked for me., I am still getting the Error "Failed to initialize direct 3d with current settings".

I hope I can get my money back because I've just about lost patience with this crap.

#17 Posted by Pie (7035 posts) -

Errr so this thread has 32,871 views. Hmph

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.