Fix for crashes on Nvidia GPUs

#1 Posted by Vitor (2809 posts) -

Turn off tesselation. Fixed the issue completely for me. Was crashing once every few minutes after the cave section now it hasn't happened once.

Also, if you want to use the cool tressfx hair stuff but don't like the performance hit, turn off High Precision to compensate. Big performance gains for a tiny downgrade to shadows/lighting but I think the hair effects more than make up for it.

#2 Posted by iceman228433 (572 posts) -

What ever as much as it pisses me off I am just going to wait for new drivers I want to play this game at it's maximum.

#3 Edited by killacam (1284 posts) -

Yeah, worked for me. Did you also get weird tearing at the same places (either near the top or the bottom of the screen) with tesselation on? it went away as soon as I turned it off. Weird.

So what exactly does high precision do? It didn't seem like it was hitting my fps too hard..

Also, any chance of a new driver better optimized for tressFX?

#4 Edited by GiroMindTricks (63 posts) -

It crashes for me at the campfire where you unlock fast travel. Tried turning off tessellation and no joy. Also tried turning off the exclusive fullscreen, v-sync, tried older and beta drivers and several other 'fixes' and still no luck.

Nvidia have said they are aware of the issue and are working on it. Apparently they only got the code of the final build this weekend and it created a lot of instability.

I'm just gonna wait for the driver update or a patch and just start again, only about 90 mins into the game.

#5 Posted by GiroMindTricks (63 posts) -

Quote of post for those that are interested and link

"We are aware of major performance and stability issues with GeForce GPUs running Tomb Raider with maximum settings. Unfortunately, NVIDIA didn’t receive final code until this past weekend which substantially decreased stability, image quality and performance over a build we were previously provided. We are working closely with Crystal Dynamics to address and resolve all game issues as quickly as possible.

In the meantime, we would like to apologize to GeForce users that are not able to have a great experience playing Tomb Raider, as they have come to expect with all of their favorite PC games."

#6 Posted by RVonE (4601 posts) -

Oh but it gets better!

"Hi Brent, this isn't solely a driver issue. The developer needs to make some changes on their end to fix their issues on GeForce GPUs. This will require code changes to the game."

#7 Posted by Vitor (2809 posts) -

@killacam said:

Yeah, worked for me. Did you also get weird tearing at the same places (either near the top or the bottom of the screen) with tesselation on? it went away as soon as I turned it off. Weird.

So what exactly does high precision do? It didn't seem like it was hitting my fps too hard..

Also, any chance of a new driver better optimized for tressFX?

I have loads of tearing in cutscenes but none in actual gameplay which is weird.

#8 Posted by Tearhead (2147 posts) -

Roll back to Nvidia driver 310.90 if you want to use tesselation without crashes. Worked for me (GTX 670).

#9 Posted by jsnyder82 (725 posts) -

Turned off Tesselation and Exclusive Fullscreen (have no idea what that even is) and it worked for me.

But Nvidia's really good about fixing these issues and having timely driver updates, so I have no doubt there will be a patch soon.

#10 Posted by CollegeGuyMike (388 posts) -

Wow, weird. I have a Nvidia card and haven't had any issues so far. Hope it gets worked out soon, it's a pretty fun game.

#11 Posted by Jams (2959 posts) -

I just turned off tressfx, tesselation and exclusive fullscreen to fix all the problems I was having (plus I lowered AF to 8x and shadow resolution to medium). The game looks a lot worse, but the framerates are super solid and I'm not getting any graphical glitches or crashing to desktop every 15mins.

#12 Posted by zenmastah (871 posts) -

Ive found that Level Of Detail at Normal helps when enabling other stuff.
Also does anyone know any bits for MSAA, or does that even work well with this game?

#13 Posted by killacam (1284 posts) -

@zenmastah: MSAA definitely destroys my framerate, but I think that's as much a part of the 660 ti's small memory bus as anything else.

@vitor: Yep, that first cutscene was hard to look at and a really disappointing way to start an otherwise great looking game. Stayed at 30fps too, whereas I mostly hover a lttle under 60 in game.

#14 Edited by Korwin (2813 posts) -

@jams said:

I just turned off tressfx, tesselation and exclusive fullscreen to fix all the problems I was having (plus I lowered AF to 8x and shadow resolution to medium). The game looks a lot worse, but the framerates are super solid and I'm not getting any graphical glitches or crashing to desktop every 15mins.

Lower AF will net you almost zero results, that functionality has been virtually free from a performance perspective for 10 years.

#15 Posted by rebgav (1429 posts) -

Are the problems limited to 600-series cards? I've had no problems so far with my 580s, current beta drivers.

#16 Posted by SlashDance (1801 posts) -

I got pretty good performance just by turning off tesselation, but of course I have another problem. There's a weird flicker around bushes, it looks like the shadows are acting up but it happens even with everything set to low.

Anyone having that issue ?

Online
#17 Posted by zenmastah (871 posts) -

Yeah, theres something going on with the shadows, its Skyrim all over again..

#18 Posted by SlashDance (1801 posts) -

I tried the beta drivers because why not... It actually fixed the flickering.

Online
#19 Edited by thetenthdoctor (291 posts) -

Old ass i5 655k (dual core) and overclocked GTX470 here, and no crashes. Only issue I've had is a strange "jumping "in the image when I'm in large areas such as the first area with the hand crank door. Tried disabling things one at a time, and it turned out to be Post FX. I'm guessing it's a motion blur bug on Nvidia, and disabling it got rid of the weird glitch.

Outside of that, I'm very surprised at how good this looks and runs on my aged hardware. 60fps in the caves and intro sequence, and still above 30 in the huge climbing areas. It chugs a bit in those big open spaces, but still better than a 360 or PS3 would do.

#20 Edited by thetenthdoctor (291 posts) -

Forgot to mention settings for folks like me not running a supercomputer.

1920x1080, triple buffered, FXAA, 60hz. High graphical preset, then manually upped textures to ultra, tesselation on and PostFX & TressFX off. Game looks really good, even on a several year old machine.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.