Microstuttering regardless of framerate

#1 Edited by Teclo (139 posts) -

I actually have this in a number of games, though it does seem pretty random which ones. Sometimes a beautiful-looking game will be stutter free, other times a pretty old and basic-looking game will stutter like that dude from Police Academy. What I'm referring to is this almost heartbeat-like judder that goes on regardless of the framerate of the game. The fps readout could be saying 60+fps and still, every second or so, jolt... jolt... jolt.

It's really annoying, it's worse than simply having a bad framerate because it's so unpredictable. It's not just "kind of choppy", it's like someone's randomly pausing and unpausing a DVD. It doesn't matter how low or high the settings are (nor in other games). I actually have the exact processor named in the recommended and the exact amount of RAM also, plus my graphics card is the one mentioned. I know "recommended" doesn't mean "fucking amazing, 4000 frames per second", but this is a joke. It's like I'm trying to play it on a Dell PC from 2001.

Edit: And yes, I have checked background processes and all that by-the-number troubleshooting stuff. I've read a lot about this problem with FarCry 3, a game I got it horribly with, and none of the usual solutions helped me. As the nun from Jay and SIlent Bob Strike Back once said, "Help me Giant Bomb, you're my only hope".

#2 Edited by JJWeatherman (14558 posts) -

@teclo: OK, here's an idea: have you tried a framerate limiter? I had an issue with visual choppiness in Skyrim which was fixed by forcing the game into a 60 frame per second maximum. Apparently some games like to over render and it causes the issue. Although I will say that your issue seems more severe than mine, but it's probably worth a try.

Search for MSI Afterburner and download it. It should come with another program called "On Screen Display Server." Open that and disregard the main program. Find the wrench at the top right of the UI and enter your 60 (or 30) frame max. See if that works.

#3 Edited by MonetaryDread (2015 posts) -

what are your specs?

I ask because it has been revealed lately that ATI cards in Crossfire have almost criminal frame-lag problems.

Other than multiple video-cards, the main causes of micro-stuttering are bad drivers, not enough RAM, or a PC that cannot deliver a consistent frame rate (that is why locking a framerate at 45 or 30 might help).

#4 Edited by Teclo (139 posts) -

Thank you both for you responses. I'll try out the framerate limiter ASAP. I also think it might be down to a terrible HDD. My PC's various components are pretty good, but the HDD is a decentish HDD from the early 2000s. You know that WIndows hardware rating thing? Well most of my stuff gets near maximum, but my HDD gets a mere 5.5 - and that drags the whole thing down to that level. The drivers are up to date, I'm just using a single video card, and my RAM (which is Corsair DDR3 4GB) is right on the money as far as recommended specs go. Well, just in case, I'll put my specs below.

CPU: AMD Phenom II X4 955 BE (3.2ghz Quad)

RAM: 4GB of DDR3 Corsair

Graphics: AMD Radeon 5870

Windows 7 Ultimate 64-bit

#5 Edited by hellerphant (96 posts) -

I have had a few issues myself - I'm running 2x 6900 series ATI cards and the game runs silky smooth one minute, the slows to a crawl the next. I thought it might be my hard drives crapping out, but perhaps there are some drive stability issues?

#6 Edited by Teclo (139 posts) -

I've reinstalled Windows and at first the game was running really smoothly. After a while it started chugging again (even if I went back to the places it was smooth). As a test, I set the resolution to 800x600 and put everything on minimum/off. Bizarrely, the performance was terrible. Stuttering and lurching like crazy. I put it back to 1920x1080, everything on High, and it was a lot smoother but with that subtle but annoying microstutter. I have no idea what's going on with this PC.

I still haven't got around to limiting the framerate - the Windows reinstallation was for a few other reasons as well - so hopefully that'll work. The fact the chugging got worse when I put it on the lowest possible settings, where you'd normally expect a really high framerate, makes me think it's connected to that.

Edit: Limiting the framerate does indeed work. Thanks for the suggestion. It's odd, though, since if it even goes 1 frame below what I've limited it to, the game starts freaking out again. In some areas I have to limit it to 30fps because while it's typically around 40+ (and 60 in smaller areas and indoors), just now and then it'll drop down by a bit and the game starts stuttering again. No idea what the larger problem behind it all is, but it's nice that I can at least play Tomb Raider without it looking like the whole world is having an epileptic fit.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.