Xbox will not let me purchase this?

#1 Edited by Murdouken (709 posts) -

Hey. I have 2100 points, more than enough to buy this, but I'm getting a generic error when I try to purchase it. I've tried buying it both from Xbox.com and from the console itself, but nothing seems to be working. Any idea on what this problem could be and how to fix it? I've been so unbelievably excited for this game for ages.

#2 Edited by TimmyChaw (114 posts) -

Its because we are all going apeshit trying to get it right away, it will work soon...

EDIT: Actually this is kinda weird, I used the backdoor website way of getting games an hour early a few times now. Did it with Turtles RS and Perfect Dark, but with both of those I was able to purchase right away. Maybe they are finally stopping us from jumping the gun on new releases? Seems weird that they would stop us from sneaking money into their pockets, lol...

#3 Posted by blueinferno (442 posts) -

Same thing. I thought maybe my points were invalid, so I bought that shitty Ghostbusters game to make sure, and they weren't. So yeah I guess too many people are trying to purchase it right now. Just have to wait it out.

#4 Posted by TruthTellah (8552 posts) -

XBOX Live seems to be saying that some may be seeing service issues right now. So, I'm guessing you may just be one of those affected. Try again later and see if it works. :)

#5 Posted by Murdouken (709 posts) -

Alright, good. As long as it is for everyone and not just for me. I just bought a new Xbox yesterday as my last one was stolen, so I thought there might be a problem with it or something. Cheers for the clarification.

#6 Posted by joshthebear (2700 posts) -

If you search for it on Xbox.com you an add to your queue form there. That's what I did.

#7 Posted by Murdouken (709 posts) -

@joshthebear: Nope. "Your transaction cannot be completed."

#8 Posted by blueinferno (442 posts) -

In the mean time, just play the trial. :)

#9 Posted by Imsorrymsjackson (855 posts) -

I wouldn't bother, its get really old really fast.

#10 Posted by TimmyChaw (114 posts) -

@joshthebear: Thats what we did, we just cant purchase it yet... Kinda sucks, cant even do a complete run in the demo.

#11 Posted by _Chad (963 posts) -

after watching the quicklook it doesn't look very good. There are only a couple of levels I care about or even remember. Also the new music is shit.

#12 Posted by Chaser324 (6328 posts) -

Same problem here. I can't get the purchase to go through.

Moderator
#13 Posted by jonnyboy (2920 posts) -

Most prestigious event in the Xbox Live calender, and xbox live goes tits up. Bang up job lads.

#14 Posted by phuzzybunny (171 posts) -

Damn it. I wanted to play some of this before I crashed out. Oh well. I'll just play it tomorrow.

#15 Posted by XenoNick (1390 posts) -

Same problem. Gutted =[

#16 Posted by joshthebear (2700 posts) -

Anybody actually gotten it to work yet?

#17 Posted by Murdouken (709 posts) -

Nope. Still not working. Has anybody tried downloading the trial and then unlocking the main game from the main menu or something?

#18 Posted by slndr (62 posts) -

I downloaded the trial and attempted to unlock from the games menu. Still no luck. Guess I'll try again later today.

#19 Edited by Peanut (953 posts) -

Yep, it's kinda fucked. It's weird because the game wasn't up and advertised on the dashboard when I woke up about an hour ago, but I found it on Xbox.com, which allowed me to DL the tria but not purchase it. Now all the Summer of Arcade adage is up on the dashboard and you can download the trial, but you can't actually buy the game, which is...odd.

#20 Edited by XenoNick (1390 posts) -

@Murdouken said:

Nope. Still not working. Has anybody tried downloading the trial and then unlocking the main game from the main menu or something?

Still no go through the game either.

EDIT: Was just able to purchase it.

#21 Posted by Peanut (953 posts) -

Went through for me now. Hooray! 30 minutes until work!

#22 Posted by BrainSonata (105 posts) -

Goldfinger and Millencolin. Sweeeeeet.

#23 Posted by Murdouken (709 posts) -

Just got it! looks like it's working.

#24 Posted by Demoskinos (14574 posts) -

Yeah.... I can't download the thing period. No option at all on the Dashboard. WTF? =\

#25 Posted by dropabombonit (1484 posts) -

You won't have this problem on PSN (but you would wait a day to download it)

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.