FPS low

#1 Edited by BagManForHire (382 posts) -

This is driving me insane I should be able to run this at 60fps but instead it runs anywhere between 10~45fps

Here are my specs
Amd a6 quad-core 8gb ram Nvidia GTX 550ti

#2 Posted by AlexW00d (6275 posts) -

I can't tell if you hit send too early or this is a joke.

#3 Edited by Chaser324 (6556 posts) -

I've taken a look through your detailed specs and clearly the problem is AMD.

Moderator
#4 Posted by BagManForHire (382 posts) -

@alexW00d yea im at work hit send early lol my specs are: AMD a6 quad-core 8gb ram Nvidia GTX 550ti

#5 Posted by GetEveryone (4455 posts) -

Processing....

Processing...

Pithy comment detected.

Success rate: 63%

#6 Posted by DaveC524 (86 posts) -

Ya, I actually had this issue last night, where it would sometimes get down to around 30 fps (not during intense combat) and just stay there, as if some sort of arbitrary frame rate cap was being placed on the game. Also, after restarting the game, I would go back to pumping out a constant 60. IMO, maybe vsync is bugged. I'm running on an i7-920 (first gen) and a GTX 460. All of my drivers are also up to date.

#7 Edited by BonOrbitz (2193 posts) -

All PC games at launch are buggy in one way or another (it seems that way to me anyway). At least it's playable and enjoyable so give it time for a couple of patches and it'll iron itself out soon. Can't wait to play this after I wrap up TL 1 this weekend!

I have an Intel quad core and a 570 so I'll see how that goes...

#8 Edited by believer258 (11922 posts) -

Try turning the settings down and see if you can't keep a consistent 60.

EDIT: Also, try D3DOverrider to force VSYNC and turn off VSYNC in the game. That often gives me a decent amount more frames.

#9 Posted by BagManForHire (382 posts) -
@believer258 thats the 1st thing I did, I turned down everything to low and still have same problem.
#10 Edited by believer258 (11922 posts) -

@BagManForHire said:

@believer258 thats the 1st thing I did, I turned down everything to low and still have same problem.

Have you tried validating the files or whatever Steam calls it? Right click, properties, local files tab, validate?

EDIT: Also drivers, restart computer, virus scan, etc.?

#11 Posted by BagManForHire (382 posts) -
@believer258 yes to all of those I even reinstall windows 7
#12 Posted by Kamakazie (3 posts) -

Are you running fullscreen or windowed (or windowed fullscreen)?

#13 Posted by Largo6661 (335 posts) -

Yeah I'm getting the same thing but for me the game only slows down in combat, my machine runs skyrim on ultra with a great framerate. I think its torchlight

#14 Posted by Cataphract1014 (1313 posts) -

My performance in windowed fullscreen was weird. Fraps was telling me I was getting like 80FPS but the game was running like shit.

In fullscreen it runs good, but I like to play in windowed fullscreen.

#15 Posted by Kamakazie (3 posts) -

Yeah, Windowed/Windowed Fullscreen have horrible performance.

#16 Posted by BagManForHire (382 posts) -

@Kamakazie: fullscreen

@Largo6661: yea that's whats happening running around fine but in the main town or combat it starts acting up

#17 Posted by RuthLoose (816 posts) -

@GetEveryone said:

Processing....

Processing...

Pithy comment detected.

Success rate: 63%

You are the hero Giant Bomb is in need of. Never stop.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.