Optimization?

#1 Posted by Pobearo (108 posts) -

So I have a decent laptop that can play most games (Starcraft 2, Portal 2, Team Fortress 2) pretty smoothly. With Tribes, though, I get choppy framerates on the lowest settings. I know the game is not optimized well, but will that be fixed in a future patch or something, or is the game just going to be poorly optimized and I just need to deal with it?

#2 Posted by zSgtPePPeR (2 posts) -

@Pobearo: I was having the same problem until this morning. Performance was still poor even at lowest settings. For some reason Tribes was using my integrated graphics card

on my laptop instead of my Nvidia GTM555. Simply right clicked on the launcher and selected launch with Nvidia........ Not sure if this will work for you but it sounds like the same problem.

#3 Posted by Skytylz (4031 posts) -

I have a 6950 and I didn't play for a few weeks only to come back and enjoy very inconsistent frame rate at any setting. I really hope they are working on optimizing it, because I've kinda quit playing because it runs like crap for me right now.

#4 Edited by emem (1965 posts) -
@Pobearo@zSgtPePPeR@Skytylz: You guys can try to modify your tribes.ini at C:\Users\<username>\Documents\My Games\Tribes Ascend\TribesGame\Config and set bloom, depthoffield, etc to False. It helped me a lot to keep a fairly decent framerate.
#5 Posted by zSgtPePPeR (2 posts) -

@emem: I' have had a steady 40fps on high since I figured out the problem was Tribes was using the wrong graphics cards for some reason. Laptops use the integrated graphics for non demanding things like browsing etc to preserve power. Once I changed the default it worked fine. Seems to be the problem for OP aswell because his/her card should easily run the game at mid/high settings.

#6 Posted by Pobearo (108 posts) -

When I right click there is no "Launch with NVIDIA" option, although I do have an Nvidia graphics card. Is there any other way to change it?

#7 Posted by Pobearo (108 posts) -

Update: I changed my INI settings a lot, aiming for maximum frames per second, and It works great for like the first four minutes of my first match, at which point it just gets choppier and choppier until I bottom out at about 4 frames per second. Any idea what that's about?

#8 Posted by ADAMWD (581 posts) -

@Pobearo: This was already mentioned, but my roomate was getting choppy gameplay on the lowest settings on his laptop. Turns out the game was using his integrated card rather than discrete. Wouldn't be surprised if this was an issue for you as well. Different laptop manufacturers have different methods for switching graphics, so I would suggest checking into power options or going into the Nvidia/AMD control panel.

#9 Posted by Pobearo (108 posts) -

@ADAMWD: I've been using the maximum performance settings, so power settings aren't the issue. If it is indeed using the incorrect graphics card how do I change it to use my preferred card? I don't have the option of right clicking and selecting "run with nvidia" so I really don't know what else to do.

#10 Posted by ADAMWD (581 posts) -

@Pobearo: What type of laptop do you have?

#12 Posted by ADAMWD (581 posts) -

@Pobearo: I'm pretty sure that laptop doesn't have switchable graphics, so that probably isn't the issue. I'm not too sure what to suggest other than messing with settings to try and get the game running smoothly, consistently.

#13 Posted by Vitor (2815 posts) -

Games can often start losing frames if your GPU is overheating. How old is the laptop? Have you cleaned out the dust with a can of compressed air since you bought it?

Other than that, probably just a bad driver. Can't think of anything else that would cause this.

#14 Posted by Pobearo (108 posts) -

@Vitor: My computer actually does have dust-related heating issues, so that sounds like my best bet. I'll get on it, thanks!

#15 Posted by Vitor (2815 posts) -

@Pobearo: If your FPS suddenly drops in other games also for no apparent reason, then that's your best bet. I wouldn't play anything until you get that sorted - the dropped frames are from your GPU downclocking itself because the temperature is getting dangerously high. Prolonged usage can permanently damage your card.

I had the same problem. One can of compressed air later, my temps had dropped dramatically.

Run something like CPUID Hardware Monitor and measure your temps before/after gaming. If they get to above 85 Celsius when gaming, you likely have an issue. It'll also show the voltage of the card - if that drops for any reason, it's your BIOS kicking in and throttling your GPU to save it from burning out.

#16 Posted by Pobearo (108 posts) -

Update: Went to my campus computer repair center and they blasted a literal shit-ton of dust out, and that seems to have done the trick. Thanks for the words of wisdom!

#17 Posted by Vitor (2815 posts) -

@Pobearo said:

Update: Went to my campus computer repair center and they blasted a literal shit-ton of dust out, and that seems to have done the trick. Thanks for the words of wisdom!

Yeah, surprising how much stuff can get stuck in there. Glad you solved the issue!

#18 Posted by The_Drizzle (624 posts) -

Sorry if this is a bit off topic, but I've heard that using a compressed air can actually can blow dust back into the laptop? Any clarification on this? Thanks

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.