I can't do this!

#1 Edited by Aegon (5852 posts) -

I've been playing this game keyboard only and I've been loving it so far, but now I've reached a part where I just can't do what I'm supposed to. I kept trying to do this over and over again, but it didn't work, so I wondered if I was doing the right thing. I checked a guide. YES I AM DOING WHAT I HAVE TO, BUT IT'S NOT WORKING!.

You see, I have to unplug these shitters. 

There's three of them, but the last one just will not go out! I've gotten it to the brink where it looks like it's gonna pop out, but I just can't get it OUT!  

Anyone else using a keyboard to play that has gotten through this part? I've tried all kinds of angles from all kinds of distances to get some leverage. It ain't working. 
#2 Edited by Aegon (5852 posts) -

I can't believe this, of course this happened. After numerous attempts, I got it out as soon as I made this thread...what the f***.  
 
*sigh* 
 
It's just so random. I run at the plug from a crazy angle and that should not be the way to do it for keyboard folks, but after multiple attempts like that I got through.  
 
This almost makes me frustrated enough to want to stop for today...oh look, an upgrade pod!

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.