417 Comments
Edited by MrAWESOME247

YES! YES! YES!

Posted by sir_tonk

Matt Rorie is back? Fuck yes, more puppies!

Edited by SkullcrusherMountain

@xite said:

@blacklab said:

Wow, what is Rorie's new gig?

He replacing Dave as the Product Manager of Giant Bomb. Here's Dave's post.

Holy shit. While I LOVE me some Rorie, I'll miss Dave's special brand of crazy. What a wonderfully sad situation this is.

Posted by Szlifier

This is the best possible news ever.

It would be, if at the same time Dave wasn't leaving. :(

Edited by Sin4profit

Classic starting point with Steam fixes is to delete the "ClientRegistry.blob" file forcing Steam to re update itself if you havn't tried that yet.

Only other issues i've had with Steam were the need to run it as "Admin" and the need to reboot Steam itself to get new game installs to work properly.

don't know if it helps but it's all i've got.

Posted by Rapid

Yay missed Matt, more puppies!

Posted by Brutakas

You could try starting steam with the '-tcp' launch option. Another thing to try would be to uncheck 'automatically detect settings' from Internet Options -> Connections -> LAN Settings. The reason is that Steam uses those Internet Options for its networking stuff.

Posted by Red12b

@ejiehi said:

When the moon hits your eye like a big pizza pie Matt's a Rorie?

Ahaha

Posted by csl316

Mailbag is over. Nothing better than a Matt Rorie will ever come in the mail.

Edited by Red12b

Let the uncomfortable touching between Ryan and Matt begin again!

@smcn said:

Yay Matt Rorie!

It's not uncomfortable, It's love.

Edited by marbleCmoney

Rorie!

Posted by Zatoichi_Sanjuro

Edited by Kyle

Welcome home, Matt! :D

Posted by iragequit

Oh god... Fingers will be meshed.

Posted by csl316

Whoa whoa, that intro is NSFW. Thanks for the warning, guys.

Edited by darkelink

Steam help:

Delete ClientRegistry.blob , this will force steam to update and resolve any corrupt files.

Make sure the steam directory isn't read only, it sometimes causes issues.

Open steam with the -dev command line option (or it might be -console) and check to see if anything shows up in the console.

Posted by muthachugga

I see everyone is excited about Rorie. It won't be the same for me with Dave gone.

Posted by Luck702

I've only been a bomber since last July. Is this Rorie character "cool?" CAN WE TRUST HIM?!?

Edited by Do_The_Manta_Ray

@brad

Plenty of decent suggestions in this thread as how to fix the issue you're describing here, Brad.

I'd recommend going through the list. Rather than repeat what's already been said, let me add a few inputs of mine own.

- Disable UAC

- Manually install the .NET Framework beforehand, as this may be be what's halting the installation.

- Rather than reinstall windows manually, perform a so called ghost partition, which is essentially cloning one of the working PCs, drivers, software, settings and all. Considering you got the same hardware set up across the board, this shouldn't provide any additional issues. You can easily get your hands on a program which can do this reliably simply by googling.

- Post your "DxDiag" here among the messages so that we might be able to dig through it.

- Check for other connection inconsistencies on said PC by stress-testing it in order to eliminate hardware as an option.

- Circumvent the CBS firewall and connect to a different network incase you haven't already. The way to go about fixing these kind of issues ain't so much trying one idea after the other, it should be about eliminating potential reasons until you can ball-park the source of the issue, at which point you should be able to brute-force your way through one way or another.

- Finally, I want to quote out one particulary good suggestion by another user in regards to examining your switch/hub setup. He describes what is a very common error in work-places where additional computers are added at a later date.

@baltimore said:

I have run into the exact same problem with Steam that you guys ran into. Are the machines plugged into a hub/switch at your desk or are they plugged into separate ports (at your desk)? My issue was solved once I removed a hub from my network. I found that steam thought I was trying to install the same game on an IP address that had two different mac addresses. Yes, I realize that's impossible and silly sounding but after doing some futzing I found that both machines looked liked they were coming from the same IP (which was the hub).

Also, make sure you are not logged into steam on both machines at the same time. That has caused issues for me as well.

To conclude, switches are bitches.

Quick Edit: There's a number of files in the steam folder that goes by different variations of the name "connection_log.txt". Search your steam folder for these files and compare the information held within to your attempts at installing, connecting, etc. It's all timed. With this information, you should be able to deduce this issue.

(Can't believe I forgot this.)

Posted by BoomSnapClap113

Have you tried unplugging the router for 10 seconds, then plugging it back it?

Edited by Lucinice

Actually steam not saving your community stuff happens sometimes.

Posted by Rorie

Rorie is getting fat

Yeah, I've been off work for so long and it's been kinda cold in SF so I haven't been biking as much as I'd like. Plus, when I'm at home all day I just wind up eating out of boredom. Now that I'm back at work hopefully I'll be both eating less and biking to the office, so I'm looking to cut 10-15 pounds. If you really want to see Big Rorie, check out some of the first Screened videos.

Staff Online
Posted by Lydian_Sel

Welcome back Rorie!!!

Edited by RVonE

I hope Giant Bomb grows large enough for Rorie to transition into an editorial position. He was the best writer Whiskey Media had on staff.

Online
Edited by stenchlord

@rorie: More cushion for the pushin' Rorie :D lol

Glad to have you back. I look forward to seeing your exploits :P

Edited by 6n00bkilla9

https://support.steampowered.com/kb_article.php?ref=3134-TIAL-4638 This will fix it! @brad

Posted by NmareBfly

@brad, I assume you've tried deleting the clientregistry.blob? That's a magical fix for all sorts of steam issues.

Posted by Jayzz

@rorie: It's so good to have you back man! GET PUPPIES ON THE LIVE SHOWS! :D

Edited by darkest4

Well done to whoever mailed in Rorie. Disappointed that Giantbomb neglected to record the unboxing of Rorie.

Posted by Szlifier

@do_the_manta_ray: Switches and Hubs are very different devices. That situation would be impossible with a switch.

Edited by steelknight2000

Off the top of my head, it looks to me like it's an account issue rather than hardware/OS stuff. Maybe you're using the same account of multiple machines at once and that's screwing with something server-side? I know I get weird issues when I try to connect to Steam through a VPN.

I dunno...

Edited by MarkWahlberg

@luck702 said:

I've only been a bomber since last July. Is this Rorie character "cool?" CAN WE TRUST HIM?!?

We can trust him, assuming this is the *real* Rorie...

Edited by avantegardener

MUSEUM QUALITY.

Edited by Paindamnation

@rorie said:

@rocospi said:

Did Babs leave Comicvine?

She's working remotely from New York at the moment.

DUDE YOU ROCK. IT TOOK THEM LONG ENOUGH TO HIRE YOU. How do you feel about @finaldasa Doing the stuff on Screened?

Posted by Marokai

@stimpack said:

Welcome home, Rorie! We love you!

^ This!

Edited by MrMazz

YAYAYAYAYAYAY RORIE IS BACK

Hopefully he dosen't get fired in 2 months like his last job

Posted by DeathbyYeti

i became so happy seeing the thumbnail

Posted by Mitch0712

Make sure your personal computer is plugged in.

Posted by Redhorn

Please get a better camera for these.

Posted by fisk0

OK, Rorie is great, but the loss of Dave will be mourned for generations to come. I guess we won't see the end of Blade Runner then?

And, yeah, that box was pretty amazing. I wish someone would send them a copy of Project Firestart though, that's a really interesting prototypical System Shock/Bioshock/Dead Space style game for the C64, you know, alone on a ship with aliens all over the place, patching together what happened before by reading crew logs and e-mails and stuff like that.

And, @brad, I haven't had this specifically happen with Steam before, but for a really long time I was unable to play any EA games on my machine, as Windows had randomly started Internet Connection Sharing on my network adapter, and that somehow made EA games unable to authenticate properly with EA's servers - with somewhat similar results in Origin as what you're getting in Steam - I could connect to Origin, even download some games, but I would get "the connection has timed out" whenever I tried to play any games that used Battlelog/Autolog style features or otherwise needed a persistent connection. So I'd recommend go to the Networking and Sharing Center in Windows 7 (and 8?) and make sure that none of the Network connections are listed as "shared" or "bridged" in the Network status fields, and if they are, disable that in the Properties.

Edited by wukong

@brad Have you tried jiggling the handle?

@rorie Welcome home!

Posted by bkbroiler

rooooooooooorie

Edited by flyingace16021

WOOOOOO!!! There has been a horrible lack of puppies on giantbomb without Rorie nearby.

Posted by OriginalYellow

WELCOME BACK RORIE!

Posted by CashBailey

AWWWWWW, SHIT!!!

The Gang's all here, motherfuckers!!

There is no smilie sufficent to depict my happiness right now.

Posted by enemymouse

Ask your IT guy if the Mac Address of the bad machine is at all restricted by company network.

Also, RORIE!

Posted by pancakehumper

Run Steam as Administrator

Posted by TheManWithNoPlan

HE'S BACK!!!!!

Edited by TheManWithNoPlan

HE'S BACK!!!!!!!