Help me out, bro

#1 Posted by Crimacabre (46 posts) -

So i've got a problem, if you know the solution please post it here!

Whenever i connect to XBOX LIVE, i get disconnected after a couple of seconds. It's really annoying, and it really only seems to happen when i'm at the dashboard. If i connect to LIVE while playing a game, it all works fine, but when i go to the dashboard i get disconnected.

Could use some help here.

#2 Posted by HitNRun (344 posts) -

Weird. I would say it sounds like your connection, except that works when you're in-game.

Bump.

#3 Posted by Shawn (3825 posts) -

Restart your router or gateway I guess. Or check the ethernet port.

I really don't know what to recommend

#4 Posted by Vinchenzo (6192 posts) -

Do the internet check to make sure nothing is semi-failing. For instance, your NAT could be Moderate, not closed, and yet not quite Open. If it's a NAT problem, that's probably your router. If everything checks out, I would try calling MS (1-800-4MY-XBOX).

#5 Posted by Vlademir (1029 posts) -

Try restarting your router, port-forwarding, and make sure that your cables are all plugged in. Otherwise, maybe it's a problem with your Xbox.

Try the Internet Connection Test on your 360 too.

#6 Posted by DualReaver (3882 posts) -

I am not your bro pal.

#7 Posted by Brasky (83 posts) -

Ill help you out bro, except ill tell you the same thing vinchenzo said. I had a similiar problem with frequent disconnects and i fixed by changing from dchp to static ip and having the NAT open.

#8 Posted by Ubergeist (416 posts) -

I think it's your NAT same thing happened to me on COD3 until I fixed it.

#9 Posted by MsCortana (429 posts) -
DualReaver said:
"I am not your bro pal.
"
There's no need in trolling. If you're going to comment leave something constructive that actually pertains to the topic. Geez....
Now, regarding the TP, I would inquire at Microsoft support or try resetting your router.
#10 Posted by Megalon (1392 posts) -
DualReaver said:
"I am not your bro pal."
I'm not your pal, buddy. (I assume you're referencing the same thing I am...)

I had this problem once too, resetting my router fixed it (not simply unplugging it, I had to hold the little reset button in the back to get it working again).

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.