Anyone keep getting forced to install a .NET redistributable? PC

Avatar image for jams
#1 Posted by Jams (3043 posts) -

When the game unlocked last night it asked to install a .NET redistributable or something but I guess I already had it maybe? Anyways, it'd install it then ask for a restart. Once I restarted and tried to play the game again, it'd go through the motions again of installing the .NET file. This kept happening about 4 times in a row. Then I decided to just run the game without restarting and that worked.

I was wondering if anyone else ran into this?

Avatar image for demoskinos
#2 Posted by Demoskinos (17325 posts) -

@Jams: I've had that happen with games before. Next time it asks you to install it just click "no" and if its anything like the problem I had with witcher 2 It will run.

Avatar image for lukeweizer
#3 Posted by Lukeweizer (3276 posts) -

This was happenign to me last night, lots of posts about it in the "Steam Pre-Load is up" thread. It'll just keep asking you to do it. Did you choose to repair .NET or do a fresh install? I chose to repair and my techy friend told me I chose poorly. Anyone know how to uninstall .NET Framework so it can do a fresh install? Is it the "Microsoft C++ 2010 x86" thing in Add/Remove programs?

Avatar image for ravenlight
#4 Posted by Ravenlight (8057 posts) -


This thread might help you out. Download the .NET cleanup tool and run that, then locate whichever framework version you need to install and slap that back on.

DISCLAIMER: Messing with .NET installs can be a pain in the ass, it might be a good idea to set up a system restore point before poking around.

Avatar image for kishinfoulux
#5 Posted by kishinfoulux (3243 posts) -

This is really frustrating. No reason we should all be having this issue. Now the game won't even start up so I'm reinstalling it AGAIN.

Avatar image for jozzy
#6 Posted by jozzy (2053 posts) -

Yup, very annoying. Clicked the repair option too, seemed the safest to me at the time.

I also got a message this morning which was awesomely weird: "You have unsaved settings. Do you want to save them? [Yes] [No]". If they were unsaved, how did you remember I did them dumb game?

Game is awesome though!

Avatar image for sanity
#7 Posted by Sanity (2149 posts) -

Ok, found a fix for this, worked for me anyways, find your borderlnds 2 folder inside the steam folder and go to the folder properties. Disable the read only attribute and apply it. That worked for me anyways,

Avatar image for jams
#8 Posted by Jams (3043 posts) -

I'll have to try some of these fixes when I get off work, thanks.

Avatar image for cataphract1014
#9 Posted by Cataphract1014 (1470 posts) -

Last night I did the whole repair thing and when it asked me to restart I clicked I would do it later and got into the game fine. Today it tried to install again and I hit cancel and it hasn't asked since.

Avatar image for tennmuerti
#10 Posted by Tennmuerti (9082 posts) -

Simplest solution is to just let it restart once. Then the second time around just select restart later.

Fucking around with .NET installs, fixes, wipers etc is a dangerous game that can completely irreversibly fuck them up and .NET is a core windows component that it will never fully remove couse the bitch depends on it. Worse case scenario your .NET get fucked and you will have to reinstall the entire system to fix it.

Avatar image for kishinfoulux
#11 Posted by kishinfoulux (3243 posts) -

I just deleted that framework stuff and reinstalled it and it seems to have worked. Whatever.

This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.