Directx 11 won't work

Avatar image for doomst4
#1 Posted by doomst4 (5 posts) -

Hey there,

well i was playing FarCry3 with directx11 and everything worked just fine. No lags, no bugs, no crashs.

The next day I wanted to play again but the game was running with directx 9 and it was just lagging all the way. I wanted to set it back to directx11 but i couldn't change it, just like if it was not installed or something. I changed nothing on my comp.

I already tried to launch the exe farcy3_d3d11 but then Uplay wants me to insert a the key which i get from Steam and it then says that the key ain't available...

I also already contacted Ubisoft and Steam support, both of their answers weren't of any help..

Any clues?

Thank you guys

Avatar image for bourbon_warrior
#2 Posted by Bourbon_Warrior (4569 posts) -

What card do you have?

Avatar image for doomst4
#3 Posted by doomst4 (5 posts) -

Card name: NVIDIA GeForce GT 440

Manufacturer: NVIDIA

Chip type: GeForce GT 440

DAC type: Integrated RAMDAC

Device Key: Enum\PCI\VEN_10DE&DEV_0DE0&SUBSYS_83B01043&REV_A1

Display Memory: 2528 MB

Dedicated Memory: 993 MB

Shared Memory: 1535 MB

Current Mode: 1680 x 1050 (32 bit) (60Hz)

All drivers are up to date!

Avatar image for doomst4
#4 Posted by doomst4 (5 posts) -


This edit will also create new pages on Giant Bomb for:

Beware, you are proposing to add brand new pages to the wiki along with your edits. Make sure this is what you intended. This will likely increase the time it takes for your changes to go live.

Comment and Save

Until you earn 1000 points all your submissions need to be vetted by other Giant Bomb users. This process takes no more than a few hours and we'll send you an email once approved.