Avatar image for johnwilshire
#1 Posted by johnWilshire (4 posts) -

Hi guys,

I am new to this site I was wanting to try out your api and I was following the instructions in the stickied quick start guide

http://www.giantbomb.com/forums/api-developers-3017/quick-start-guide-to-using-the-api-1427959/

and it says to get a key from:

http://www.giantbomb.com/api/

but when I go to this link I get a 500 internal server error.

Any help is appreciated, Thank you.

Avatar image for khemitude
#2 Posted by Khemitude (236 posts) -

Have you tried going to the api link while logged in? as going to it myself produces an api key.

Avatar image for johnwilshire
#3 Posted by johnWilshire (4 posts) -

I am logged in and still getting 500 server error.

Avatar image for jealous
#4 Edited by jealous (2 posts) -

same problem for me I log in go to http://www.giantbomb.com/api/ and I get a 500internal server error.

Avatar image for chaser324
#5 Posted by Chaser324 (8585 posts) -

There's been a lot of recent development with the API, so it's possible this is due to some of that. @jslack, @edgework may be able to help you figure out the issue.

Moderator
Avatar image for rick
#6 Posted by rick (506 posts) -

@johnwilshire: I'm not sure what the problem is. I logged into your account and generated an API key with no problem. Can you go to giantbomb.com/api now?

Avatar image for rick
#7 Posted by rick (506 posts) -

@jealous: I'm not sure what the problem is. I logged into your account and generated an API key with no problem. Can you go to giantbomb.com/api now?

Avatar image for jealous
#8 Posted by jealous (2 posts) -
Avatar image for beforesteam
#9 Posted by beforesteam (1 posts) -

http://www.giantbomb.com/api/ = 500 error currently

No Caption Provided

Avatar image for johnwilshire
#10 Posted by johnWilshire (4 posts) -

its working now for me thanks. I had just made an account and I am running xubuntu if it helps you work out the issue for anyone else.

Avatar image for rafaelalmeidatk
#11 Posted by rafaelalmeidatk (1 posts) -

I'm new here and I receive the same error when I acess http://www.giantbomb.com/api/: "500: Internal Server Error". @edgework, can you genereta an API to me?

Avatar image for chef_boyargee
#12 Posted by chef_boyarGEE (1 posts) -

Hi. Im having the same issue as the rest. When I try to access the page for an api key I get a 500: Internal Server Error.

Avatar image for quantris
#13 Edited by Quantris (1222 posts) -

Same for me (I don't need an API key, just thought I'd check to see if this issue affects me).

It sounds like there's some issue during API key generation (maybe it only works if you're on the CBSi network and that's why @edgework couldn't reproduce it? Or some other difference between logging in as yourself and an admin logging in via impersonation) whereas if you already have an API key then giantbomb.com/api will return it just fine.

Presumably looking in the logs for the details of the ISE would shed some light on what the underlying issue is.

Avatar image for rick
#14 Posted by rick (506 posts) -

Sorry. We found the bug and a fix should go live Monday or Tuesday.

if you REALLY need an API key now let me know, I'll try to generate one for you. I'm going to be AFK in about 10 minutes and though Saturday though...

Avatar image for mr2012789
#15 Edited by Mr2012789 (1 posts) -

Hi, I am new on here.
I logged in as a free account. But the API key is not generating... What am I doing wrong?
Thank YOU.