Bad API key on iOS / Apple TV app not returning content

Avatar image for deactivated-5c9d14856890c
deactivated-5c9d14856890c

317

Forum Posts

1147

Wiki Points

0

Followers

Reviews: 0

User Lists: 1

Hey, think somethings gone wrong with my account as iOS and tvOS apps not returning content.

I've tried re-linking my account and problem persists. Can still access content as usual on the website.

Anyone else having similar issues?

Avatar image for iqmay
iqmay

7

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#2  Edited By iqmay

Same here, also tried relinking my account. So I'm guessing it's not an account issue.

@edgework any idea what's going on?

Avatar image for rick
rick

507

Forum Posts

33

Wiki Points

0

Followers

Reviews: 1

User Lists: 1

@iqmay: @scribble: There were a group of API keys that got revoked but not banned. The were on a list of premium keys going around pirate sites. We know how they got there and its not your fault and no data was leaked. But re-linking should have generated a new key for you. Let me talk to the app developer and poke around on our side. I've seen 800 people so far who've re-linked without issue so this is a rare case though that's probably no solace for you.

Avatar image for petethepanda
petethepanda

395

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 2

This may well have just been impatience on my part, but I had this happen last night on the Apple TV app, and relinking didn't seem to do the trick until I deleted and reinstalled the app and tried relinking again.

Avatar image for iqmay
iqmay

7

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#5  Edited By iqmay

@edgework: Thanks for the update.

Tried relinking my account a few minutes ago, at first nothing happened, made some coffee and when I returned I could see videos in the latest tab, restarting the app gave the menus back and I can watch videos again.

So maybe I was just impatient :)

If either you or the app developer did something to make thinks work again: Thanks! :)

Avatar image for deactivated-5c9d14856890c
deactivated-5c9d14856890c

317

Forum Posts

1147

Wiki Points

0

Followers

Reviews: 0

User Lists: 1

@edgework Just tried relinking the iOS app, and it needed to be force closed for the change to kick in it seems. I expect the same is probably true for the tvOS one judging by @petethepanda's fix - I'll check when the Apple TV is not in use.

So I reckon my issue is pretty much solved :)

Avatar image for forrax
Forrax

2

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

I have been getting the same or similar errors on iOS and Apple TV. No amount of unlinking and relinking or force quitting and uninstalling the apps seems to have helped.

Avatar image for avenged
avenged

43

Forum Posts

282

Wiki Points

0

Followers

Reviews: 0

User Lists: 3

@forrax: Can you send me a bit more info on what you are seeing? When you attempt to relink in settings are you receiving a code?

Avatar image for edmorex
edmorex

38

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Just another datapoint; my tvOS app stopped showing content, when I forced quit and redid the account auth it now shows the "latest" tab. Oddly the other tabs no longer show up though.

Avatar image for gamevault
GameVault

1

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#10  Edited By GameVault

@edmorex: Are you seeing content in the latest tab? Did you re-link via settings?

Avatar image for cjdunn
cjdunn

68

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 7

#11  Edited By cjdunn

So relinking on my iPhone and iPad went smoothly. On my Apple TV, the problem started with the code not doing anything (meaning: the Apple TV app generated a code, I input it to giantbomb.com/Apple-tv which said I'm all set and the app didn't do anything). Then, a few days later, my categories, except for Latest and Settings, disappeared. (Edit: They were listed in Settings, but in the top menu bar it was just Latest and Settings). I declared the app borked, deleted the app, redownloaded it. The categories returned but now giantbomb.com/Apple-tv tells me the new code is invalid.

Everything's broken.

Avatar image for ryanodonnell
ryanodonnell

14

Forum Posts

2

Wiki Points

0

Followers

Reviews: 0

User Lists: 12

#12  Edited By ryanodonnell

I was getting no content no matter how many times I tried to link my account. I then deleted and re-downloaded the app and now all content is fetched except for the premium stuff. I really wanna watch UPF in my front room but the only videos that show in the "premium" tab are (free) premium videos and no new UPFs :(