Can't log in on iOS, security certificate not trusted

Avatar image for cannongoose
CannonGoose

421

Forum Posts

277

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

#1  Edited By CannonGoose
iPad mini, iOS 6.1
iPad mini, iOS 6.1

Getting the same thing on my iPhone 4 running iOS 6.0.1.

If I tap proceed anyway it just takes me back to the Giant Bomb homepage and then trying to log in a second time leads me to the same warning page.

Avatar image for forcen
Forcen

2666

Forum Posts

28270

Wiki Points

0

Followers

Reviews: 0

User Lists: 30

#2  Edited By Forcen

I had the same issue on my android phone.

I did a little test of the SSL for the site, not sure if shows the error or not.

Avatar image for lordandrew
LordAndrew

14608

Forum Posts

98301

Wiki Points

0

Followers

Reviews: 0

User Lists: 36

@forcen said:

I had the same issue on my android phone.

I did a little test of the SSL for the site, not sure if shows the error or not.

The one with an F rating is issued to auth.whiskeymedia.com. I'd trust it based on the domain it was issued to, but yeah that really needs to be fixed.

Avatar image for uniform
uniform

1842

Forum Posts

33

Wiki Points

0

Followers

Reviews: 0

User Lists: 1

I'm getting this on Android. Effecting Chrome and Dolphin. No issue with Firefox.

Avatar image for beaker
Beaker

102

Forum Posts

211

Wiki Points

0

Followers

Reviews: 0

User Lists: 4

I have the same on my iphone and ipad. I did manage to log in though eventually.

Avatar image for naldean
Naldean

16

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 1

I'm still getting this on Chrome for iOS and Android. Any word on a fix? I know I could bypass the warning but I'd prefer not to.

Avatar image for sexytoad
SexyToad

2936

Forum Posts

3297

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Hmm, it's working fine for me on safari. Is it only with chrome?

Avatar image for lordandrew
LordAndrew

14608

Forum Posts

98301

Wiki Points

0

Followers

Reviews: 0

User Lists: 36

I just tried it on my mobile browser and came across this issue. The cerificate is issued by GoDaddy. According to GoDaddy this problem has something to do with an intermediate certificate not being installed. I don't know what that means or if it's actually relevant.

Avatar image for kimparnage
KimParnage

263

Forum Posts

288

Wiki Points

0

Followers

Reviews: 1

User Lists: 1

i have the same problem on my ipad with chrome.. Its driving me bonkers!

Avatar image for mrpibb
mrpibb

480

Forum Posts

18

Wiki Points

0

Followers

Reviews: 3

User Lists: 0

interesting, we'll take a look into it.

Avatar image for aufaber
Aufaber

100

Forum Posts

1353

Wiki Points

0

Followers

Reviews: 1

User Lists: 3

#11  Edited By Aufaber

Looks like this is still happening on both chrome and beta chrome for android:

No Caption Provided

Avatar image for azquelt
Azquelt

23

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Looks like auth.giantbomb.com isn't sending the intermediate certificate.

The certificate chain (as reported by Chrome on my PC) looks like this: auth.giantbomb.com -> Go Daddy Secure Certification Authority -> Go Daddy Class 2 Certification Authority

However, auth.giantbomb.com sends only the first certificate. While chrome on android knows about the last certificate, it doesn't seem willing to go and find the intermediate certificate on its own so it can't validate the first certificate.

This is in contrast to https://www.godaddy.com which sends both the first and intermediate certificates in its response.

This page explains the problem in more detail (as well as why it's a problem with the site rather than the accessing device): https://code.google.com/p/android/issues/detail?id=6657

Avatar image for hi_im_rob
hi_im_rob

268

Forum Posts

4

Wiki Points

0

Followers

Reviews: 0

User Lists: 1

#13  Edited By hi_im_rob

Hi Everyone,

I just wanted to say that I am having the same issues logging in on my Samsung Galaxy S3 my Nexus 10 tablet using Chrome for Android.

I've emailed support about this but have not heard back from them.

Avatar image for hi_im_rob
hi_im_rob

268

Forum Posts

4

Wiki Points

0

Followers

Reviews: 0

User Lists: 1

#14  Edited By hi_im_rob

Anything new on this? I was unable to view premium content last night on my Android Tablet due to this issue!

Avatar image for alexisg
alexisg

414

Forum Posts

10018

Wiki Points

0

Followers

Reviews: 0

User Lists: 3

@hi_im_rob: ef really? I was under the impression this was fixed a few weeks ago. Site seems to load fine now on my Nexus 7. Any idea what version of Android you are on?

Avatar image for hi_im_rob
hi_im_rob

268

Forum Posts

4

Wiki Points

0

Followers

Reviews: 0

User Lists: 1

#17  Edited By hi_im_rob

@alexisg: Never mind. Everything is working.

Thanks Alexis!