GDPR "Manage Settings" box in live video player

Avatar image for processr
processr

208

Forum Posts

4

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

The "Manage Settings" box to allow users to control their settings for third-party cookies is appearing in the live video player when it absolutely shouldn't. It handily manages to cover all the important controls, too.

No Caption Provided

An additional issue I noticed is that the settings menu at bottom right currently has two options, both "HTML5":

No Caption Provided

OS: Windows 10

Browser: Firefox 66.0.5

Extensions: Giant Bomb QoL, 1Password. GB is whitelisted on my adblocker.

Avatar image for rorie
rorie

6416

Forum Posts

1163

Wiki Points

0

Followers

Reviews: 1

User Lists: 3

#2 rorie  Staff

@processr: Thanks for the note; I'll file a bug for this!

Avatar image for erzauge
erzauge

2

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

I have the same problem.

os: windows 10

browser: Chrome 74

extensions: Grammarly,Kaspersky Protection

and the error log:

https://docs.google.com/document/d/13OuEC5ok5s4nuQgvUXfG2Sygg56qOiREdpCaKDQZPvA/edit?usp=sharing

Avatar image for tomba_be
Tomba_be

205

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Same, Chrome, W10. During whatever live show is going to start right now?

Avatar image for gamer_152
gamer_152

14829

Forum Posts

73675

Wiki Points

0

Followers

Reviews: 71

User Lists: 6

#5 gamer_152  Moderator

Spoke to Will about the "Manage Settings" button last night and he's now aware. If the problem continues, it's worth noting that Chrome users can use the "Inspect" feature to delete the button. I'm also told that Firefox users can delete it with the DOM Inspector. If you don't want to go through all that, you can also full screen the player to make the controls accessible again.

Avatar image for wcarle
wcarle

434

Forum Posts

54

Wiki Points

0

Followers

Reviews: 0

User Lists: 1

#6 wcarle  Staff

@processr: @erzauge: @tomba_be: Hey guys I'm really trying to replicate this and get it to happen to me but I just can't get this to happen to me. I tried logging in to a proxy in Germany to make the manage settings pop up and it is only popping up on the parent page not in the video player. Is this still happening to you all?

No Caption Provided

Can you try clearing your cookies/cache and trying again?

Avatar image for processr
processr

208

Forum Posts

4

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@wcarle: I can't reproduce it right now, but I know people were seeing it happen at the beginning of both of today's streams.

Avatar image for tomba_be
Tomba_be

205

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Thanks for looking into it. I only had the problem during a live stream, if I manage to catch another one, I'll update with any new information.

Avatar image for erzauge
erzauge

2

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

the manage settings problem appears to be gone but not the html5 part.

Avatar image for processr
processr

208

Forum Posts

4

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

So I actually did see the Manage Settings button over the player today, but only before the actual Bombcast began. My theory is:

  • Stream begins, chat opens, player is instantiated
  • At this point the Manage Settings button is visible
  • The producer denotes the start point of the video for the purposes of the fast automatic upload
  • Something about this stops the Manage Settings button from appearing

This would explain why @wcarle and others were struggling to reproduce while a stream was properly in progress. Just speculation on my part based on a small amount of evidence, but hopefully that helps.

Avatar image for esteph
ESteph

22

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#11  Edited By ESteph

@processr said:

So I actually did see the Manage Settings button over the player today, but only before the actual Bombcast began. My theory is:

  • Stream begins, chat opens, player is instantiated
  • At this point the Manage Settings button is visible
  • The producer denotes the start point of the video for the purposes of the fast automatic upload
  • Something about this stops the Manage Settings button from appearing

This would explain why @wcarle and others were struggling to reproduce while a stream was properly in progress. Just speculation on my part based on a small amount of evidence, but hopefully that helps.

This checks out for me, had the stream running in the pre show, tried the clear cookies thing and ended up with not 1 but 2 manage settings buttons, one on the player, one at the bottom of the window proper. Saw this post and tried opening a new copy of the (now live) stream in a new tab, lo and behold, no manage settings covering the player.

Win10, Firefox 66.0.5

Avatar image for tomba_be
Tomba_be

205

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Just checked in on the in-progress Bombcast stream, the button is no longer there for me.

Avatar image for dazzhardy
dazzhardy

1495

Forum Posts

4300

Wiki Points

0

Followers

Reviews: 2

User Lists: 4

No Caption Provided

Getting this over the current live stream.

Avatar image for afroofdoom
Afroofdoom

196

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 2

#14  Edited By Afroofdoom

This is happening for me right now in the Pro Skater Advanced pre-show.

I saw it during the Bombcast pre-show too, but not during the show itself.

I'll refresh at a few points to see if there's a point at which it goes away.

EDIT: The button still appeared during the old-episode-pre-roll.

EDIT2: The button disappeared once the old-episode pre-roll ended.

Avatar image for dazzhardy
dazzhardy

1495

Forum Posts

4300

Wiki Points

0

Followers

Reviews: 2

User Lists: 4

@processr said:

So I actually did see the Manage Settings button over the player today, but only before the actual Bombcast began. My theory is:

  • Stream begins, chat opens, player is instantiated
  • At this point the Manage Settings button is visible
  • The producer denotes the start point of the video for the purposes of the fast automatic upload
  • Something about this stops the Manage Settings button from appearing

This would explain why @wcarle and others were struggling to reproduce while a stream was properly in progress. Just speculation on my part based on a small amount of evidence, but hopefully that helps.

This seems to have applied to the Pro Skater stream. Since going Live its gone after a refresh.

Avatar image for rorie
rorie

6416

Forum Posts

1163

Wiki Points

0

Followers

Reviews: 1

User Lists: 3

#16 rorie  Staff

Hey, we are still poking around on this one - Will is working with one of our mods who is affected. Sorry for the trouble, hopefully we'll lick it soon.