Livestream Video Player Issues on Safari

Avatar image for ben_h
#1 Posted by Ben_H (4204 posts) -

I just went to watch the Burnout Paradise stream and on Safari it keeps playing about 10-30 seconds of video live and then skipping back to the start of the stream. Refreshing the page will fix it for another 10-30 seconds but it jumps back again eventually. My Safari version is Version 11.1 (13605.1.23.1). I have all plugins disabled for Giant Bomb so it isn't Ghostery or anything like that breaking it.

Someone else also mentioned it happening on their iPad so it could be a Safari issue.

I tested the stream on Chrome and it was fine so it isn't my internet connection. It seems like whatever player is used for Safari (it appears to be different than the one on Chrome?) is borked right now.

Avatar image for rorie
#2 Posted by Rorie (5867 posts) -

@ben_h: I will have to defer to @wcarle on this one as I don't have a Safari device to test this with.

Avatar image for rorie
#3 Posted by Rorie (5867 posts) -

@ben_h: Is this just streams or is it VOD content as well?

Avatar image for inevitabledoubt
#4 Posted by inevitabledoubt (20 posts) -

@rorie: This happens to me lately in live streams too. VOD content is fine. But live streams play for a few seconds then jump all the way back to the start of the stream. I opted not to watch today’s UPF as a result. It’s happening on my iPad Mini on iOS 11.2.6 both when I play live streams on my iPad and when I use my iPad to airplay to an Apple TV 4K.

I tried the same on my iPhone X, also on iOS 11.2.6, both on the phone and airplaying to the same Apple TV 4K. In all four instances live streams play for a few seconds then jump back to the start. I am using safari in both cases and, at least on my iPad, I reloaded the chat page with content blockers turned off (by pressing and holding on the refresh button) and the same thing happened then too.

But, for me at least, I can play VOD stuff without issue using the above methods. Hope that helps!

Avatar image for iqmay
#5 Edited by iqmay (7 posts) -

I have the same issue. Tested on my iPhone and my AppleTV 4 using the Giant Bomb app. Not sure if it skips to the beginning of the stream however. It jumps to the ‘please wait’ Luchadeer screen. I’m guessing that one of the higher bitrate streams is not working, as the stream starts with a low bitrate and resolution and then jumps to the ‘please wait’ screen. (Just a guess, could be totally wrong :))

VOD plays fine on both devices.

Avatar image for minustimes
#6 Posted by MinusTimes (35 posts) -

@iqmay: I can verify this bug. I was trying to watch the UPF live stream last night on my Apple 4K Tv, and the stream would load in low quality for about 10 seconds then would cut to the “Please Stand By” image and play music. I tried it on iPad and had same issue. Yet it worked fine on my laptop.

Avatar image for heis24
#7 Posted by heis24 (54 posts) -

Happens on chrome as well

Avatar image for himynameismurphy
#8 Posted by himynameismurphy (10 posts) -

I’ve been having a similar issue on both Chrome/Safari and Windows/Mac. It appears, at least for me, isolated to the live streams.

Stream will load at any quality fine, and let’s say after about 5 minutes (haven’t timed it) the player will buffer for a second and repeat the last 10-20 seconds of content. That loop will continue to happen regardless of stream source, quality, browser, or OS. Refreshing or relaunching the browser does not solve the problem.

Hope this info helps!

Avatar image for rorie
#9 Posted by Rorie (5867 posts) -

@heis24: What device are you using?

Avatar image for iqmay
#10 Posted by iqmay (7 posts) -

I was only able to catch the last few minutes of the Bombcast livestream today, but had no issues with the stream.

Avatar image for cageysquid
#15 Posted by CageySquid (151 posts) -

This is happening for me as well. It only happens on west coast live streams. East coast stuff and VOD/infnite is fine. I'm on an older ipad using ios 10.3.

Avatar image for rorie
#16 Posted by Rorie (5867 posts) -

@cageysquid: Do you know approximately how long the stuttering has been happening for you? I'm told that the west coast hasn't changed anything recently in terms of how we stream, but if you have an approximate timing on how long it's been going on we can try to track down what's happening.

Avatar image for iqmay
#17 Edited by iqmay (7 posts) -

Running into this issue again during tonights stream, I can watch about 5 seconds of the stream until it skips to, what I assume is the begining of the stream (the please wait screen). Tried restarting my Apple TV, but that didn't help. The same happens when streaming on my phone in Safari and Firefox.

Avatar image for rewind
#18 Posted by Rewind (2 posts) -

This is happening to me on an iPad as well now for all video content. Video starts fine then audio skips back and de syncs.

Avatar image for rorie
#20 Posted by Rorie (5867 posts) -

I believe a fix for this should finally be arriving next week, the audio skipping. Sorry for the trouble!