Avatar image for wcarle
Posted by wcarle (314 posts) -

The new video player has been officially released! (For video on demand only for now, we are still testing it with livestreams).

Thanks to everyone who participated in the beta and helped us solve so many issues! We have a couple outstanding bugs that we've recently discovered and are actively working on. Here they are:

ProblemFix ETA

Video not loading when adblock enabled. Some adblockers are blocking some of our core code, we're working on a fix that should be out soon. But in the meantime you can just whitelist GiantBomb

Tomorrow 12/6
Opera not playing video. Opera doesn't seem to like HLS video. If you are premium try switching to the 'progressive' playback option.Unknown
Buttons missing (play/pause, etc.) This is most likely caused by the extension https everywhere. Until we switch those assets to https please disable that extension on GBA few weeks
Fullscreen video gets cut off in some browsers. We have a fix ready!

Fixed

Mouse cursor not hiding in fullscreen. Fix ready!

This week

Mac Picture in Picture not working. Looking for a fix for this now

Unknown

If you have some problems other than the ones mentioned here please post them in the comments below or in the bug reporting thread. Thanks!

Here's a rundown of the features:

Features

FeaturePremium Only

All HTML5 Video (No Flash at all!!!)

No

Chromecast support

No

More sharing features

More options for sharing like: links and embeds, start and end times for clips, looping, and autoplay (See sharing section below)

No

Resume from saved position

Will save across all browsers/devices if logged in

Yes

Resume from saved position

Will save in your current browser (via a cookie).

No

Streaming video

Can jump to any point in the video. Will only buffer a few seconds ahead at a time

No

Progressive video

The entire video will buffer/download (even if paused)

Yes

Save Settings

We will save all the settings in a cookie so they should stick with you. Things like:

Volume, Quality, Player Size.

No

Sizes

Embiggen: Bigger video! Fits fills most of browser width

Fill Browser: Fill your entire browser tab/window

Fullscreen: Fill the entire monitor

No

Pin

Video will follow you as you scroll down the page

No

Report broken video

This will send us a detailed report of what happened with the video and video player. If you have problems with the beta player please press this button!

No


Sharing

No Caption Provided

Start Time

t=3m1s

http://www.giantbomb.com/videos/best-of-giant-bomb-100-weed3/2300-11391/?t=3m1s

Clip (Start & End Time)

t=3m1s&e=3m30s

http://www.giantbomb.com/videos/best-of-giant-bomb-100-weed3/2300-11391/?t=3m1s&e=3m30s

Autoplay

autoplay=1

http://www.giantbomb.com/videos/best-of-giant-bomb-100-weed3/2300-11391/?t=3m1s&e=3m30s&autoplay=1

Looping clip

loop=1

http://www.giantbomb.com/videos/best-of-giant-bomb-100-weed3/2300-11391/?t=3m24s&e=3m27s&autoplay=1&loop=1



Keyboard Shortcuts

ActionShortcut
Play/Pause videoK or Spacebar
Go Back one frame (You should pause the video first), (Comma)
Go Forward one frame. (Period)
Go Back 5 secondsLeft Arrow
Go Forward 5 secondsRight Arrow
Go Back 10 secondsJ
Go Forward 10 secondsL
Skip to a section of the video1-9 (10%-90%)
Restart video0
FullscreenF
Fill BrowserG
Exit Fullscreen / Exit Fill BrowserEsc
Go to beginning of videoHome
Go to end of video (Last 5 Sec)End
Increase Volume (5%)Arrow Up
Decrease Volume (-5%)Arrow Down
Mute/UnmuteM
Staff
Avatar image for dprotp
#1 Posted by dprotp (602 posts) -

The left/right arrow shortcuts alone have been beautiful, on top of everything else. Baller engineers!

Avatar image for shinytan
#2 Edited by ShinyTan (55 posts) -

Here's a weirdly specific issue I've had with this video player - whenever I use the chrome keyboard commands to jump to another tab (command + 1-9) the video player will interpret that as just hitting 1-9 and jump to that part of the video. It's really disorienting and basically makes me paranoid to ever have the video player in focus so I never use the keyboard shortcuts.

I don't know if this affects others (I'm on Chrome on a Mac, if that helps) or if its even an issue on your end but I figured I'd bring it up now.

Avatar image for pd
#3 Posted by PD (148 posts) -

Oops, didn't realize there was a new thread for the player. I posted a bug roundup on the beta thread here.

Avatar image for caramelpolice
#4 Posted by caramelpolice (12 posts) -

Safari for Mac user here. The previous HTML5 player allowed you to right-click to activate macOS Sierra's picture-in-picture mode so I can watch GB videos and do other things at the same time, and allowed for AirPlay. The new one does not appear to support either, in part because the new player has its own right-click menu. Would love to see support for these features just as there is a Google Cast button.

Avatar image for slipcell
#5 Posted by Slipcell (10 posts) -

2 things:

1 - Is it possible to have fullscreen on doubleclick disabled when in "Fill Browser" mode. It's really annoying as someone that only uses Fill Browser. Also for the fullscreen button to switch to leave Fill Browser once you are in that mode.

2 - Is it possible to not have the weird 2 tone almost bezel? I really don't think it looks good with the rest of the site.

Otherwise the new player seems to be functioning much better for me! Keep up the great work!

Avatar image for blanketfort
#6 Posted by blanketfort (10 posts) -

So excited!
Awesome work, techno-duders.

Avatar image for megasoum
#7 Edited by megasoum (393 posts) -

Maybe not a "problem" per say but I'm pretty sure that the old player would remember an individual Embiggen setting between the front page and the video's specific page?

For example the video at the top of the front page would never be "Embiggened" but when I clicked on a link to a video page THAT video would be big?

Maybe I'm completely crazy but I feel like it used to be like that? I always like that since I liked the big video when I'm actually watching it but I also don't want 1/2 of the front page being a huge video player.

Edit:

vvvvv Yay I'm not crazy lol

Two things:

  1. The Embiggen setting now also applies to the front page. While this is nice in theory, it means that in order to load up the site without having to scroll to see content I want I have to disable embiggen on the main page's video every time I want to browse and then enable it again whenever I get to a video. It's a small issue, but one that does significantly increase the amount of time that I have to spend fiddling about.
  2. The coloration (and overall UI design) of the new player is very different from the rest of the site. A once-over on that would be great.
Avatar image for sagewaterdragon
#8 Edited by SageWaterDragon (37 posts) -

Two things:

  1. The Embiggen setting now also applies to the front page. While this is nice in theory, it means that in order to load up the site without having to scroll to see content I want I have to disable embiggen on the main page's video every time I want to browse and then enable it again whenever I get to a video. It's a small issue, but one that does significantly increase the amount of time that I have to spend fiddling about.
  2. The coloration (and overall UI design) of the new player is very different from the rest of the site. A once-over on that would be great.
Avatar image for dystopiax
#9 Posted by DystopiaX (5698 posts) -

Mouse cursor not hiding in fullscreen. Fix ready!

THANK. FUCKING. GOD.

My number one pet peeve with video players and incidentally the reason that I can't watch any of Austin's new videos over at Waypoint in fullscreen

Avatar image for how92
#10 Posted by how92 (105 posts) -

I'm sorry I just loved full browser. That might have been my favorite thing.

Avatar image for emtee
#11 Edited by emtee (138 posts) -

Pinned a video earlier just to see how it worked, and then unpinned it. After hitting the button to refresh the comments, the video became pinned again, even though I didn't hit the button, and the button didn't show as being selected. I had to pin and unpin it again for it to go back to normal.

Avatar image for levelzerozilch
#12 Posted by LevelZeroZilch (28 posts) -

Thank you so much for Chromecast support!

Avatar image for cakesmash
#13 Posted by cakesmash (3 posts) -

I'm still having the same issue I had when I tested the Beta. There's like "micro buffering" on every video, where it'll stop and show the buffer animation for literally a split second. On HTML5/Streaming it occurs every minute or two, and kind of randomly when using the Progressive setting. Never had this problem with the previous player.

Win7, latest Chrome w/ an adblocker (though I did try an incognito window without any addons; same deal).

Avatar image for dodongo
#14 Edited by Dodongo (143 posts) -

Can I play videos at 1.5x speed? If not then I'm sticking to the YouTube feed.

Avatar image for endsofinvention
#15 Posted by EndsOfInvention (45 posts) -

Cross-posting from the old thread:

I get this bug:

Video not loading when adblock enabled.

In Chrome 55.0.2883.75 on Win 7, with AdBlock disabled. Have whitelisted GiantBomb.com but it doesn't help. I know it's still early in the US so presume this fix hasn't been applied yet, maybe it will sort my issue.

Avatar image for picky_bugger
#16 Posted by Picky_Bugger (196 posts) -

Seems really great regarding playback etc. but what's with the video scrolling on the front page. It makes the website almost unusable.

Avatar image for charlie_victor_bravo
#17 Posted by charlie_victor_bravo (1635 posts) -

What sources need to enabled in order for player to work (using noscript)?

Avatar image for flstyle
#18 Posted by FLStyle (6337 posts) -

It didn't work during the beta, it still doesn't work now. I even whitelisted GB just like you said.

Avatar image for antaru
#19 Edited by antaru (2 posts) -

Shortcut for Skip to section is nice, but I think it shouldn't react when holding down ctrl, alt, cmd, or shift, since these are used for other things in the browser.

As an example, changing tabs in Chrome on mac can be done with cmd+number, and when you do that from the tab with the player it skips to that section.

Avatar image for gwil
#20 Posted by gwil (5 posts) -

Another Safari user who’s now sorely missing picture-in-picture support the old video player used to have. Just need to be able to right click the video element.

Avatar image for kazona
#21 Posted by Kazona (3398 posts) -

Great job on the new player! It certainly works a lot better than the old one and I'm not constantly running into buffering problems like I used to. So kudo to the team!

Avatar image for amason
#22 Posted by amason (4 posts) -

There seems to be a memory leak which might be down to the out of date hls.js v0.6.6 which was fixed in later versions.

Avatar image for egonor
#23 Posted by Egonor (3 posts) -

@picky_bugger: Make sure you don't have the Pin button clicked - white is off/red is on. That will lock the video as visible when scrolling and if it's Embiggened it will cover most of the page.

Avatar image for picky_bugger
#24 Posted by Picky_Bugger (196 posts) -

@egonor: Ah that's it, must have turned it on when messing around with the player. A noble spirit embiggens the smallest videoplayer.

Avatar image for dixavd
#25 Posted by Dixavd (2683 posts) -

Congrats on finally getting it released.

Avatar image for idkicarus
#26 Posted by idkicarus (53 posts) -

Forgive me if you're already aware of this, since you have a fix in store for fullscreen video getting cut off in some browsers, but I've been having a related issue with videos being cut off at the bottom when using "fill browser".

Avatar image for meierthered
#27 Posted by MeierTheRed (5465 posts) -

Thanks a bunch for the Chromecast support. Finally.

Avatar image for hassun
#28 Posted by Hassun (8319 posts) -

@wcarle: Is it possible to hide the cursor on full-screen mode? Hiding it at the bottom keeps the progress bar on screen.

Avatar image for bollard
#29 Posted by Bollard (7710 posts) -

Two things:

  1. The Embiggen setting now also applies to the front page. While this is nice in theory, it means that in order to load up the site without having to scroll to see content I want I have to disable embiggen on the main page's video every time I want to browse and then enable it again whenever I get to a video. It's a small issue, but one that does significantly increase the amount of time that I have to spend fiddling about.
  2. The coloration (and overall UI design) of the new player is very different from the rest of the site. A once-over on that would be great.

Agree with both of these. Now the bugs are (mostly) fixed I hope we can see a visual pass to make the player look better.

Avatar image for finaldasa
#30 Posted by FinalDasa (3104 posts) -

Good job!

Moderator
Avatar image for chance_s
#31 Posted by Chance_S (154 posts) -

@caramelpolice: @gwil: A work around for now is to load the site in the Helium app. It is a floating video player and you can fill screen.

Avatar image for conmulligan
#32 Edited by conmulligan (1747 posts) -

@caramelpolice said:

Safari for Mac user here. The previous HTML5 player allowed you to right-click to activate macOS Sierra's picture-in-picture mode so I can watch GB videos and do other things at the same time, and allowed for AirPlay. The new one does not appear to support either, in part because the new player has its own right-click menu. Would love to see support for these features just as there is a Google Cast button.

@gwil said:

Another Safari user who’s now sorely missing picture-in-picture support the old video player used to have. Just need to be able to right click the video element.

Yep, I flagged this in the original bug reporting thread and it wasn't followed up on so I'm not holding my breath. It's a shame, because unless they're doing some really weird JS stuff it would be almost trivial to explicitly support PiP and Airplay using the webkitSetPresentationMode and webkitShowPlaybackTargetPicker functions. Failing that, there's really no good reason to completely disable the context menu — even YouTube allows you to access that by right-clicking twice on the video element.

@chance_s said:

@caramelpolice: @gwil: A work around for now is to load the site in the Helium app. It is a floating video player and you can fill screen.

If you don't want to fire up an external app and you're a premium member, you can also just hit "download" to open a raw .mp4 file; you can then right-click on the video element as before to access PiP and Airplay. This'll progressively download the video, though, so keep that in mind if you're tight on bandwidth.

Avatar image for admiralkong
#33 Edited by AdmiralKong (3 posts) -

Every video I play in the new player shows the loading animation over the video the whole time it's playing. Makes the thing kind of unusable. Same thing happened in the beta version. I'm on Safari 10.0.1 (12602.2.14.0.7) on a Mac. I also have uBlock origin installed but as a premium member that shouldn't matter, right?

Edit: Disabled uBlock Origin for GiantBomb and the issue went away.

Avatar image for chance_s
#34 Posted by Chance_S (154 posts) -
Avatar image for stesmithy83
#35 Posted by stesmithy83 (7 posts) -

Playing videos on chromecast it seems to stutter alot

Avatar image for crazycraven
#36 Posted by CrazyCraven (230 posts) -

No chromecast on live videos? (Podcast/ UPF etc.)

Avatar image for nihilisticmonkey
#37 Posted by nihilisticmonkey (106 posts) -

Subscriber since day 1. Utterly disappointed at the lack of PiP support in OSX Sierra after mentioning it in the Beta.

Looks like it's not going to be resolved as well?

Avatar image for wcarle
#38 Posted by wcarle (314 posts) -

No chromecast on live videos? (Podcast/ UPF etc.)

Not yet, new player isn't out for livestreams yet, look for it either later this week or next!

Playing videos on chromecast it seems to stutter alot

All we do for chromecast is provide the video file and chromecast is in charge of playing it, if it's stuttering it may be a problem with your chromecast... or with the video encode...

Every video I play in the new player shows the loading animation over the video the whole time it's playing. Makes the thing kind of unusable. Same thing happened in the beta version. I'm on Safari 10.0.1 (12602.2.14.0.7) on a Mac. I also have uBlock origin installed but as a premium member that shouldn't matter, right?

Edit: Disabled uBlock Origin for GiantBomb and the issue went away.

Yeah adblockers can cause some headaches.. we're slowly eliminating these bugs but it so hard to test all the different browser extensions :(

Staff
Avatar image for wcarle
#39 Posted by wcarle (314 posts) -

Subscriber since day 1. Utterly disappointed at the lack of PiP support in OSX Sierra after mentioning it in the Beta.

Looks like it's not going to be resolved as well?

Working on this one, it's just the context menu being hidden. I'll see what I can do

Staff
Avatar image for wcarle
#40 Posted by wcarle (314 posts) -

Forgive me if you're already aware of this, since you have a fix in store for fullscreen video getting cut off in some browsers, but I've been having a related issue with videos being cut off at the bottom when using "fill browser".

This should be fixed now... *fingers crossed*

Staff
Avatar image for anobix
#41 Posted by Anobix (54 posts) -

I had posted this in the beta stickied thread, but will copy it into here in case this is the new thread to follow --

Stuck with loading video as well Windows 10 Chrome browser (latest version). Tried w/ and w/o uBlock Origin enabled.

edit: tested with Edge as well, same thing.

Avatar image for wcarle
#42 Posted by wcarle (314 posts) -

@anobix: Can you open the error console and take a screenshot? I'm not able to reproduce this at all

Staff
Avatar image for nihilisticmonkey
#43 Posted by nihilisticmonkey (106 posts) -

@wcarle: Ah, I thought as it wasn't mentioned in the 'known issues' it was a no-go. I will love you forever if this comes back.

Avatar image for madman356647
#44 Posted by madman356647 (801 posts) -

The Chromecast support is awesome!

Avatar image for stordoff
#45 Posted by stordoff (910 posts) -
Go to beginning of videoHome

Is there anyway to disable this specific shortcut, either in browser (Chrome) or in the GB player? I often scan through the comments if I'm watching a video I've seen before, then hit Home to get back to the video player, so having it skip to the beginning of the video is rather annoying (it's the main reason I typically avoided the YouTube option on the old player, because it had the same behaviour).

Avatar image for idkicarus
#46 Posted by idkicarus (53 posts) -

@wcarle: Yeah, it's fixed for me now. You guys are magicians!

Avatar image for flasaltine
#47 Posted by flasaltine (2497 posts) -

The design is still bad. Looks gaudy.

Avatar image for gwil
#48 Posted by gwil (5 posts) -

@chance_s said:

@caramelpolice: @gwil: A work around for now is to load the site in the Helium app. It is a floating video player and you can fill screen.

Yeah, Helium was my gateway drug into this picture-in-picture business. It's great, but having it at at system level…

@caramelpolice said:

Safari for Mac user here. The previous HTML5 player allowed you to right-click to activate macOS Sierra's picture-in-picture mode so I can watch GB videos and do other things at the same time, and allowed for AirPlay. The new one does not appear to support either, in part because the new player has its own right-click menu. Would love to see support for these features just as there is a Google Cast button.

@gwil said:

Another Safari user who’s now sorely missing picture-in-picture support the old video player used to have. Just need to be able to right click the video element.

Yep, I flagged this in the original bug reporting thread and it wasn't followed up on so I'm not holding my breath. It's a shame, because unless they're doing some really weird JS stuff it would be almost trivial to explicitly support PiP and Airplay using the webkitSetPresentationMode and webkitShowPlaybackTargetPicker functions. Failing that, there's really no good reason to completely disable the context menu — even YouTube allows you to access that by right-clicking twice on the video element.

@chance_s said:

@caramelpolice: @gwil: A work around for now is to load the site in the Helium app. It is a floating video player and you can fill screen.

If you don't want to fire up an external app and you're a premium member, you can also just hit "download" to open a raw .mp4 file; you can then right-click on the video element as before to access PiP and Airplay. This'll progressively download the video, though, so keep that in mind if you're tight on bandwidth.

The download method is a nice workaround for now, thanks!

@wcarle said:
@nihilisticmonkey said:

Subscriber since day 1. Utterly disappointed at the lack of PiP support in OSX Sierra after mentioning it in the Beta.

Looks like it's not going to be resolved as well?

Working on this one, it's just the context menu being hidden. I'll see what I can do

Thank you very much :)

Avatar image for robatw
#49 Posted by robatw (56 posts) -

Player works fine for me. I am no design expert but this player looks hideous. It is visually not on par with rest of the page. Please.

Avatar image for onekillwonder_
#50 Posted by OneKillWonder_ (2422 posts) -

I'm having the same problem I had in the beta. Every 10 seconds or so, the video will buffer for a half-second, then skip the video ahead about a second. It makes everything borderline unwatchable.