New video player rolling out today

  • 131 results
  • 1
  • 2
  • 3
Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

Hey there is a new video player rolling out. For the most part most of you should just be seeing the YT embeds on the site but if there are any issues with Premium videos, please let me know in this thread. One thing is that the Play Next Video functionality will probably break with this rollout but we'll find out together!

Avatar image for ydross
Ydross

164

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Maybe im missing something but there does not seem to have the old "auto resume to where you were" if you reload the page :(

Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

@ydross said:

Maybe im missing something but there does not seem to have the old "auto resume to where you were" if you reload the page :(

Hmm I'll have to check on that one.

Avatar image for paul_tillich
Paul_Tillich

358

Forum Posts

40

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Wow this is unfortunate. The GB player will be missed. Fill to browser, as opposed to full screen, was a game-changer for me and how I could watch content while doing other easy tasks I needed to work on during the day. If the previously noted auto-resume is indeed gone, I can live with that, but if the progress bars don't fill up upon finishing a video, I am screwed. That seems to be the case based upon my first finished video. When viewing the videos page, the red completion bars under videos is how I kept track of my backlog of videos (like podcast episodes in podcast apps being marked listened to or not). To be clear, I still see the progress bar for old videos right now. But that vanishing on old videos and the progress bar apparently being a non-feature on the new player is a big issue for at least myself.

Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

@paul_tillich: I'm looking into what it will take to restore all that! Engineers are aware, we'll see what we can do.

Avatar image for superslidetail
superslidetail

756

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 7

Yea, the completion bar is a biggy. We lost all of the status' for every watched video during the last site re-design and never got them back. Hopefully they won't go away too. Other than that I am fine with this lol.

Avatar image for isjelly
isjelly

2

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

I don't know if it's just me, but I can't seem to cast videos to a chromecast device any more

Avatar image for brian_
brian_

1251

Forum Posts

12560

Wiki Points

0

Followers

Reviews: 0

User Lists: 4

Seems like the videos with the new player are on auto-mute when I start them. Is that an intentional thing?

Avatar image for paul_tillich
Paul_Tillich

358

Forum Posts

40

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@rorie: Thank you. I'm sure you get a lot of crap flung your way, especially amid transitions, so I just want to give you a thank you, and I appreciate that this in on the radar.

Avatar image for frozenpixel
frozenpixel

48

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Doesn't seem to be a way to switch back to the Youtube player from the new GB player. Had to delete cookies/cache.

Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

Avatar image for antime
antime

303

Forum Posts

82

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Is this related to the download file names now just being random strings of letters and numbers?

Avatar image for unclejam23
UncleJam23

344

Forum Posts

40

Wiki Points

0

Followers

Reviews: 1

User Lists: 0

#13  Edited By UncleJam23

Hey @rorie, so the fact that it doesn't always resume from where you were has already been reported. Sometimes if I'm away from the tab for a while, it stays where I paused it. Sometimes, however, when I return to the tab, it goes back the start screen and when I play the video again, it restarts from the beginning. I also have to click a "Play Sound" button despite the fact that it's already playing sound. All it seems to do is make the button go away.

NOTE: I have premium, and I'm trying all this out with the new Demo Derby. I have another tab open with "Demo Derby: PlayStation Underground: Volume 3 Issue 3" and that still shows up in the old player.

Avatar image for blitzfitness
blitzfitness

288

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

I'm also experiencing the click to play sound button on the videos I have played this morning.

Avatar image for babymrbob
babymrbob

2

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@isjelly: AirPlay isn’t working anymore either

Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

@antime: I do not know but I will ask!

Avatar image for windex
Windex

110

Forum Posts

74

Wiki Points

0

Followers

Reviews: 0

User Lists: 3

Hey @rorie, thanks for your help investigating issues from this change!

I found another one unfortunately. It looks like this upgrade coincided with a change in the video file hosting location and the video RSS feeds are broken.

e.g. https://www.giantbomb.com/videos/feed/mobile/?api_key=REDACTED-SECRET-KEY

Grubber Lang's Punch-Out!! 03 was the last working video with the URL in the RSS of:

<enclosure url="https://giantbomb.redvideo.io/2023/02/01/2ded6ec7-407e-4a27-94a2-44f79d413667/vf_grubberlang_020123_920_360h700k.mp4?api_key=REDACTED-SECRET-KEY" type="video/mp4" length="0"/>

Game Mess Mornings 02/01/23 and all videos posted afterwards have a new host and are rejecting (403 Forbidden) download requests:

<enclosure url="https://cdn.jwplayer.com/videos/7mEow2YV-rwwcgS4K.mp4?api_key=REDACTED-SECRET-KEY" type="video/mp4" length="0"/>

If you need other info, I am happy to provide.

Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

@windex said:

Hey @rorie, thanks for your help investigating issues from this change!

I found another one unfortunately. It looks like this upgrade coincided with a change in the video file hosting location and the video RSS feeds are broken.

e.g. https://www.giantbomb.com/videos/feed/mobile/?api_key=REDACTED-SECRET-KEY

Grubber Lang's Punch-Out!! 03 was the last working video with the URL in the RSS of:

<enclosure url="https://giantbomb.redvideo.io/2023/02/01/2ded6ec7-407e-4a27-94a2-44f79d413667/vf_grubberlang_020123_920_360h700k.mp4?api_key=REDACTED-SECRET-KEY" type="video/mp4" length="0"/>

Game Mess Mornings 02/01/23 and all videos posted afterwards have a new host and are rejecting (403 Forbidden) download requests:

<enclosure url="https://cdn.jwplayer.com/videos/7mEow2YV-rwwcgS4K.mp4?api_key=REDACTED-SECRET-KEY" type="video/mp4" length="0"/>

If you need other info, I am happy to provide.

Thanks that's not good! I will let the engineers know.

Avatar image for paradigmdream
paradigmdream

84

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#19  Edited By paradigmdream

couple annoyances i've noticed with the new player. these may have been addressed somewhere but i just wanted to throw this out there anyway. let me know if i can clarify anything further.

-every video seems to be muted by default

-if i press the pause/play button on my keyboard, it doesn't pause the video thats playing but instead starts playing the same video i guess layered underneath the video that is visible resulting in the same video playing twice. i hope that makes sense. i tried this on other sites and its working fine everywhere else.

-played videos aren't being tracked on the videos page. makes it a little harder to keep track of what i haven't watched.

-videos no longer resume where i left off which has become a bigger issue with the double playing i mentioned above. i have to refresh the page when that happens and then try to figure out where i was

Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

@rorie said:
@windex said:

Hey @rorie, thanks for your help investigating issues from this change!

I found another one unfortunately. It looks like this upgrade coincided with a change in the video file hosting location and the video RSS feeds are broken.

e.g. https://www.giantbomb.com/videos/feed/mobile/?api_key=REDACTED-SECRET-KEY

Grubber Lang's Punch-Out!! 03 was the last working video with the URL in the RSS of:

<enclosure url="https://giantbomb.redvideo.io/2023/02/01/2ded6ec7-407e-4a27-94a2-44f79d413667/vf_grubberlang_020123_920_360h700k.mp4?api_key=REDACTED-SECRET-KEY" type="video/mp4" length="0"/>

Game Mess Mornings 02/01/23 and all videos posted afterwards have a new host and are rejecting (403 Forbidden) download requests:

<enclosure url="https://cdn.jwplayer.com/videos/7mEow2YV-rwwcgS4K.mp4?api_key=REDACTED-SECRET-KEY" type="video/mp4" length="0"/>

If you need other info, I am happy to provide.

Thanks that's not good! I will let the engineers know.

It looks like there is a fix for this but may take until Monday to roll out. Sorry for the trouble but thanks for the report!

Avatar image for jester1390
jester1390

1

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Ever since the introduction of the new player idk of effecting the app on Apple TV. Apple TV won’t play any new videos. I’ve tried it on all 3 TVs. I don’t think it’s on my end because the games mess morning and punch out 3 work from before the change was made.

Avatar image for sleinmcawesome
SleinMcAwesome

97

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#23  Edited By SleinMcAwesome

Any chance we'll get the Embiggen/Full Window options back? So where it fills the complete browser window with the video, but not goes fully fullscreen like with the Fullscreen option? Seems to be missing in the new player.

Avatar image for hack1501
hack1501

81

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Another issue I've noticed on top of what other have mentioned, is the controls at the bottom often stay visible and do not hide themselves after a few seconds as they should. I am seeing this happen in Firefox.

Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

Any chance we'll get the Embiggen/Full Window options back? So where it fills the complete browser window with the video, but not goes fully fullscreen like with the Fullscreen option? Seems to be missing in the new player.

I think this should be doable but it's in the hands of the engineers right now!

Avatar image for windex
Windex

110

Forum Posts

74

Wiki Points

0

Followers

Reviews: 0

User Lists: 3

Ever since the introduction of the new player idk of effecting the app on Apple TV. Apple TV won’t play any new videos. I’ve tried it on all 3 TVs. I don’t think it’s on my end because the games mess morning and punch out 3 work from before the change was made.

Assuming the Apple TV App pulls from the same RSS feeds I reference above, then the potential fix coming Monday should address this too!

@rorie said:

It looks like there is a fix for this but may take until Monday to roll out. Sorry for the trouble but thanks for the report!

Avatar image for dragmagpuff
dragmagpuff

5

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#27  Edited By dragmagpuff

It appears that the video player time tracker can't fit the longer times right where part of the time wraps onto a new line. Something like below.

03:45 / 01:45

:34

Avatar image for cybexx
Cybexx

1697

Forum Posts

1458

Wiki Points

0

Followers

Reviews: 1

User Lists: 9

I think I'm just seeing the same stuff everyone else is seeing. Resume doesn't work, doesn't list the video in Continue Watching. Videos are muted at the start. No option to switch to YouTube. Time code text wraps if the browser window is past a certain size.

This is my experience with Chrome on Windows anyway. I'll probably just use YouTube right now since video resume is pretty important to me.

Avatar image for sleinmcawesome
SleinMcAwesome

97

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@rorie: Thanks, I hope they will add it. Those options were a big reason why I liked the "old" player, the video automatically fitting to the browser window makes it a great way to resize it and move it around anywhere on the screen I want without having to download the video. :)

Avatar image for avioto
Avioto

513

Forum Posts

39

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

I am curious why there is a new player? Really liked the old one.

I have the same issues as everyone else and the overlay never goes away in fullscreen.

Avatar image for genessee
Genessee

1228

Forum Posts

78

Wiki Points

0

Followers

Reviews: 0

User Lists: 13

The new player is awesome (mainly cuz it doesnt fart out for weeks at a time on my desktop).

Top work from top men.

Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

@avioto said:

I am curious why there is a new player? Really liked the old one.

I have the same issues as everyone else and the overlay never goes away in fullscreen.

I believe this is a Fandom-wide player for all sites going forward. RV and CBS before them had their own video players that they liked to use across all properties, so it's not uncommon for this to happen. Just have to try and make sure that we don't lose too much GB-specific functionality in the process.

Avatar image for daltimond
daltimond

328

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#34  Edited By daltimond

Might have been said, but the video defaults to muted. If you hit the volume button to unmute it, the "play sound" notification stays at the top left of the video. It still goes away once you click it. Minor thing I'm sure but I figured I'd say it.

Avatar image for superaven
superaven

38

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@rorie: Plus one for "Fill to browser" function. TY

Avatar image for sonof64
sonof64

9

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

+1 for the loss of the following: resume at last point watched, no fitting to the browser window, and loading videos muted.

Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

Hey I believe the issues with the RSS feeds should be resolved but please let me know if it isn't!

Avatar image for aizo
Aizo

22

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

A bunch of recent videos aren’t showing up in the ‘latest’ feed or in their respective show feeds for me. For instance the latest Voicemail Dump Truck and the Future Port ‘82 Quick Look don’t show up on the site, but are available on YouTube. Is this related to the new video player too somehow or is something different going on?

Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

#41  Edited By rorie

@aizo: Hmm this showed up for me in the VMDT feed:

https://www.giantbomb.com/shows/55/2970-22121/free-video

But let me check on the Future Port vid.

(Checked the Future Port vid and it looks like it didn't publish correctly but should be live now.)

Avatar image for rorie
rorie

7887

Forum Posts

1502

Wiki Points

0

Followers

Reviews: 4

User Lists: 3

Avatar image for bigsteve33
bigsteve33

80

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 9

#45  Edited By bigsteve33

(sent a report on the video player)

Latest Giantbombcast video is not working. When I press the play button nothing happens. I refresh the page and then the play button gives me a never ending "loading circle". Now, if I hit Download, I just get Processing... under the Download button. (this is new). All browsers Windows 11. Also Ipad Chrome browser. This was the case for both Premium Video and Free Video. then after 10:35pm EST the Free Video started to work (after page refresh). Video works fine on YouTube and Twitch. - <<Technical section.>>

{Kinda a major bummer that I've got to go off site to view GB content. Seems SUS that corp overlords are trying to save on hosting costs which I could understand if it wasn't for the whole premium membership thing that's supposed to cover stuff like that and I dunno.. keeping people employed. So much hate for Fandumb.} - <<Cranky old man section.>>

Thanks Rorie, Much love to you. Frustration/venom for your corporation.

Avatar image for bardalien
Bardalien

40

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Hoping this doesn't ruin video bomb or the LG app...

Avatar image for nophilip
nophilip

814

Forum Posts

18

Wiki Points

0

Followers

Reviews: 0

User Lists: 21

Avatar image for evanfavreau
EvanFavreau

90

Forum Posts

234

Wiki Points

0

Followers

Reviews: 6

User Lists: 6

The new video player not having an option for Airplay on iOS is a real bummer. I can still do it from the download file, but is this something that will be fixed?

Avatar image for aizo
Aizo

22

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

@rorie: That seems to have fixed it. Thank you!

Avatar image for alpha_bit
alpha_bit

128

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Hey @rorie thanks for working with the community on this! Curious as to the progress of being able to "continue where left off" is at?

No Caption Provided

Also, layout is a tad wonky on w11/10, the time display is slightly weird, like the image

Thanks again for your help! I'm sure there's a bunch to consider right now.