• 119 results
  • 1
  • 2
  • 3
Avatar image for scottthepilgrim
#1 Posted by ScottThePilgrim (4 posts) -

Yo yo! (@rorie seems to be the one to tag here)

Seems I payed for a monthly subscription (with a card, not through PayPal) and - after refreshing page, logging out and in, and quitting and restarting Chrome - I'm not being recognized as a member. I got the key in the email and everything, and when I go to my account it shows my subscription key. Any idea what's going on?

Thanks a bunch! Stoked to be a subscriber! Now to catch up on some videos on my day off...

Avatar image for rorie
#2 Posted by Rorie (5615 posts) -

@scottthepilgrim: Hey there,

Sorry to hear about that. Sometimes the system just needs a kick in the pants. I manually updated you and saved your account, so you should be good to go. Thanks for being a subscriber!

Staff
Avatar image for scottthepilgrim
#3 Posted by ScottThePilgrim (4 posts) -

No worries, dude! Thanks a bunch!

Avatar image for quasigoodandy
#4 Edited by quasigoodandy (24 posts) -

I'm having the same problem. Subscribed through the site, not paypal. Tried logging out and clearing browser cache. Still no access to premium videos :/

Avatar image for rorie
#5 Posted by Rorie (5615 posts) -

@quasigoodandy: Is that still happening to you? It looks like you have the plaque now.

Staff
Avatar image for thunderslash
#6 Posted by ThunderSlash (2605 posts) -

@rorie: Is this problem being worked on by the engineering team? Or is it just some inherent side effect to how the payment system is hooked up?

Avatar image for rorie
#7 Posted by Rorie (5615 posts) -

@thunderslash: We're moving to a new payment processor in the next few weeks, so I'll probably just handle any issues manually until that's done. I'm sure the new system will have its own suite of bugs but it'll probably obviate any current bugs when the hookup for that is finally complete.

Staff
Avatar image for hcaryan
#8 Posted by HCARyan (69 posts) -

I'm having this problem too. Just subscribed to premium and I don't have any premium access.

Avatar image for nicknacknob
#9 Posted by nicknacknob (12 posts) -

I just subscribed as well and need a manual update please :)

Avatar image for hcaryan
#10 Posted by HCARyan (69 posts) -

Ha, did you subscribe to see Dan Ryckert play world of warcraft? I'm figuring that's got to be worth something.

Avatar image for hcaryan
#11 Posted by HCARyan (69 posts) -

Interesting. I used the promo code that was emailed me and it looks like my account upgraded. So that might be a workaround.

Avatar image for rorie
#12 Posted by Rorie (5615 posts) -

@nicknacknob: Hmm, I'm trying to save your account but I'm not sure that it's working. Try logging out and logging back in and see if that unlocks the premium stuff for you.

Staff
Avatar image for nicknacknob
#13 Posted by nicknacknob (12 posts) -

@hcaryan: yasss hahaha I really want to see how he will react!

@rorie: ah I just did and it works! I should have done that from the beginning haha. thank you!

Avatar image for stabbymcknife
#14 Edited by StabbyMcKnife (16 posts) -

Guess I'm not alone, I figured it would just take a few days but I subscribed and don't have any premium access yet either.

E: subscribed through the site, not PayPal. Dunno if I need to tag @rorie on this or not, new to the forums.

Avatar image for deathfyre13
#15 Posted by deathfyre13 (3 posts) -

I'm having the same issue. Would appreciate the manual magic.

Avatar image for rorie
#16 Posted by Rorie (5615 posts) -

@deathfyre13: Sorry about that! Try logging out and back in if it doesn't appear shortly.

Staff
Avatar image for magmaros
#17 Posted by Magmaros (7 posts) -

Hey Rorie, would you be able to check on mine, still hasn't updated yet

Avatar image for tall_guy
#18 Edited by Tall_Guy (27 posts) -

I, too, am having this issue. Please switch me over when you can. Sorry for the inconvenience!

e: Nevermind - for some reason, it fixed itself.

Avatar image for leej
#19 Posted by LeeJ (21 posts) -

@rorie: Can you check up on my account as well? I'm having the same issue as OP. Thanks!

Avatar image for rorie
#20 Posted by Rorie (5615 posts) -

@leej: Sorry duder! Should be hooked up now.

Staff
Avatar image for akere
#21 Posted by Akere (5 posts) -

I'm having the same problem wanted to support Dan and his transfer over to GB but can't watch him torment people with Mario Party.

Avatar image for rorie
#22 Posted by Rorie (5615 posts) -

@akere: Try watching now! Or logging out and back in if it's still not working.

Staff
Avatar image for akere
#23 Posted by Akere (5 posts) -
Avatar image for grantheaslip
#24 Posted by GrantHeaslip (1869 posts) -

I might be running into the same problem here: I'm suddenly a free member, and my billing history is empty. It's very possible that my subscription ran out, but I want to be sure of that. Thanks!

Avatar image for adn89
#25 Posted by ADN89 (2 posts) -

@rorie Count me in as another who has this issue. Subscription key and billing history are all good but I can't access premium content.

Avatar image for freedom35
#26 Posted by Freedom35 (2 posts) -

I'm having this issue as well. I paid for premium, but can't watch the videos.

Avatar image for laika
#27 Posted by laika (148 posts) -

@adn89 said:

@rorie Count me in as another who has this issue. Subscription key and billing history are all good but I can't access premium content.

I'm having this issue as well. I paid for premium, but can't watch the videos.

You guys should have access now. A real fix for this is in the works.

Avatar image for chromo89
#28 Posted by chromo89 (22 posts) -

Same problem, just re-subscribed and logging out didnt fix anything.

Avatar image for capnqwark
#29 Posted by CapnQwark (15 posts) -

Hey Rorie, it happened to me now too. Just re-subbed after ending my subscription in April, but so far no dice on the premium access.

Avatar image for tylambert86
#30 Posted by tylambert86 (67 posts) -

I just subscribed and can't get it to work either :(

Avatar image for chromo89
#31 Posted by chromo89 (22 posts) -

all good here now, thanks!

Avatar image for rorie
#32 Posted by Rorie (5615 posts) -
Staff
Avatar image for reallionheart
#33 Posted by RealLionheart (10 posts) -

Hey @rorie, you mind checking mine out when you get the chance? Same issue, signed up an hour ago and tried the log-out/log-in feature. My billing info shows I'm a subscriber but still get all the locks :( I desperately need to see that Mario Party video... Thx man!

Avatar image for rorie
#34 Posted by Rorie (5615 posts) -
Staff
Avatar image for capnqwark
#35 Posted by CapnQwark (15 posts) -

Awesome, thanks.

Avatar image for mjbrune
#36 Edited by mjbrune (175 posts) -

@rorie I wanted to just tack on to this thread but it's kind of the exact opposite problem. I let my subscription lapse for about a week without knowing it because I still had full access to the awesome premium content (Not to say other content is less awesome there is just more awesome available to view). I remembered getting an email warning about renewing and checked my renewal date. I somehow was watching premium content without renewing. I've renewed now so I can't provide you guys a repro but I wonder if somehow I got a bug with my account.

Avatar image for rorie
#37 Posted by Rorie (5615 posts) -

@mjbrune said:

@rorie I wanted to just tack on to this thread but it's kind of the exact opposite problem. I let my subscription lapse for about a week without knowing it because I still had full access to the awesome premium content (Not to say other content is less awesome there is just more awesome available to view). I remembered getting an email warning about renewing and checked my renewal date. I somehow was watching premium content without renewing. I've renewed now so I can't provide you guys a repro but I wonder if somehow I got a bug with my account.

There's a bit of a grace period at the end of a subscription period just in case someone's card is declined and they have to update it. It's around a week.

Staff
Avatar image for bondbill2k2
#38 Posted by bondbill2k2 (10 posts) -

Same issue here settings page hows my account as monthly premium but videos say I need a premium membership still. Love the random looking premium content thats been getting even more frequent since Dan joined so decided to try monthly out, if Its good I'll be going for an annual subscription

Avatar image for j_boy
#39 Edited by j_boy (16 posts) -

Hey I'm having the same issue as the original poster. Paid via card, got the acceptance email, but no access to premium stuff yet. I appreciate the system might just take a few days to recognise me but if I could get a manual update that would be great. Eager to see the stuff I've been missing.

Avatar image for arjailer
#40 Edited by Arjailer (146 posts) -

Same here - account page shows as Premium Monthly with a subscription key, but still getting "this video is only available to subscribers" :-(

Used a card, not Paypal, and logged out and back in with no luck.

Admittedly I only subscribed about 10 minutes ago - maybe I'm just too used to most things being instant on the web these days :-)

Avatar image for lennoxxx
#41 Posted by lennoxxx (29 posts) -

I am experiencing this exact problem at the moment!

Any help would be super-duper!

Avatar image for chewok411
#42 Posted by Chewok411 (2 posts) -

I'm having the same problem. Please help thanks.

Avatar image for rorie
#43 Posted by Rorie (5615 posts) -

@chewok411: Hey, I'll flip you on in a bit. Have you ever subscribed in the past?

Staff
Avatar image for icyeyes
#44 Edited by IcyEyes (608 posts) -

A few troubleshooting ideas:

  1. Insure your payment has been processed. You should receive an email once this happens.
  2. Sign out, clear browser cache, close and reopen your browser and then sign back in to Giantbomb.
  3. Check your account status by going to "Billing" under account options. It should say "Premium Monthly / Yearly"
  4. If you don't receive an email about payment or see a change in your account status then email support.
Avatar image for narwhalnoel
#45 Posted by NarwhalNoel (2 posts) -

Hello, I'm a new subscriber as well and I am unable to access premium content. Whenever I try to click the subscriber videos it says I need to upgrade my account when I already did. I really enjoy Giant Bomb and look forward to watching your videos. Thanks so much!

Avatar image for andy853
#46 Posted by andy853 (10 posts) -

Im having the same problem if i can get some help please???

Avatar image for laika
#47 Posted by laika (148 posts) -

@andy853 said:

Im having the same problem if i can get some help please???

You should be set now. Sorry for the trouble.

Avatar image for spk6543
#48 Edited by spk6543 (3 posts) -

@laika:

I just signed up with the PAX deal. No premium for me yet either... Should I be doing something with this key code?

Avatar image for laika
#49 Posted by laika (148 posts) -

@spk6543 said:

@laika:

I just signed up with the PAX deal. No premium for me yet either... Should I be doing something with this key code?

The issue is on our end, sorry. Should be set now.