Premium Podcast feed not working in itunes *SOLVED*

Avatar image for sniffulls
Sniffulls

197

Forum Posts

376

Wiki Points

0

Followers

Reviews: 9

User Lists: 11

#1  Edited By Sniffulls

I tried to get the premium podcast feed to work in itunes and it keeps saying that I didn't provide the correct username or password. I'm assuming I should use my email because that's what I use to log into the site and I know I'm putting in my password correctly. I even changed my password to something super simple to make sure I didn't type it in incorrectly and no dice. I would love to start listening to some of the premium feeds.

EDIT: For anyone that needs to know. You should use your username, not your email for the username/password combination.

Avatar image for devil240z
Devil240Z

5704

Forum Posts

247

Wiki Points

0

Followers

Reviews: 0

User Lists: 2

I continually have issues with the premium feed in itunes.

Will it allow you to download anything from the feed?

Avatar image for sniffulls
Sniffulls

197

Forum Posts

376

Wiki Points

0

Followers

Reviews: 9

User Lists: 11

@devil240z: I can't even get it to recognize my username and password combination.

Avatar image for mendelson9
Mendelson9

572

Forum Posts

175

Wiki Points

0

Followers

Reviews: 0

User Lists: 5

I think you need to use your username and not your email address, but i've always had problems with iTunes and premium podcasts. Try adding your Username and Password in the URL. For instance...

http://USERNAME:PASSWORD@www.giantbomb.com/videos/feed/hd/7/

...should let you subscribe to all Quick Looks in HD. Works for me in Pocket Casts.

Avatar image for sniffulls
Sniffulls

197

Forum Posts

376

Wiki Points

0

Followers

Reviews: 9

User Lists: 11

@mendelson9: That seems to do the trick. Thanks for the info.

Avatar image for keala
keala

15

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#6  Edited By keala
Avatar image for ripmurdock
RipMurdock

71

Forum Posts

103

Wiki Points

0

Followers

Reviews: 0

User Lists: 2

Duders! I can confirm that you need to use your sitename, not your email. This is what worked for me: http://username:password@www.giantbomb.com/podcast-xml/premiumbombcast/